2 cisco 876 with 2 ISP config pbr to allow smtp from isp 1 and www fro

Unanswered Question
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Sat, 05/26/2007 - 08:43
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Yes, it's definitely possible.

bjornarsb Mon, 05/28/2007 - 06:43
User Badges:
  • Bronze, 100 points or more

Hi,


It's possible , however your smtp server then have to be configured with an ip from isp 1 ,and server traffic to isp 2 must come from a server configured with an ip in the scope "owned" by isp 2..


For servers that do not need to be reached initiating communication from Internet,

you just have to set up NAT overloading.


BR,

Bjornarsb

I do the following config on the first cisco

But seems something going wrong

sho run

Building configuration...


Current configuration : 4934 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname yourname

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

!

no aaa new-model

!

resource policy

!

ip cef

!

!

no ip domain lookup

ip domain name yourdomain.com

!

!


!

!

!

!

interface BRI0

no ip address

encapsulation hdlc

shutdown

!

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

no snmp trap link-status

pvc 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

switchport access vlan 2

!

interface Dot11Radio0

no ip address

shutdown

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$

ip address 62.xxx.38.17 255.255.255.240

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

!

interface Vlan2

ip address 194.xxx.21.45 255.255.255.240

ip nat outside

ip virtual-reassembly

ip policy route-map forthnet

!

interface Dialer0

ip address negotiated

ip virtual-reassembly

encapsulation ppp

ip policy route-map otenet

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname [email protected]

ppp chap password 0 megadis1

ppp pap sent-username [email protected] password 0 megadis1

!

ip route 0.0.0.0 0.0.0.0 Dialer0

ip route 0.0.0.0 0.0.0.0 194.xxx.21.33

!

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 5 life 86400 requests 10000

ip nat inside source route-map forthnet interface Vlan2 overload

!

access-list 101 permit tcp any eq smtp any

access-list 102 permit tcp any eq www any

dialer-list 1 protocol ip permit

no cdp run

!

!

route-map otenet permit 10

match ip address 101

set interface Dialer0

!

route-map forthnet permit 10

match ip address 102

set ip next-hop 194.xxx.21.33

!

!


the second router is conected on port fa03 of the main and do routing with real ip from the second provider


bjornarsb Tue, 05/29/2007 - 02:56
User Badges:
  • Bronze, 100 points or more

Hi !


Nice going , you just need to change:

access-list 102 permit tcp any eq www any

to

access-list 102 permit tcp any any eq www


BR,

Bjornarsb

bjornarsb Tue, 05/29/2007 - 04:36
User Badges:
  • Bronze, 100 points or more

Hi,


If vlan1 is ISP 1 and vlan2 is ISP 2 it should work.


You should not use same adm distance for your default gateways:

!

ip route 0.0.0.0 0.0.0.0 Dialer0

ip route 0.0.0.0 0.0.0.0 194.xxx.21.33

!

Use

!

ip route 0.0.0.0 0.0.0.0 Dialer0

ip route 0.0.0.0 0.0.0.0 194.xxx.21.33 222

!





Post a sh ip nat translations.


BR,

Bjornarsb

i fix the roure

but the same all the trafic do to dialer 0


in the sh ip nat translation


i did not see any thing is blank

the sh ip nat stat.. is


yourname#sho ip nat statistics

Total active translations: 0 (0 static, 0 dynamic; 0 extended)

Outside interfaces:

Vlan2

Inside interfaces:

Vlan1

Hits: 38 Misses: 0

CEF Translated packets: 11, CEF Punted packets: 0

Expired translations: 9

Dynamic mappings:

-- Inside Source

[Id: 2] route-map forthnet interface Vlan2 refcount 0

Queued Packets: 0



Actions

This Discussion