interface speed

Unanswered Question
May 25th, 2007

I am connecting a Cisco router to a Cisco MLS. The router interface is fastE, in full-duplex mode. The MLS interface is GigE, in 100Mbps, full-duplex mode. The link on the router fastE came up, but the link on the MLS gigE link is down. Is there something else I should configure?

Both sides are using vlan.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
maskmukesh Fri, 05/25/2007 - 10:17

Hi Sarah

Could you please tell whether u have force the command speed 100 on the MLS. and on router its set to auto.



sarah12345 Fri, 05/25/2007 - 10:32

Yes, the MLS interface is 10/100/1000, and I forced it to 100Mbps.

The router interface is fastE.

MLS config:

interface GigabitEthernet2/11


switchport trunk encapsulation dot1q

switchport trunk allowed vlan 12

switchport mode trunk

no ip address

load-interval 30

speed 100

duplex full

mls qos trust dscp

storm-control broadcast level 30.00


interface Vlan12

ip address ... ...

ip ospf network point-to-point

ip ospf hello-interval 1

ip ospf dead-interval 3

load-interval 30

service-policy output monitor_traffic


Router config:

interface FastEthernet4/1/0

no ip address

load-interval 30



interface FastEthernet4/1/0.12

encapsulation dot1Q 12

ip address ... ...

ip ospf network point-to-point

ip ospf hello-interval 1

ip ospf dead-interval 3

no snmp trap link-status


The strange thing is, the interface on the router is up up, but the interface on the MLS is down down.

If I bounce the interface on the MLS, I see the interface on the router goes down, so they are connected correctly.

maskmukesh Fri, 05/25/2007 - 10:50

Hi Sarah,

set the MLS side also to auto and router is alreasdy auto this way the MLS switch and router will autonegotiate the link speed.



jasonrandolph Fri, 05/25/2007 - 10:55


10/100 Ethernet standard has no duplex negotiation built into it.

Gigabit, however, does.

sarah12345 Fri, 05/25/2007 - 11:03

I configured both sides to be auto/auto, and both links are down. :-( Bounced both interfaces, and still no help. :'(

Maybe 10/100/1000 interface doesn't work well with GigE interface.

jasonrandolph Fri, 05/25/2007 - 11:01

How is it that the router has allowed you to configure duplex without first hard-setting speed? Most Cisco routers will balk at attempting this.

Try adding VLAN1 to the allowed VLANs on the MLS port. VLAN1 is typically the default native VLAN for dot1Q tagging unless you have specified elsewhere in your config.

sarah12345 Fri, 05/25/2007 - 11:17

For GigE interfaces, you have to configure speed to non-auto before configuring duplex mode. For FastE interfaces, you don't have to, since the speed is not configurable. The interface on the router is FastE.

jasonrandolph Fri, 05/25/2007 - 11:24

Speed is configurable on FastEthernet interfaces as it is typically capable of running 10/100 unless it is a fiber link.

jasonrandolph Fri, 05/25/2007 - 11:17

You're also missing your native VLAN on your router...

int FE4/1/0.1

Description Native Dot1Q VLAN

Encapsulation dot1q 1 native

no ip address


This Discussion