Unity msg subject line issue

Unanswered Question
May 25th, 2007

Hi,

We are having some issues on a Unity Installation (UM, ver 4.2.1, Exchange2K3 partner server, all subscribers in one AD domain/Exchange server). When a message is left internally, the subject line says "Message from XXXX" where xxxx is the extension of the caller. It should say "Message from yyyy", where yyyy would be the name of the caller. The Advanced setting in Tools Depot for "subject line - subscriber to subscriber" option is set to "Message from %NAME% (%EXTENSION%)", so you'd expect to see "Message from yyyy (xxxx)", but we're not.

Additionally, when the message is heard over TUI, during the conversation, it doesn't inform who the caller was. Also, the recorded name of one of the users keeps getting deleted on its own. We think all these issues are related. Any ideas? Where should we start looking at this?

Thanks,

Joseph

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Ginger Dillon Fri, 05/25/2007 - 15:33

Hi Joseph -

It may be as simple as making sure the domain controller Unity is pointing to in DC/GC Reconnect tool is also a global catalog server. But you may also want to ensure you don't have Identified subscriber messaging disabled anywhere - check the Configuration Settings page on your Unity SA.

Ginger

jessakhanian Tue, 05/29/2007 - 10:53

Hi Ginger,

All of the servers listed in the DC/GC Reconnect tool are both DC and GC servers. I did some more digging, and it seems like the users who are having the problem are the ones that have the checkbox "Allow inheritable permissions from parent to propagate to this object" turned off (unchecked) in ADUC Security tab. There must be a group policy or something in effect at a higher level because once it's checked, they change back to unchecked after a while.

We're investigaing this further, but I wonder if there is a work-around if we had to leave this box un-checked.

Thanks,

Joseph

Ginger Dillon Tue, 05/29/2007 - 12:50

Hi Joseph -

Good catch! You will not want to leave this box unchecked, otherwise the unitymsgstoresvc account will not have the necessary permissions to access the user's mailbox, which includes Send As permissions.

The same will occur for the unitydirsvc account and you will get errors attempting to import users into Unity.

Ginger

jessakhanian Tue, 05/29/2007 - 13:42

Yes, we noticed that users weren't importing into Unity from AD if the box was un-checked. Certain users had this box turned off and we were able to import them by checking it, but we noticed that later on, the check mark was gone. Some policy higher up must be over-writing it. I am waiting to hear from the network admin guys as to how we can fix this.

Thanks for your input.

Joseph

Ginger Dillon Tue, 05/29/2007 - 14:08

Hi -

On one of your logged on trouble user accounts, you can go to the command line and enter gpresult. This will show the GPOs that are applied. You can also run the Group Policy management console to identify the GPOs that are linked to the OU which holds the user's record. Are these users by any chance members of protected Windows administrative groups? If this is the case, it would be better to create separate admin accts for these users which are not voicemail enabled in Unity (just a thought).

Ginger

Actions

This Discussion