501 open https for external access

Answered Question
May 25th, 2007

Hi,

I have the following setup;

external ip router (internal ip 192.168.128.1) -----> (external ip pix 501 192.168.128.2) -----> (internal ip pix 501 192.168.1.1)

webserver 192.168.1.2

I'm having difficulty accessing the webserver from the internet. I can access it internally on my network.

Here is the acl lists, can anyone poitn out where I'm going wrong, please.

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

name 192.168.128.0 router

name 192.168.1.2 owserver

access-list inside_outbound_nat0_acl permit ip any 192.168.1.192 255.255.255.224

access-list outside_cryptomap_dyn_20 permit ip any 192.168.1.192 255.255.255.224

access-list outside_access_in permit tcp router 255.255.255.0 eq www interface outside eq www

access-list outside_access_in permit tcp router 255.255.255.0 eq https host 192.168.128.2 eq https

global (outside) 1 interface

nat (inside) 0 access-list inside_outbound_nat0_acl

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

static (inside,outside) tcp interface www owserver www netmask 255.255.255.255 0 0

static (inside,outside) tcp 192.168.128.2 https owserver https netmask 255.255.255.255 0 0

access-group outside_access_in in interface outside

Many thanks

Suzanne

I have this problem too.
0 votes
Correct Answer by acomiskey about 9 years 5 months ago

Check your access list and my post above. You can't refer to the destination in the acl as the inside address(192.168.1.2). The destination is the outside interface.

access-list outside_in permit tcp any interface outside eq www

access-list outside_in permit tcp any interface outside eq https

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
acomiskey Fri, 05/25/2007 - 12:41

Use the interface keyword like you did in your other static...

static (inside,outside) tcp interface https owserver https netmask 255.255.255.255 0 0

techsitc10 Fri, 05/25/2007 - 13:20

Hi

Thanks for the prompt response.

Interestingly, I copied the http rule in the pdm to create the https and so not sure why it changed. I will try re-adding it with the interface keyword and let you know.

Thanks again

Suzanne

techsitc10 Fri, 05/25/2007 - 13:21

Actually the http isn't working either!

Any other ideas ?

Thanks again

Suzanne

acomiskey Fri, 05/25/2007 - 14:16

Suzanne,

192.168.128.2 is not routable on the internet. If that is the address you are attempting to hit from the internet, this explains why it is not working. If you unplugged the inside of the router and plugged a computer directly into outside of pix. Assigned the inside address of the router to your computer, then tried to access 192.168.128.2, then it would work. You most likely will need to access your servers by the outside address of your outside router and create the proper translations in the router as well. Is this the case?

techsitc10 Tue, 05/29/2007 - 06:02

Hi

Sorry I should have explained that more fully when I initially posted. There is an external router set up. It has an internal ip address of 192.168.128.1 and has static routes setup to translate through to the static external ip address with a proper internet address on the outside. I just didn't want to publish it unnecessarily.

When I use a computer to connect between the pix and the server it doesn't resolve which is why i think the problem is with the pix and not the router.

Any further help would be appreciated.

Thanks

Suzanne

acomiskey Tue, 05/29/2007 - 06:10

No problems...

I must have overlooked this before. These acl entries are wrong.

access-list outside_access_in permit tcp router 255.255.255.0 eq www interface outside eq www

access-list outside_access_in permit tcp router 255.255.255.0 eq https host 192.168.128.2 eq https

First off, you are limiting the source of the requests to "router" network. I assume you want this to be any instead. Also you have added a source port "router 255.255.255.0 eq https", which the requests would never have. They would be some random port above 1024. So the statements should look like this.

access-list outside_access_in permit tcp any interface outside eq www

access-list outside_access_in permit tcp any interface outside eq https

access-group outside_access_in in interface outside

techsitc10 Fri, 06/08/2007 - 04:44

Hi

Sorry for the delay in the reply lots of things going on at the moment.

I've tried this and got a null rule message.

It still doesn't work.

Anything else I'm missing ?

Thanks

Suzanne

acomiskey Fri, 06/08/2007 - 04:49

Could you post the relevant config so we can see what's going on?

techsitc10 Fri, 06/08/2007 - 04:55

Hi

You're amazingly prompt at replying. i will do, at present I'm at another site so it will be next week now but I'll update then.

Thanks for all your help.

Suzanne

techsitc10 Thu, 06/21/2007 - 12:31

Hi

acomis apologies for the delay

I've added these and this is my current config

Building configuration...

: Saved

:

PIX Version 6.3(5)

interface ethernet0 auto

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password xxx

passwd xxx

hostname pixfirewall

domain-name ciscopix.com

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list outside_in permit icmp any host 192.168.128.2 echo-reply

access-list outside_in permit tcp any host 192.168.1.2 eq www

access-list outside_in permit tcp any host 192.168.1.2 eq https

pager lines 24

mtu outside 1500

mtu inside 1500

ip address outside dhcp setroute

ip address inside 192.168.1.1 255.255.255.0

ip audit info action alarm

ip audit attack action alarm

pdm location 192.168.1.2 255.255.255.255 inside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

static (inside,outside) tcp interface www 192.168.1.2 www netmask 255.255.255.255 0 0

static (inside,outside) tcp interface https 192.168.1.2 https netmask 255.255.255.255 0 0

timeout xlate 0:05:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http 192.168.1.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd address 192.168.1.2-192.168.1.129 inside

dhcpd lease 3600

dhcpd ping_timeout 750

dhcpd auto_config outside

dhcpd enable inside

terminal width 80

Cryptochecksum:xxx

: end

Correct Answer
acomiskey Thu, 06/21/2007 - 12:44

Check your access list and my post above. You can't refer to the destination in the acl as the inside address(192.168.1.2). The destination is the outside interface.

access-list outside_in permit tcp any interface outside eq www

access-list outside_in permit tcp any interface outside eq https

techsitc10 Thu, 06/21/2007 - 13:00

THanks for bearing with me..

I thought that was what I had added, but just re done it and it works fine.

Thanks again for all your help and your extra prompt replies.

Actions

This Discussion