Unanswered Question
May 25th, 2007

This is Unity 4.2.1 with PIMG on Nortel M1.

We have 4 ports configured for MWI only on one of the PIMG units.

Occasionally the bottom PIMG port will go into "TDM out of service" condition for up to 10-15 minutes and then reset itself and come back up.

This is not related to a particular PIMG unit or port (we have moved the MWI ports around). Also we have moved the extension on the M1 side to different card - no change.

The problem is that Unity does not recognize the port being out of service, and keeps pushing out MWI requests to the same port causing MWI failures.

This is frustrating due to the PIMG not putting the port SIP state into busy.

Also Unity does not do round-robin MWI port usage which would minmize the problem it would simply complete the next request on another port.

I believe the constant hammering of MWI requests on this port while in a down state is making the problem worse. I have had other ports do this on PIMG units (call answer only) but they only go out of service for a few seconds and recover.

PIMG code is 5.0.64 - does the latest firmware do anything for this?



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Tommer Catlin Tue, 05/29/2007 - 12:26

You can take a PIMG port out of service in the UTIM. Just uncheck the boxes for that pIMG and Unity should not use that port that is having a problem. There have been issues with PIMGs "dropping" ports and not coming back. YOu basically have to RMA the unit. I would RMA the box and try another one. You could also hit up the Diaglogic Forum and post there to find other answers.

I have also had this work. Basically delete the PIMG, reboot, add it back into the UTIM and try and again. Something with the delete/readding it again sometimes fixes random problems.

I would also activate the SNMP traps on the PIMG. Let it send out the "out of service" traps to your catcher. Possibly you are getting other code messages from it that are signally a bad box.

schonb01 Fri, 06/27/2008 - 12:28


Are you still having this problem? If not, what was the solution? I have a customer with exactly the same issue on an M1 integration, only the port goes out of service for a few seconds. Unity gets an error back and does retry, but I think this may be related to another problem with TRaP calls.



sposte Fri, 06/27/2008 - 18:50


Cisco came out with updated firmware for the PIMG (5.1.70 I think) which killed the MWI problem.

schonb01 Sun, 06/29/2008 - 22:24

Thanks, Scott. Do you remember what update version you downloaded? I believe we are already on a later version (5.1 SU2 was the release). What did Cisco do to fix the problem? We are having literally the exact same thing, although the ports don't go offline for very long, sometimes for < 1 second. Longer outages do occur, and that does cause some MWI failures in the Unity logs. A problem that may be related is that we have cases where TRaP calls (on the same ports as MWI) to Nortel phones occur where the user just hears static. I've moved the TRaP ports to different ports from the MWI ports as a workaround to see if we still have the issue. I figure that the MWI ports are busy enough. The system takes over 6000 calls a day.

ANGUEL STEFANOV Fri, 04/03/2009 - 07:54


Did you find a solution? I have a customer with the same problem - ports going out of service for few seconds while callers hear screaching sound or dead air during that time.

schonb01 Fri, 04/03/2009 - 15:17

We didn't solve it completely but did manage to minimize its occurrence. Here's my notes on the issue. For more info, please email me directly at [email protected] and I'll send you the complete document.

MWI ports will occasionally loose carrier and generate a "TDM Out of Service" alarm message on the PIMGs. It generally happens for up to 2 minutes, and only on MWI ports unless after a night maintenance routine. Research on this states that Cisco/Dialogic addressed an issue in the past whereby ports would go into this state for 10-15 minutes on MWI ports by releasing an updated version of the PIMG firmware (v5.1.70 of the Gateway Application); we are currently running a later release in this configuration. Dialogic suggested that unless we are seeing cases where calls are being lost (dropped) or inbound calls are being constrained by this (this is not occurring), it is probably not something that needs to be worried about (this is reinforced by the fact that, although MWI requests to the port fail while the port is offline, Unity will retry each MWI request 5 times, so unless the port is offline for more than about a minute, the MWI request will be completed eventually [and if not then, during the nightly resync process]). The other thing brought up on the Dialogic forum is that in some of the newer PBX builds, the same set of port tests that get run during a midnight/nightly routine can get run during the day; this can have an impact on ports doing MWI; the problem is that to the PBX, the port looks idle during an MWI request because the phone is left on hook during that action, so the PBX thinks the port can be tested; the tests can collide with MWIs and cause the port to get into a "funny state" that can cause the "TDM Out of Service" alarm. The fact that it only happens on MWI ports reinforces that it could very well be a port test causing this because port tests are only run on idle ports, and incoming ports are never idle during an active call. To help ease the impact of this occasional issue, MWI requests were slowed down by inserting a comma (,) before the MWI extensions in Unity; this causes the PIMGs to pause for 3000 ms before sending the MWI request to the Nortel station port (the amount of time that the PIMGs wait is controlled by the Dial Pause Time parameter in the Gateway Advanced section of the PIMG configuration). The end result is that more MWI requests (including retries) are pushed to the next available port during a brief loss of carrier on an MWI port.


This Discussion