How to disable igmp snooping on a L2 interface, cat6500

Unanswered Question
May 26th, 2007
User Badges:

The following output shows that the catalyst 6500 have snooped the multicast address 0100.5e00.0190 on port gi1/24 and gi2/24.

Question: How do I disable snooping on these L2 interfaces.

SD00#sh mac-address-table multicast igmp-snooping

vlan mac address type learn qos ports


3000 0100.5e00.0190 static Yes - Gi1/24

3001 0100.5e00.0190 static Yes - Gi2/24


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
mohammedmahmoud Sat, 05/26/2007 - 02:59
User Badges:
  • Green, 3000 points or more


By default, IGMP snooping is globally enabled on the switch. When globally enabled or disabled, it is also enabled or disabled in all existing VLAN interfaces. IGMP snooping is by default enabled on all VLANs, but can be enabled and disabled on a per-VLAN basis or globally.

no ip igmp snooping [vlan ]

HTH, please do rate all helpful replies,

Mohammed Mahmoud.

simonvyrdal Sat, 05/26/2007 - 08:07
User Badges:

Hi, Thanks for you answer.

The Cat6500 Version 12.2(18)SXD7b don't have the option [vlan ] to specify the vlan in global config mode. You can disable snooping on a L3 VLAN interface with "no igmp snooping". However, Gi1/24 and gi2/24 are L2 interfaces assigned to vlan 3000 and 3001 respectively.

I also wonder why the multicast entry type is STATIC. No "mac-address-table static ..." entries are configured.

Regards Simon

ankbhasi Sat, 05/26/2007 - 06:44
User Badges:
  • Cisco Employee,

Hi Friend,

Just curious to know the reason why you want to disable IGMP snooping? I believe you understad that if you have this disable your multicast application traffic will be treated like a broadcast and will be sent on all the ports on this switch.

There can be some situations where IGMP snooping disable is a solution but not sure if thats your case.



simonvyrdal Sat, 05/26/2007 - 08:31
User Badges:

Hi Ankur,

To be honest I don't know. The scenario is this:

FWa -- SWa ---- SWb -- FWb (FW=firewall, SW=cat6509)

fwa and swa is connected by vlan3000 on gi1/24 (Primary_FW_Sync) and similarly

fwb and swb is connected by vlan3001 on gi2/24 (Secondary_FW_Sync)

One firewall is supposed to be master and the other slave. I am told that both come up as masters and that this can be repaired by disabling multicast snooping.

Regards Simon


This Discussion