STP Blocking Port

Unanswered Question
May 26th, 2007
User Badges:

I have 2 Cisco 2950G-12-EI, S1&S2 connected with two uplink cable as the other one is redundant.


S1/P11 connected to S2/P11

S1/P12 connected to S2/P12(Blocking State)


How I can enable the S2/P12 to forward state, so that if I have a host connected in S1&S2, I want to Ping from HostA(S1) to Host(S2) or vice versa and I dont want to encounter any timeout even I remove anyone of the uplink cable. Please help me to solve this issue, thanks.



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (3 ratings)
Loading.
ankbhasi Sat, 05/26/2007 - 07:44
User Badges:
  • Cisco Employee,

Hi Mahmoud,


The concept of STP is to block redundant link for loop avoidance. In your setup there is a loop and STP is doing its job blocking redundant port and once your primary link goes down second link which is currently in blocking state will become active but YES that will take its own convergance time and there will be loss of connectivity for few seconds.


WHY don't you configure etherchannel for the 2 links so that both the interfaces will be in fwding state and if any of the link in etherchannel goes down you still have second lin kin that etherchannel to take care of your data traffic.


HTH


Ankur


*Pls rate all helpfull post

bjornarsb Sat, 05/26/2007 - 12:09
User Badges:
  • Bronze, 100 points or more

Hi,


Yes etherchennel is perfect in this scenario like ankbhasi posts.

And its configured like this:

!

interface Port-channel1

switchport trunk native vlan 99

switchport mode trunk

switchport nonegotiate

interface FastEthernet0/1

switchport mode trunk

switchport nonegotiate

no ip address

channel-group 1 mode on

!

interface FastEthernet0/2

switchport mode trunk

switchport trunk native vlan 99

switchport nonegotiate

no ip address

channel-group 1 mode on

!


HTH


BR,

Bjornarsb


mahmoud.hattab Sat, 05/26/2007 - 19:37
User Badges:

Hi, thanks for the information. I know etherchannel is the solution, but my boss wants this scenario. He wants to connect a 3 2950G-12-EI switch with loop and another redundant loop a total of 12 physical ports to be combine or channel-group as one logical ports. The questions is, is it possible to balance the two logical ports on a forwading state, so that even he remove any uplink connections he will not encounter any timeout while he's pinging from HostA(S1) to HostB(S2). I'll attached here the diagram of the scenario. I already use #channel-group 1 mode desirable non-silent, but as far as I know, a one channel-group has only eigth members port allowed, but on this scenario it has a total of 12 ports that needs to combine as on logical ports, so that all the ports are in forwading state. I know this really overkill connection, im just following my boss. I hope you can help me to solve this or just give a good explanation if this is not possible. Thank you and I will wait for your reply.



Amit Singh Sat, 05/26/2007 - 20:55
User Badges:
  • Cisco Employee,

Yes, It is possible. You can create multiple ether-channel groups per switch. Configure 2 channel groups on each switch and have the neighor switch ports assign to the same group. For example :


Create channel group 1 on Switch A to have a 4 port-bundle to connect to Switch B and another channel group 2 a 4 port-bundle to connect to Switch C. Do the same on other switches.


But why do you want do that.. you might see it an overkill design. A 2 port etherchannel might suffice your need here.


http://www.cisco.com/en/US/docs/switches/lan/catalyst2950/software/release/12.1_20_ea2/configuration/guide/swethchl.html#wp1021856


HTH,Please rate if it does.


-amit singh

mahmoud.hattab Sun, 05/27/2007 - 07:04
User Badges:

Hi, thank you for your help. I created a 3 logical channel in this scenario. Another questions, how I can minimize the timeout once I remove the first logical port. I'd try #span vlan 1 forward-time 4 and #span uplinkfast max-update-rate 1 on 3 switches. But once I removed the channel-group 1 that has 2 uplink ports, I encounter a 5 timeout a total of 20 seconds, is it possible to minimize this up to 2 timeout? thanks.

Amit Singh Sun, 05/27/2007 - 08:27
User Badges:
  • Cisco Employee,

Why do you want to change the timers? 5 timeouts are normal.It is not suggested to change the timers as it can result in some undesired STP behaviour.


Anyways, in such a small network it should not make any problem. There are two ways to do it:


1. Change the STP timers Hello, fordward-delay and max-age timers as required and change it only on the root bridge in the topology.


http://www.cisco.com/en/US/docs/switches/lan/catalyst2950/software/release/12.1_20_ea2/configuration/guide/swstp.html#wp1020759


2. Chek if you have RSTP support on the switches, if you have RSTP, then change the STP mode to it on all the switches. This will result in a faster convergence of the network topology and you will get the desired results that you are looking for.


HTH,Please rate if it does.


-amit singh

Actions

This Discussion