Unknown error in connecting to the SMTP server

Unanswered Question
May 26th, 2007
User Badges:

Hi,


I?m using CiscoWroks 2.5, I?m trying to configure CiscoWorks to send e-mail, I have configured the SMTP server in my CiscoWorks I?m getting this error.


[ Sun May 27 03:00:57 GMT+03:00 2007 ] INFO [Util : sendMail] : sendMail() - Starts

[ Sun May 27 03:00:57 GMT+03:00 2007 ] INFO [Util : sendMail] : SMTP Server:10.1.183.186

[ Sun May 27 03:00:57 GMT+03:00 2007 ] INFO [Util : sendMail] : From ID:[email protected]

[ Sun May 27 03:00:57 GMT+03:00 2007 ] INFO [Util : sendMail] : To ID:[email protected]

[ Sun May 27 03:00:57 GMT+03:00 2007 ] INFO [Util : sendMail] : Subject:1005 : Succeeded

[ Sun May 27 03:00:57 GMT+03:00 2007 ] ERROR [Util : sendMail] : Unknown error in connecting to the SMTP server [10.1.183.186]

[ Sun May 27 03:00:57 GMT+03:00 2007 ] ERROR [Util : sendMail] : Exception: java.lang.NullPointerException

[ Sun May 27 03:00:57 GMT+03:00 2007 ] ERROR [Util : sendMail] :

[ Sun May 27 03:01:18 GMT+03:00 2007 ] INFO [Util : sendMail] : sendMail() - Starts

[ Sun May 27 03:01:18 GMT+03:00 2007 ] INFO [Util : sendMail] : SMTP Server:10.1.183.186

[ Sun May 27 03:01:18 GMT+03:00 2007 ] INFO [Util : sendMail] : From ID:[email protected]

[ Sun May 27 03:01:18 GMT+03:00 2007 ] INFO [Util : sendMail] : To ID:[email protected]

[ Sun May 27 03:01:18 GMT+03:00 2007 ] INFO [Util : sendMail] : Subject:1420 : Succeeded

[ Sun May 27 03:01:18 GMT+03:00 2007 ] ERROR [Util : sendMail] : Unknown error in connecting to the SMTP server [10.1.183.186]

[ Sun May 27 03:01:18 GMT+03:00 2007 ] ERROR [Util : sendMail] : Exception: java.lang.NullPointerException

[ Sun May 27 03:01:18 GMT+03:00 2007 ] ERROR [Util : sendMail] :


For my conformation I have verified the SMTP server


C:> telnet 10.1.183.186 25


I?m getting fallowing result


220 MAILG2.aramco.com Microsoft ESMTP MAIL Service, Version: 6.0.3790.3959 ready

at Sun, 27 May 2007 09:16:14 +0300


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Sun, 05/27/2007 - 08:40
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

What version of Common Services do you have? You will need to be running at least 3.0.3 to get Exchange support. If you are, and this problem is still occurring, then you should get a packet capture of the CiscoWorks/SMTP server communication which will provide more information as to why the connection is not working.

ahmedmt2007 Sun, 05/27/2007 - 21:45
User Badges:

We are using Common Services 3.0.4, please let me know which software we use for packet capture.


Thanks in advance.

Joe Clarke Sun, 05/27/2007 - 22:18
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Packet capture software is built into Common Services. Go to Device Center > Packet Capture to start a capture. Filter on TCP port 25 traffic to the SMTP server.

Actions

This Discussion