Unanswered Question
May 27th, 2007

Hi Tony,

I have a problem on setting up the B-ACD in CME router. Please find below the problem.

I download the B-ACD files and it is available in the router.

Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(9)T1, RELEASE SOFTWARE (fc2)

service aa flash:app-b-acd-aa-

Dam-Gateway(config-app-param)#param handoff-string aa

Warning: parameter handoff-string has not been registered under aa namespace

Dam-Gateway(config-app-param)#param aa-pilot 8005550100

Warning: parameter aa-pilot has not been registered under aa namespace

I can't even get the welcome message also. No unity module available in this router.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (3 ratings)
Chris Deren Sun, 05/27/2007 - 08:27

These warnings are OK, did you apply the "service aa" to a dial-peer?

What do you get when you dial it?


jacobtoms Sun, 05/27/2007 - 22:06

Dear Chris,

Thanks for the prompt reply.

What I am getting is a dial tone and from there I can dial the extension

Please find attached the configuration

jacobtoms Mon, 05/28/2007 - 23:46


I solved the issues

I put the Service on the dial-peer 101

so its ok


aazmi Tue, 07/10/2007 - 04:31

hi tom

i am getting the same dial tone, even i have changes the aa service to 101.

need help.



jacobtoms Tue, 07/10/2007 - 05:18

There is no need to create a seperate dial peer for this you just aply the services aa in the incoming port.

Please paste your configuration so I can check.

AhmedEl-Eraky Mon, 10/08/2007 - 04:57


I am having the same warnings. In addition, I get a "Number Not Available" message and a Busy tone, when the pilot number is registered on CME (Pilot=420).

However, the pilot number is not associated with an ephone.

By issuing the show call application sessions command;

Router#sh call application sess

Session ID 51

App: Default

Type: Service

Url: builtin:Session_Service.C


When I changed it to a number that is NOT registered to the CME (pilot Number=600), and changed the respective dial-peers and configurations, I get a "Number Not Available" message.

Also, How do I verify the script and application's configurations

An excerpt of my configuration file.


service queue flash:app-b-acd-

param number-of-hunt-grps 3

param queue-len 15

param aa-hunt2 2222

param aa-hunt3 3333

param aa-hunt4 4444

param queue-manager-debugs 1

service aa flash:app-b-acd-aa-

param number-of-hunt-grps 3

paramspace english language en

paramspace english index 1

paramspace english location flash:

param call-retry-timer 15

param handoff-string aa

param dial-by-extension-option 1

param max-time-call-retry 700

param welcome-prompt _bacd_welcome.au

param aa-pilot 420

param service-name queue

voice-port 1/0/1

supervisory disconnect dualtone mid-call

supervisory custom-cptone test

cptone EG

timeouts call-disconnect 3

timeouts wait-release 3

connection plar opx 420

caller-id enable

dial-peer voice 11 pots

service aa

destination-pattern 9T

incoming called-number 420

port 1/0/1



ephone-hunt 1 longest-idle

pilot 2222

list 414, 415, 416, 417, 418

timeout 15, 15, 15, 15, 15

auto logout 1



ephone-hunt 2 longest-idle

pilot 3333

list 410, 411, 412, 413

timeout 15, 15, 15, 15

auto logout 1



ephone-hunt 3 longest-idle

pilot 4444

list 403, 404, 405, 406

timeout 15, 15, 15, 15

auto logout 1


ephone-dn 21

number 420


Really appreciate the response.



Chris Deren Mon, 10/08/2007 - 06:23

One thing that B-ACD is picky about is that you need all parameters defined even though you may not use them. I dont see the voicemail parameter defined in your config, make sure you add it and try again.


jacobtoms Tue, 10/09/2007 - 01:56

I solve this issue long back and thank you for your support

AhmedEl-Eraky Tue, 10/09/2007 - 02:11


First of all, thanks for the prompt response.

It worked.

By adding the voice mail parameters, even though I don't have any voicemail, I can now hear the ACD script. So the ACD is now working.

However, I am having another problem here, when an IP Phone calls a PSTN phone, I don't hear any ringback tone or audio, although the PSTN end can hear audio.

There is always a one-way audio from the PSTN to IP phone, whether it's an incoming or outgoing to the PSTN.

How can this be?

I tried editing some of the parameters of the voice ports and dial-peers, but still not working...


dial-peer voice 21 pots

service aa

destination-pattern 9T

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

port 1/1/1


voice-port 1/1/1

supervisory disconnect dualtone mid-call

cptone EG

timeouts call-disconnect 3

timeouts wait-release 3

caller-id enable


Really appreciate the response



jacobtoms Tue, 10/09/2007 - 03:08

Is it was working before properly in the basic configuration?

Please check the IOS version and try to load the latest IOS

Chris Deren Tue, 10/09/2007 - 05:34

One way voice is most often caused by incorrect IP routing, make sure your traffic is flowing as expected.

Also, check to see if you have bound the H323 to your intefrace.

Lastly I have seen this resolved by simply rebooting a router


AhmedEl-Eraky Wed, 10/10/2007 - 02:05

Okay, I can understand that being a routing issue if the call is carried over the WAN.

But if the call over the PSTN how can routing be involved. Isn't it simply dispatching the call to and from the voice port through the voice port and dial peer configuration?

Isn't that right?

Mind you I have checked the routing anyway, and It looks alright.

Could it be a software bug either with the IOS or CME? or the firmware of the phones?



AhmedEl-Eraky Thu, 10/18/2007 - 04:08


it's solved....

I had to configure the router from scratch again...

but anyway....

thanks for the help... really appreciate it...



This Discussion