route and hardware setup

Answered Question
May 27th, 2007
User Badges:

here is my hardware now...


2511 com-server= = loopback 192.168.10.10

2x 2610 router

2900 xl sw


now I just created some loopbacks in

R1= 1.1.1.1 255.255.255.0

R2= 2.2.2.2 255.255.255.0 >>>so they can talk to each other but I get ping failed


I am connected from 2511 to 2610s and SW1

I am able to connect from com-serv to R1,R2,SW1 with telnet sesion from com-ser..my question is


do I have to configure serial 0/0 in R1 and r2 with static ip for R1 to talk to R2 and if yes is R1 need to be connected directely to R2.. ?


Help!!!!!!!!



Thanks

Correct Answer by mohammedmahmoud about 10 years 1 month ago

Hi Karim,


Nice work :) please keep up ... i hope that you'll keep up the nice work until reaching the CCIE lab :)



BR,

Mohammed Mahmoud.

Correct Answer by mohammedmahmoud about 10 years 1 month ago

Hi Karim,


I am glade with your insistence to learn :) please keep up the nice practice.


The problem with your routers is that the Ethernet Interface of R2 is shutdown, please use "no shut" to have it operational.


You can see that from the configuration, and since it is not showing in the "show ip route" of R2 (if an interface is not UP/UP it will not show in the routing table).



HTH, please do rate all helpful replies if you found helpful,

Mohammed Mahmoud.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.8 (5 ratings)
Loading.
mohammedmahmoud Sun, 05/27/2007 - 11:03
User Badges:
  • Green, 3000 points or more

Hi Karim,


Can you attach or post a simple diagram with all the IPs, and preferred the configuration of the your devices, in order to help you in your scenario.


And yes you'll need to configure serial IPs or Ethernet IPs to make connectivity between your devices (the comm-server cables are for reverse telnet only not for connectivity).


To connect 2 routers back-to-back via serial interfaces you need DCE-DTE cable, if you need to connect them back-to-back via Ethernet you need a cross-over cable, and if through a switch you need 2 straight through cables.


HTH, please do rate all helpful replies,

Mohammed Mahmoud.


cisco steps Sun, 05/27/2007 - 17:25
User Badges:

Hi Mo,

first of all I hope you don't mind me calling you Mo. :-).. that how I call one of my best freind, back to a subjet...I have comm-ser connected to R1,R2, and a 2950 xl .. then I have a R1=2610 connected from ethernet to ethernet 1x on sw 2950 and the same for R2 on 2x ethernet port of the SW with straight through cable.


no ip is configured yet on R1,R2, OR 2950 SW...

mohammedmahmoud Sun, 05/27/2007 - 22:42
User Badges:
  • Green, 3000 points or more

Hi Karim,


First of all you are very welcomed, and you can call me Mo with no problems, as long as he is your friend :)


As we agreed earlier the connection from the comm-server to the console of the devices is used for management purposes only and not for connectivity.


Now, since you have connected the routers through the switch using Ethernet you'll need to configure IPs on the Ethernet interfaces of the routers to have connectivity between your routers.


As a best practice for you lab (this is what i do), allocate a network for your loopbacks, and another one for your serial IPs, and a third one for your Ethernet IPs, and always do the subnetting using them.


I hope that i've been informative.



HTH, please do rate all helpful replies,

Mohammed Mahmoud.

cisco steps Mon, 05/28/2007 - 13:05
User Badges:

here is router 2 config

**************************************


R2#show config

Using 674 out of 29688 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R2

!

boot-start-marker

boot-end-marker

!

enable password cisco

!

no aaa new-model

ip subnet-zero

ip cef

!

!

ip audit po max-events 100

!

!

interface Loopback0

ip address 2.2.2.2 255.255.255.0

!

interface Ethernet0/0

ip address 192.168.1.2 255.255.255.0

shutdown

half-duplex

!

interface Serial0/0

no ip address

!

interface Serial0/1

no ip address

shutdown

!

ip http server

no ip http secure-server

ip classless

!

!

line con 0

password ccna

login

line aux 0

line vty 0 4

login


here is router 1 config

**************************************


R1#show config

Using 794 out of 29688 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname R1

!

boot-start-marker

boot-end-marker

!

enable secret xxx

enable password xxx

!

memory-size iomem 15

no aaa new-model

ip subnet-zero

ip cef

!

!

no ip domain lookup

!

ip audit po max-events 100

!

!

!

interface Loopback0

ip address 1.1.1.1 255.255.255.0

!

interface Ethernet0/0

ip address 192.168.1.1 255.255.255.0

half-duplex

!

interface Serial0/0

no ip address

!

interface Serial0/1

no ip address

shutdown

!

no ip http server

no ip http secure-server

ip classless

!

!

!

line con 0

password xxx

login

line aux 0

line vty 0 4

password xxx

login

!

!

end

********************************************************************************************


I still can't ping r1 from r2 or r2 from r1..


I used straight trough cable from r1 to sw 2950 port 1x and from r2 to sw 2950 port 2x


*****************************************


R1#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route


Gateway of last resort is not set


1.0.0.0/24 is subnetted, 1 subnets

C 1.1.1.0 is directly connected, Loopback0

C 192.168.1.0/24 is directly connected, Ethernet0/0


**********************************************


R2#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route


Gateway of last resort is not set


2.0.0.0/24 is subnetted, 1 subnets

C 2.2.2.0 is directly connected, Loopback0

Correct Answer
mohammedmahmoud Mon, 05/28/2007 - 13:16
User Badges:
  • Green, 3000 points or more

Hi Karim,


I am glade with your insistence to learn :) please keep up the nice practice.


The problem with your routers is that the Ethernet Interface of R2 is shutdown, please use "no shut" to have it operational.


You can see that from the configuration, and since it is not showing in the "show ip route" of R2 (if an interface is not UP/UP it will not show in the routing table).



HTH, please do rate all helpful replies if you found helpful,

Mohammed Mahmoud.

cisco steps Tue, 05/29/2007 - 17:52
User Badges:

MO, sorry I am not near the lab but I managed to draw someting I hope that help or clarify my question I will do waht you suggested and get back to you w/ the result .. Thanks again



Attachment: 
mohammedmahmoud Wed, 05/30/2007 - 00:01
User Badges:
  • Green, 3000 points or more

Hi Karim,


Nice start for a lab please keep up the nice work :), i am sure that you'll find the Ethernet interface shut, and when no shut it everything will work out.


Just to make sure that you have no conflicts, the loopback interface is not bonded to any physical interface, it is a logical interface used for reverse telnet, routing protocols and other purposes and it is not bonded to any physical interface.


Take care, waiting for your feed back.



HTH, please do rate all helpful replies,

Mohammed Mahmoud.



P.S When attaching diagrams try having it in jpg of gif format and not bmp, in order to reduce its size.




cisco steps Thu, 05/31/2007 - 08:32
User Badges:

that will do it . I was able to see r1 from r2 and r2 from r1.. I will add an other router to the network that will be router 3 .. you here about it soon :-} Thanks for the help Mo..


karim

Correct Answer
mohammedmahmoud Thu, 05/31/2007 - 11:22
User Badges:
  • Green, 3000 points or more

Hi Karim,


Nice work :) please keep up ... i hope that you'll keep up the nice work until reaching the CCIE lab :)



BR,

Mohammed Mahmoud.

Actions

This Discussion