Configuring Prior Used 831 ADSL Router to Just Connect to Internet

Unanswered Question
May 28th, 2007

Have a Cisco 831 DSL router pulled from working environment. I've tried a number of CLI entries to get the router to simply connect to the Internet with no success. At one point, I could ping Internet provider gateway and DNS server. I know more than what "not being able to connect" implies-yet I obviously am overlooking a simple matter. Getting the router back to how they are shipped new for CRWS (web setup) is fine with me. I can build on that. Following is running-config, sh version, and proof that web setup files are all present in webflash. I have stripped this running-config to nothing except an ethernet address to be able to communicate with the router over IP on my LAN. The DSL information is as follows:

I switch the Embarq DSL modem to run as a bridge. IP addresses are assigned via DHCP. Modem is running what appears to be proprietary encapsulation ENET ENCAP. (I've never switched this to RFC 1438 yet, when trying to set up router.) Multiplex is LLC, VPI 8 and VCI 35, ATM QoS Type UBR


Building configuration...

Current configuration : 931 bytes

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

hostname Router



memory-size iomem 5

no aaa new-model

resource policy

ip subnet-zero

no ip dhcp use vrf connected

ip cef

no ip ips deny-action ips-interface

interface Ethernet0

ip address

interface Ethernet1

no ip address

duplex auto

interface Ethernet2

no ip address


interface FastEthernet1

duplex auto

speed auto

interface FastEthernet2

duplex auto

speed auto

interface FastEthernet3

duplex auto

speed auto

interface FastEthernet4

duplex auto

speed auto

ip classless

ip http server

no ip http secure-server


line con 0

no modem enable

line aux 0

line vty 0 4

exec-timeout 120 0


length 0

scheduler max-task-time 5000


Router#sh version

Cisco IOS Software, C831 Software (C831-K9O3SY6-M), Version 12.4(2)T4, RELEASE SOFTWARE (fc2)

Technical Support:

Copyright (c) 1986-2006 by Cisco Systems, Inc.

Compiled Wed 01-Mar-06 10:58 by ccai

ROM: System Bootstrap, Version 12.2(8r)YN, RELEASE SOFTWARE (fc1)

Router uptime is 23 minutes

System returned to ROM by power-on

System image file is "flash:c831-k9o3sy6-mz.124-2.T4.bin"

Cisco C831 (MPC857DSL) processor (revision 0x400) with 46695K/2457K bytes of memory.

Processor board ID AMB08250J5J (1968708112), with hardware revision 0000

CPU rev number 7

3 Ethernet interfaces

4 FastEthernet interfaces

128K bytes of NVRAM.

12288K bytes of processor board System flash (Read/Write)

2048K bytes of processor board Web flash (Read/Write)

Configuration register is 0x2102

Router#sh webflash

Web flash directory:

File Length Name/status

1 986 ConfigExp.cfg

2 474217 CRWSbHlp.html

3 941455 CRWS_1.jar

4 278042 CRWS_2.jar

5 62561 CRWS_VPNLogin.jar

6 47026 GUI.html

7 4895 home.html

8 8082 loading.gif

9 3463 VPNLogin.html

[1821320 bytes used, 13684 available, 1835004 total]

2048K bytes of processor board Web flash (Read/Write)


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
bjornarsb Tue, 05/29/2007 - 00:20


Try this:


interface Ethernet1

bandwidth 2048

ip address dhcp

ip access-group 115 in

no ip proxy-arp

ip nat outside

ip route-cache flow

service-policy output QUEUING



interface Ethernet0

ip address 192.168.X:X secondary

ip address 172.16.X:X

ip accounting output-packets

ip nat inside

ip route-cache flow

standby ip 192.168.X.X

standby preempt

hold-queue 100 out


ip nat inside source list 5 interface Ethernet1 overload

access-list 5 permit

access-list 5 permit

access-list 5 permit

If it does not work try:

debug dhcp

(ter mon)

to see if you get an IP from the ISP





This Discussion