ISDN backup not working on 1841

Unanswered Question
May 29th, 2007

Hi,

I am facing a problem with ISDN backup for a Frame-relay link. The router is a 1841 with 12.1 IOS.The router works fine with the primary frame relay link. However when i issue a shut command on the serial frame-relay interface to test the backup, the BRI doesn,t come up. When i issue a "sh ip int brief" command it shows disabled for the BRI interface. On issuing "sh isdn status" it says the Layer 1 is deactivated. But there is no issue with the ISDN connection as the telco has verified it by hooking the line with a phone and testing it.I physically removed the serial interface and tried working with just the BRI when the physical BRI shows as up but both B channels are down.I tried restarting the modem , router, changing the cable etc but its of no use.Sometimes i get an error which says "unfound B-channel on disconnect-ack callid 0x800 ".The following are the command used:

interface Serial0/0/0

ip address 192.168.125.34 255.255.255.252

ip nat inside

encapsulation frame-relay IETF

backup delay 1 5

backup interface BRI0/1/0

frame-relay interface-dlci 18

frame-relay lmi-type q933a

interface BRI0/1/0

ip address 192.168.125.38 255.255.255.252

ip access-group en1 in

ip access-group en2 out

ip nat inside

encapsulation ppp

dialer map ip 192.168.125.37 name xxxxx broadcast 1234567

dialer-group 1

isdn switch-type basic-net3

isdn point-to-point-setup

no keepalive

no cdp enable

ppp authentication chap

ppp multilink

Thanks and Regards

Sonu

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Paolo Bevilacqua Tue, 05/29/2007 - 08:45

Hi,

can you please send "show ver" and output of "term mon" and "debug isdn q921", "debug isdn q931" when pinging 192.168.125.37.

I would also remove the access-group from bri0/0/0 before testing, and re-enable keepalive.

Richard Burts Tue, 05/29/2007 - 08:49

Sonu

The main problem here is in your method of testing. When you shut down the primary interface the backup interface will not activate as the result of a shutdown command. The backup interface will activate when the primary interface is in a down state but does not activate when the primary is administratively down.

To do a test you either need to create a real problem on the frame relay or you need to temporarily remove the backup interface command. One other alternative could be to modify your config so that the ISDN uses dialer profiles. You could then configure a dialer profile for the backup and you could create another dialer profile to be used for testing.

The unfound channel error sounds like a miscommunication between your router and the ISDN switch. When the ISDN is active can you post the output of show isdn status? It would also be helpful to see what is in the inbound and outbound access lists and what is in the dialer list referred to by dialer-group 1.

HTH

Rick

Actions

This Discussion