Can any one help me with OSPF and EIGRP problems

Unanswered Question
May 29th, 2007

Objectives

Configure OSPF with authentication

Configure EIGRP

Configure default routing and propagate it using OSPF

Verify network connectivity

Preconfigs

Note: The ?no keepalive? command is added to FastEthernet0/0 interface. This will bring the interface up without having to connect a switch or a hub.

The following items have been pre-configured on these devices:

The topology cabling

Hostname on all routers

Interface IP address on the routers

Interface clock rate on the routers

Following are the actual commands already configured on the devices:

Router1

hostname Router1

interface FastEthernet0/0

ip address 172.16.2.33 255.255.255.224

no keepalive

no shutdown

interface Serial0/0

ip address 172.16.1.2 255.255.255.252

clockrate 56000

no shutdown

Router2

hostname Router2

interface FastEthernet0/0

ip address 172.30.1.1 255.255.255.0

no keepalive

no shutdown

interface Serial0/0

ip address 172.16.1.1 255.255.255.252

no shutdown

interface serial0/1

ip address 10.10.1.1 255.255.255.252

clockrate 56000

no shutdown

Router3

hostname Router3

interface FastEthernet0/0

ip address 172.30.2.1 255.255.255.0

no keepalive

no shutdown

interface serial0/1

ip address 10.10.1.2 255.255.255.252

no shutdown

Configuration Tasks

Configure OSPF with Authentication

Configure OSPF routing between Router1 and Router2 with the process ID of 50.

Configure OSPF so only the following 172.16.0.0 subnets will be routed.

172.16.2.32/27

172.16.1.0/30

Configure Router1 with the OSPF router ID of 192.168.1.1.

Configure Router2 with the OSPF router ID of 192.168.1.2.

Configure the OSPF hello interval to 5 seconds and the OSPF dead interval to 20 seconds.

Configure the OSPF communication between the routers to use authentication with MD5 encryption.

Configure EIGRP

Configure EIGRP between Router2 and Router3 with an AS of 100.

EIGRP should only route for the following networks.

10.10.1.0/30

172.30.1.0/24

172.30.2.0/24

Configure Default Routing and propagate it using OSPF

On Router 2, configure a default static route to Router 3.

Propagate that default route to all routers in the OSPF routing domain.

Verify connectivity

Router2 should be able to ping all interfaces on all routers. Router1 and Router3 will not be able to ping all interfaces since there is no redistribution between OSPF and EIGRP in this scenario. Router1 should be able to ping all OSPF-enabled interfaces and Router3 should be able to ping all EIGRP-enabled interfaces.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
smothuku Thu, 05/31/2007 - 08:40

Hi ,

Following is the config....

Experts ,

If any mistake is there in config plz correct me...

Configure OSPF so only the following 172.16.0.0 subnets will be routed.

172.16.2.32/27

172.16.1.0/30

Router1:

Router ospf 50

Network 172.16.2.32 0.0.0.31 area 0

Network 172.16.1.2 0.0.0.0 area 0

reditribute static

ip route 172.30.1.0 255.255.255.0 172.16.1.2

ip route 10.10.1.0 255.255.255.252 172.16.1.2

Router2:

Router ospf 50

Network 172.16.1.1 0.0.0.0 area 0

default-information originate always

Ip route 0.0.0.0 0.0.0.0 10.10.1.2

Configure Router1 with the OSPF router ID of 192.168.1.1.

Config)# router-id 192.168.1.1

Configure Router2 with the OSPF router ID of 192.168.1.2.

Config)# router-id 192.168.1.12

Configure the OSPF hello interval to 5 seconds and the OSPF dead interval to 20 seconds.

Router1:

interface Serial0/0

ip ospf hello-interval 5

ip ospf dead-interval 20

Router2:

inter interface Serial0/0

ip ospf hello-interval 5

ip ospf dead-interval 20

Configure the OSPF communication between the routers to use authentication with MD5 encryption.

Router1:

interface Serial0/0

ip ospf message-digest-key 100 md5 OLD

Router2:

interface Serial0/0

ip ospf message-digest-key 100 md5 OLD

Configure EIGRP

Configure EIGRP between Router2 and Router3 with an AS of 100.

EIGRP should only route for the following networks.

10.10.1.0/30

172.30.1.0/24

172.30.2.0/24

Router 2:

Router eigrp 100

Network 10.10.1.1 0.0.0.3

Network 172.30.1.0 0.0.0.255

Network 172.30.2.0 0.0.0.255.

No auto-summary

Router 3:

Router eigrp 100

Network 10.10.1.2 0.0.0.3

Network 172.30.2.0 0.0.0.255.

Redistribute static

No auto-summary

Ip route 172.30.1.0 255.255.255.0 10.10.1.2

Configure Default Routing and propagate it using OSPF

On Router 2, configure a default static route to Router 3.

Ip route 0.0.0.0 0.0.0.0 10.10.1.2

Thanks,

Satish

Actions

This Discussion