Campus does not discover ATM link

Answered Question
May 30th, 2007

Hi everybody,

I noticed that one important wan-link was not discovered by campus.

It's an ATM link between bob and zap. It's been running stable for a couple of years and I'm tolled not to touch it.

I think that ilmi might not be configured the way it should be causing the atmInterfaceMyNeighborIpAddress not to be filled, causing the OID's read by campus to contain:

snmpwalk.pl -c NetDoc bob-core22 1.3.6.1.2.1.37.1.2.1.11

1.3.6.1.2.1.37.1.2.1.11.3 = IpAddress: 0.0.0.0

I've tried to diagnose a bit but I don't recall to much ATM stuff anymore.

Can anyone help?

Thanks,

Michel

bob-core22#show atm ilmi-status atm 2/0

Interface : ATM2/0 Interface Type : Unknown

ILMI VCC : (0, 16) ILMI Keepalive : Disabled

ILMI State: Restarting

bob-core22#sh run

!

interface ATM2/0

description bob to zap DS3 45mbp/s zap-core22 Circuit ID#LD001234

no ip address

ip route-cache flow

load-interval 30

atm scrambling cell-payload

atm framing cbitplcp

no atm ilmi-keepalive

no clns route-cache

!

interface ATM2/0.45 point-to-point

description Clear Channel T3 - PVC numbers are not valid - reference only

mtu 1500

ip address 12.16.25.69 255.255.255.252

ip ospf network point-to-point

pvc 45/45

oam-pvc manage

protocol ip inarp

!

bob-core22#deb atm ilmi

Setting ILMI debug for all interfaces.

bob-core22#ter mon

bob-core22#

May 30 08:39:38.898 GMT+2: ILMI(ATM2/0): Sending ilmiColdStart trap

May 30 08:39:38.898 GMT+2: ILMI(ATM2/0): No ILMI VC found

May 30 08:39:38.898 GMT+2: ILMI: Encapsulation error on o/g ILMI Pdu <ilmi_send_pkt> (ATM2/0)

May 30 08:39:38.898 GMT+2: ILMI: Unable to Send Pdu out <ilmi_send_trap>

zap-core22#show atm ilmi-status atm 3/0

Interface : ATM3/0 Interface Type : Unknown

ILMI VCC : (0, 16) ILMI Keepalive : Disabled

ILMI State: Restarting

zap-core22#sh run

!

interface ATM3/0

description zap to bob DS3 45mbp/s - bob-core11 Circuit ID#LD001234

no ip address

ip route-cache flow

load-interval 30

atm scrambling cell-payload

atm framing cbitplcp

no atm ilmi-keepalive

no clns route-cache

end

!

interface ATM3/0.45 point-to-point

description Clear Channel T3 - PVC numbers are not valid - reference only circuit ID <to be encoded>

mtu 1500

ip address 12.16.25.70 255.255.255.252

ip ospf network point-to-point

pvc 45/45

oam-pvc manage

protocol ip inarp

!

end

zap-core22#deb atm ilmi

May 30 07:37:27.236 UTC: ILMI(ATM3/0): Sending ilmiColdStart trap

May 30 07:37:27.236 UTC: ILMI(ATM3/0): No ILMI VC found

May 30 07:37:27.236 UTC: ILMI: Encapsulation error on o/g ILMI Pdu <ilmi_send_pkt> (ATM3/0)

May 30 07:37:27.236 UTC: ILMI: Unable to Send Pdu out <ilmi_send_trap>

I have this problem too.
0 votes
Correct Answer by Joe Clarke about 9 years 6 months ago

You need to explicitly enable it on ATM with "cdp enable."

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
miheg Wed, 05/30/2007 - 01:37

I guess that the source of the problem is that ILMI is simply not configured.

It should probably be more like this:

Does anyone see if the commands I added may disturb the existing ones?

Thanks,

Michel

interface ATM3/0

description zap to bob DS3 45mbp/s - bob-core11 Circuit ID#LD001234

no ip address

ip route-cache flow

load-interval 30

pvc bob-core11 0/16 ilmi

atm scrambling cell-payload

atm framing cbitplcp

no atm ilmi-keepalive

no clns route-cache

end

!

interface ATM3/0.45 point-to-point

description Clear Channel T3 - PVC numbers are not valid - reference only circuit ID

mtu 1500

ip address 12.16.25.70 255.255.255.252

ip ospf network point-to-point

pvc 45/45

ilmi manage

oam-pvc manage

protocol ip inarp

Joe Clarke Wed, 05/30/2007 - 07:48

Actually, for a non-LANE link, you might be better off with CDP over ATM (provided your device supports it). CDP over ATM is supported in 12.2T and higher.

miheg Wed, 05/30/2007 - 21:37

I certainly prefer CDP, but CDP is globally on, and not disabled on this interface.

If you have an idea why it is not working on the ATM interface I'd appreciate.

.May 31 07:38:47.110 GMT+2: CDP-PA: version 2 packet sent out on GigabitEthernet0/2

.May 31 07:38:50.630 GMT+2: CDP-PA: Packet received from Tina-SUP720-11 on interface GigabitEthernet0/2

.May 31 07:38:50.630 GMT+2: **Entry found in cache**

.May 31 07:39:10.570 GMT+2: CDP-PA: Packet received from bob-core11 on interface GigabitEthernet0/3

.May 31 07:39:10.570 GMT+2: **Entry found in cache**

.May 31 07:39:18.262 GMT+2: CDP-PA: version 2 packet sent out on GigabitEthernet0/3

.May 31 07:39:19.398 GMT+2: CDP-PA: Packet received from wilma-core11 on interface Serial1/0

.May 31 07:39:19.398 GMT+2: **Entry found in cache**

.May 31 07:39:19.842 GMT+2: CDP-PA: version 2 packet sent out on Serial1/0

.May 31 07:39:47.110 GMT+2: CDP-PA: version 2 packet sent out on GigabitEthernet0/2

bob-core22#sh cdp

Global CDP information:

Sending CDP packets every 60 seconds

Sending a holdtime value of 180 seconds

Sending CDPv2 advertisements is enabled

bob-core22#sh ver

Cisco Internetwork Operating System Software

IOS (tm) 7200 Software (C7200-JS-M), Version 12.3(19), RELEASE SOFTWARE (fc2)

I guess my ATM memories have become more then just a bit rusty. :-|

Cheers,

Michel

Correct Answer
Joe Clarke Wed, 05/30/2007 - 21:47

You need to explicitly enable it on ATM with "cdp enable."

miheg Fri, 06/01/2007 - 08:09

So on ATM it's the opposite of what it is on the other interface types? Good to know this!! Thanks for mentioning this as I would not have guessed it.

Joe, if the TAC would answer the questions like you do I would never buy anything anywhere else then at Cisco's

Cheers,

Michel

Joe Clarke Fri, 06/01/2007 - 08:12

When this feature was implemented, development decided to make CDP disabled on ATM by default much like frame-relay multi-point interfaces. This was covered by CSCdt03339.

Actions

This Discussion