Problems running ATM over E1

Unanswered Question
May 30th, 2007
User Badges:

Hi, I'm trying to get an ATM circuit up over an E1 circuit. The router is a 2811 with an AIM-ATM installed in AIM slot 0, and a VWIC-1MFT-E1 installed. It's connected to a BT CellStream circuit in the UK. I've got a CD LED on on the E1 card, but the E1 Controller won't come up. The carrier has been to site a couiplle of times to verify that the circuit is ok. We are due to attend site tomorrow with an E1 tester to test the cct with the carrier. Can anyone see anything wrong with the config that we are trying to implement or am I right in thinking that there is a problem with the cct? The router is connected to the NTE by a 15M straight FTP cable which then goes into an RJ45 to twin-ax convertor (Cisco part# CAB-ADPT-75-120) which connects to the NTE. I have also looped the twin-ax convertor at the NTE end and the controller came up and ran with no errors, this was to prove the cabling is OK.

Here are the relevant parts of the config;


network-clock-participate wic 0

network-clock-participate aim 0

network-clock-select 1 E1 0/0/0


!

controller E1 0/0/0

mode atm aim 0

framing NO-CRC4

!


interface ATM0/0/0

no ip address

scrambling-payload

no atm ilmi-keepalive

!

interface ATM0/0/0.1 point-to-point

bandwidth 512

ip address x.x.x.x 255.255.255.252

ip ospf cost 5000

no snmp trap link-status

pvc Gatw-temp 1/32

vbr-nrt 1920 1920

oam-pvc manage

service-policy output OUTBOUND

!


Here is the output of the sh controllers e1;


E1 0/0/0 is down.

Applique type is Channelized E1 - balanced

No alarms detected.

alarm-trigger is not set

Version info Firmware: 20060927, FPGA: 20, spm_count = 0

Framing is NO-CRC4, Line Code is HDB3, Clock Source is Line.

CRC Threshold is 320. Reported from firmware is 320.

Data in current interval (528 seconds elapsed):

2717105 Line Code Violations, 504394 Path Code Violations

0 Slip Secs, 2 Fr Loss Secs, 10 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 528 Unavail Secs

Total Data (last 1 15 minute intervals):

2208485 Line Code Violations, 740288 Path Code Violations,

1 Slip Secs, 0 Fr Loss Secs, 10 Line Err Secs, 0 Degraded Mins,

1 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 880 Unavail Secs


Any help would be greatly appreciated

Dom

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
d-fillmore Wed, 05/30/2007 - 07:10
User Badges:

Thanks for your response Krisztian. I've just had an email from the carrier saying that the framing was set to CRC-4 but they could see that the router was set to NO-CRC4 so they've changed the NTE to reflect this. I'll have to go to site tomorrow and see if it's made any difference.


Confusing thing is that with the framing set to CRC-4, the controller would sometimes come up for about 3 minutes and then go down again;


show controllers e1

E1 0/0/0 is down.

Applique type is Channelized E1 - balanced

Far End Block Errors Detected

Receiver has loss of frame.

alarm-trigger is not set

Version info Firmware: 20060927, FPGA: 20, spm_count = 0

Framing is CRC4, Line Code is HDB3, Clock Source is Line.

CRC Threshold is 320. Reported from firmware is 320.

Data in current interval (517 seconds elapsed):

2628252 Line Code Violations, 494939 Path Code Violations

0 Slip Secs, 2 Fr Loss Secs, 10 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 517 Unavail Secs

Total Data (last 1 15 minute intervals):

2208485 Line Code Violations, 740288 Path Code Violations,

1 Slip Secs, 0 Fr Loss Secs, 10 Line Err Secs, 0 Degraded Mins,

1 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 880 Unavail Secs


Router#

Router#

Router#

Router#

Router#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#controller e1 0/0/0

Router(config-controller)#fr

*May 23 13:56:09.913: %ATM_AIM-5-CELL_ALARM_UP: Interface ATM0/0/0 lost cell delineation.

*May 23 13:56:09.929: %ATM_AIM-5-CELL_ALARM_DOWN: Interface ATM0/0/0 regained cell delineation.am no

Router(config-controller)#fram no-crc4

Router(config-controller)#fram no-crc4

Router(config-controller)#fram no-crc4

Router(config-controller)#

Router(config-controller)#^Z

Router#show controllers e1

E1 0/0/0 is down.

Applique type is Channelized E1 - balanced

No alarms detected.

alarm-trigger is not set

Version info Firmware: 20060927, FPGA: 20, spm_count = 0

Framing is NO-CRC4, Line Code is HDB3, Clock Source is Line.

CRC Threshold is 320. Reported from firmware is 320.

Data in current interval (528 seconds elapsed):

2717105 Line Code Violations, 504394 Path Code Violations

0 Slip Secs, 2 Fr Loss Secs, 10 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 528 Unavail Secs

Total Data (last 1 15 minute intervals):

2208485 Line Code Violations, 740288 Path Code Violations,

1 Slip Secs, 0 Fr Loss Secs, 10 Line Err Secs, 0 Degraded Mins,

1 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 880 Unavail Secs

Router#

Actions

This Discussion