Modem passthrough using mgcp.

Unanswered Question
May 30th, 2007


I have had a strange problem when using modems/faxes from a VG 224 through 3825 E1 via callmanager 4.1(3)

When the call was placed you would get 2 seconds of silence after the remote modem /fax had answered.Faxes could deal with this but modem got very confused.

I tracked it down to the command on the VG224 ,mgcp modem passthrough voip codec g711alaw.

If i removed this which means it ran as default ulaw , the gap of silence disappeared.Anyone seen anything similiar or can explain why to me.



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
s.jankowski Tue, 06/05/2007 - 16:49

The relevant configuration for fax passthrough on the VG200 is:

mgcp modem passthrough voip mode cisco

mgcp modem passthrough voip codec g711alaw

mgcp codec g729r8 packetization-period 20

thisisshanky Tue, 06/05/2007 - 17:15

At the same time, along with the above commands, You will need to disable Cisco fax relay (turned on by default) and also T38 fax relay.

no ccm-manager fax protocol cisco

mgcp t38 fax inhibit.



PS: please remember to rate posts!


This Discussion