Communication between two networks...

Unanswered Question
May 30th, 2007

I have two devices I need to connect and allow one-way communication between...a 2611 router and a PIX 501 Firewall.

On the network behind the 2611, the IP schema is this (IP/SUB/GATE) (10.20.30.x/

On the network behind the PIX, the IP schema is this (IP/SUB/GATE) (192.168.1.x/

The PIX is configured for its own internal network and is used as the primary device between its network and the outside world.

The 2611 has not yet been configured, but I'm hoping to be able to configure it to act as a security device for our network.

I have not yet performed any configuration on either of the devices that is necessary to "connect" the two networks. I need to be able to have one-way communication between one computer on the 2611 network ( and one computer on the PIX network ( on one specific port (8234).

Is it possible to accomplish this with simply entering the appropriate commands on both devices and if so, how?

I've had a little bit of exposure to the 26xx line, but have no experience at all with any PIX devices. Just can't seem to figure out the Device Manager on the PIX.

Can anyone help me out with the commands necessary to facilitate this configuration? It would be greatly appreciated.

Thank you.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
stemaxsin Wed, 05/30/2007 - 11:24

I think I have some of it figured out on the 2611 side, but I'm struggling with the PIX side of things.

Is there anyone out there in good ol' cyberspace that can assist with the configuration of the PIX?


stemaxsin Wed, 05/30/2007 - 14:27

Here's the existing configuration...

PIX Version 6.3(4)

interface ethernet0 auto

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password **************** encrypted

passwd **************** encrypted

hostname pixfirewall


fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69


access-list outside_access_in permit tcp any interface outside eq 3389

access-list outside_access_in permit tcp any eq pop3 any eq pop3

access-list outside_access_in permit tcp any eq 9100 any eq 9100

access-list inside_outbound_nat0_acl permit ip any

pager lines 24

mtu outside 1500

mtu inside 1500

ip address outside 61.x.x.59

ip address inside

ip audit info action alarm

ip audit attack action alarm

ip local pool vpnpool

pdm location inside

pdm location 216.x.x.185 outside

pdm location 55.x.x.136 outside

pdm location outside

pdm location outside

pdm location outside

pdm location inside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list inside_outbound_nat0_acl

nat (inside) 1 0 0

static (inside,outside) tcp interface 3389 3389 netmask 0 0

static (inside,outside) netmask 0 0

access-group outside_access_in in interface outside

route outside 1

timeout xlate 0:05:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http outside

http outside

http outside

http inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-pptp

telnet timeout 5

ssh timeout 5

console timeout 0

vpdn group PPTP-VPDN-GROUP accept dialin pptp

vpdn group PPTP-VPDN-GROUP ppp authentication mschap

vpdn group PPTP-VPDN-GROUP ppp encryption mppe auto required

vpdn group PPTP-VPDN-GROUP client configuration address local vpnpool

vpdn group PPTP-VPDN-GROUP pptp echo 60

vpdn group PPTP-VPDN-GROUP client authentication local

vpdn username administrator password *********

dhcpd lease 3600

dhcpd ping_timeout 750

dhcpd auto_config outside

terminal width 80


Hope that helps.


acomiskey Thu, 05/31/2007 - 06:05

So is this the topology?

10.20.30.x ---- 2611 ---- Internet ---- pix ---- 192.168.1.x

What are you looking to do exactly? Do you want to create a vpn tunnel between the router and the pix?

Or do you simply want to reach the machine behind the pix via the outside address of the pix? If so all you need is this in the pix.

static (inside,outside) tcp interface 8234 8234 netmask

access-list outside_access_in permit tcp host interface outside eq 8234

would be the address that is being natted to.

stemaxsin Thu, 05/31/2007 - 07:05

No, actually, the topology you detailed is incorrect. Here's what we are dealing with...

10.20.30.x --- 2611 - - PIX --- 192.168.1.x

You see, the 2611 and the PIX are in the same phone closet, but link to different networks. If at all possible, I need to link the 2611 and the PIX directly so that a computer on the 2611 can send information to a computer on the PIX.


acomiskey Thu, 05/31/2007 - 08:00

Ok, so are you connecting the router to the pix outside interface? Make sure both interfaces are on the same network. Make sure you have a route on 2611 to route to via outside pix interface. Add these statements to the pix. The first is called identity nat, and the second will allow the access from 10. host and your 192. host on tcp port 8234. Post your router config too if you need help there.

static (inside,outside) netmask

access-list outside_access_in permit tcp host host eq 8234

stemaxsin Thu, 05/31/2007 - 08:53

Well, apparently I did something wrong in the configuration of the 2611 so I've reset the router completely...back to empty settings.

Keep in mind, the 2611 is simply going to act as a firewall for our side of the network.

I have a line running from our existing network (10.20.30.x) to the ETH0/0 port on the router and I was assuming I could run another line from the ETH0/1 port to the PIX on the other network.

I guess I just need to know the easiest way to accomplish this with any combination of these two devices (2611 and PIX) to allow traffic from a computer on the 2611 side to a computer on the PIX side, but not the other way.

Thanx again.

acomiskey Thu, 05/31/2007 - 09:04

-You're losing you want this?

Internet --- PIX --- 192.168.1.x --- 2611 ---10.20.30.x

-Do you have another router inside your pix?

"I have a line running from our existing network (10.20.30.x) to the ETH0/0 port on the router and I was assuming I could run another line from the ETH0/1 port to the PIX on the other network."

-The pix only has 2 interfaces, you need outside for internet and inside for network. Therefore you would not plug the router directly to the pix. The above would work but you need a way to route to 10 network via 2611 router.

stemaxsin Thu, 05/31/2007 - 10:51

Okay...I guess that was a little confusing. Take a look at the attached image and hopefully that will straighten things out.

The PIX controls 192.168.1.x

The 2611 controls 10.20.30.x

They are two separate networks, but both devices are in the same phone closed. I am just looking for a way to "link" the two networks, using any combination of the aformentioned 2611 and PIX, in a manner that will allow one computer on the 10.20.30.x (2611) network to send data to a computer on the 192.168.1.x (PIX) network in a one-way fashion.

Thanx again.

acomiskey Thu, 05/31/2007 - 11:07

How many interfaces are there on the 2611? If you have a free one you just need to connect this to a switch on the 192. network. But then you have to deal with how you are going to route to the 10. network from the 192. network. You could at that point add a route on the host.

stemaxsin Thu, 05/31/2007 - 11:20

On the 2611, there are two Ethernet interfaces...Eth0/0 and Eth0/1.

On the PIX, there are five Ethernet ports, one WAN port and four LAN ports.

I'm going to assume I could just connect a patch cord between the 2611 and the PIX. If this is the case, what would be the commands I need to issue to both devices to accommodate the necessary traffic flow I detailed earlier?

Thanx again.

Also, take into consideration that on the 2611, I can connect via console and enter the commands necessary via the command line. However, on the PIX, I am limited to the web-based GUI interface.

stemaxsin Thu, 05/31/2007 - 13:14

Actually, no.

Right now, I have the 2611 connected to our network (10.20.30.x) via the ETH0/0 port. It actually goes like this...internet to our primary router (3200) - switch - switch - the router in question (2611).

At that point, I was hoping to connect a patch cord between our ETH0/1 to one of the open ports on the PIX.

If that is doable, then I just need the appropriate configuration commands to program into each of the devices to allow the one-way traffic I described earlier.

Thanx again.

acomiskey Thu, 05/31/2007 - 14:25

I was going by the picture you posted earlier. Just give the open port on the router a free address on your network. Connect this port to your network. The only problem with this is you have to route from the machine in your 192 network to the machine in your 10 network without a router. You cannot route it with the pix as it will not allow hairpinning. You will have to add a persistent route to the server itself. This setup requires no pix configuration at all.

stemaxsin Thu, 05/31/2007 - 14:57

This sounds good.

Does it matter that the 192 network is the PIX and the 10 network is the 2611? Also, the traffic needs to flow from the 10 network to the 192 network only.

So, what commands to I need to issue to the PIX and/or the 2611 to get this working?

Thanx again.

acomiskey Fri, 06/01/2007 - 10:25

No, the 2611 will have 1 connection to the 10 network and 1 connection to the 192 network. You can write access-lists in your router to prevent the traffic from the 192 network. There are no commands to be issued in the pix for this scenario. All the router needs is an ip address on the free interface connected to the 192 network and the acl's. Then you also have the routing problem I talked about earlier.

stemaxsin Mon, 06/04/2007 - 06:04

So taking all this into consideration, I'm understanding I need to do this...

- run a patch cable between the eth0/1 port on the 2611 and one of the open ports on the PIX

- configure the 2611 as follows:

----- eth0/0 =

----- eth0/1 =

----- int e0/1

----- description 'remote'

----- ip access-group Outbound_ACL out

----- ip access-group Inbound_ACL in

----- ip access-list ext Outbound_ACL

----- permit ip any reflect LAN_Traffic

- configure the PIX as follows:

----- static (inside,outside) netmask

----- access-list outside_access_in permit tcp host eq 8234

And that's it?

Thanx again.

acomiskey Mon, 06/04/2007 - 06:18

"- run a patch cable between the eth0/1 port on the 2611 and one of the open ports on the PIX"

or a switch on the 192. network.

You should not need those commands in the pix. Remember the communication between the 192. and 10. is on the inside of pix.

Internet -- PIX -- 192.168.1.x -- 2611 --

stemaxsin Mon, 06/04/2007 - 06:28


Then I only need the commands on the 2611 and I'm good to go?

So all the routing and "permissions" are handled via the 2611 and are transparent to the PIX since I'll have the one port on the 2611 configured with an "internal" PIX address?


acomiskey Mon, 06/04/2007 - 07:50

As I said before, the only remaining problem is this

I assume the client on the 192. network have a default gateway that is the inside of pix, only problem is that this is not the route to the 10. network. The route to the 10. network would be the 192. address on the 2611. You need a way to route this traffic.

stemaxsin Mon, 06/04/2007 - 10:11

So how do I go about solving that problem?

Is it as easy as creating a static route in the 2611? If not, what are my other options?


acomiskey Mon, 06/04/2007 - 10:17

No, a route there will do you no good as you've got to get the traffic there in the first place.

In the current topology, I think your option is to add a persistent route on the client itself on the 192. network. In windows it would be something like this from command prompt...

route add


get another router(3 port) for the connection between the 2 networks.

acomiskey Mon, 06/04/2007 - 10:35

to make the route persistent(come back after reboot) you also need to add "-p" to the route statement above.

stemaxsin Mon, 06/04/2007 - 10:46

So, in summary...

- No changes to the PIX

- Configure 2611 ports for both networks

- Add persistent route on workstation on 10 network

As it stands, I have 1 and 2 complete above, but am unable to ping anything outside the 10 network from the router and, unfortunately, the route add command you listed is not working on the workstation.


acomiskey Mon, 06/04/2007 - 10:59

the route would go on the workstation on the 192 network, not the 10 network.

stemaxsin Mon, 06/04/2007 - 11:08

I see.

Even though the networks are like this...

192.168.1.x / /

10.20.30.x / /

Will the route add work with different subnets and different gateways?

Thanx again.

acomiskey Mon, 06/04/2007 - 11:13

Ok, so the machine in the 192. network has a default gateway that is the pix most likely right

What you are doing with this is adding a route to the network via the 2611 ( You have to do this because 192.x.x.x does not reach 10.20.30.x via

route add -p

stemaxsin Mon, 06/04/2007 - 11:22

Okay, when I attempt to run the route add command on the workstation in the 10 (2611) network, I get a bad gateway error...when I attempt it on a workstation in the 192 (PIX) network, I get a bad argument error.


acomiskey Mon, 06/04/2007 - 11:29

Sorry, forgot "mask"....

route add mask -p

stemaxsin Mon, 06/04/2007 - 11:40

So, I'll need to issue the command on the workstation within the 192 (PIX) network, not the 10 (2611) network, right?


And, thanx very much for your patience in this have no idea how appreciated it is!!!


acomiskey Mon, 06/04/2007 - 11:45

Yes, 192 machine.

Well, I just hope it works out. It would have been much easier if you had a 3 port router, but that's another thread :)

stemaxsin Mon, 06/04/2007 - 11:48

Okay...I have entered the command into the 192 machine, but I still cannot ping that machine from the 10 network. However, I can ping the router from the 10 network, but only the 10 address on it...not the 192 address on the other interface.

It feels like we're getting closer now.

Any other suggestions?


stemaxsin Mon, 06/04/2007 - 11:51

Also, from the router (2611), I can ping any address on the 10 (2611) side, but nothing on the 192 (PIX) side.

Did I miss something on the router config?

Should I post my router config?


acomiskey Mon, 06/04/2007 - 12:14

Could you post a little picture of what you have currently?

Most importantly, can you ping from the 192.168.1.x machine?

stemaxsin Mon, 06/04/2007 - 13:02

I've attached an image.

Yes, I can ping the gateway from the 192.168.1.x machine (in this case, the workstation is .1 and the gateway is .21).


stemaxsin Mon, 06/04/2007 - 13:10

Remember, also, that we're trying to have data flow from the 10 (2611) network to the 192 (PIX) network...not the other way around.

Thanx again.

acomiskey Mon, 06/04/2007 - 17:20

I thought the 2611 was

Anyway, doesn't matter, it is good that you can ping the gateway but what I meant to say was can you ping the 2611 - from 192.168.1.x?

stemaxsin Mon, 06/04/2007 - 19:57

From the router (2611), I can ping...

- Ethernet0/0 =

- Ethernet0/1 =

- All 10.20.30.x addresses on the 10 (2611) network

From any workstation on the 10 (2611) network, I can ping...

- Ethernet0/0 =

From the 192 (PIX) network, I cannot ping any of the addresses (which doesn't really matter to me). I only need to be able to reach the 192 (PIX) network from the 10 (2611) network. I don't need it to work the other way around.

Hope this helps.


acomiskey Tue, 06/05/2007 - 05:00

I understand you don't want traffic to originate from 192. network, but being able to ping the router from the 192. host will prove the routing is working.

Anyway, open a command prompt on the 192. host and post a "route print".

Do you have any acl's in the router yet? Post the router config.

acomiskey Tue, 06/05/2007 - 05:17

Looking at your route print, I see a mistake. The following line is wrong, the 2611 is right? 1

You need to remove that route and add another one with the correct address.

route delete

route add mask -p

Give that a try and see if you can ping from 192. workstation.

stemaxsin Tue, 06/05/2007 - 05:25

Nope...still unable to ping the address from the workstation.


acomiskey Tue, 06/05/2007 - 05:29

2611, post a "show int e0/1" and also give the command "ip routing".

acomiskey Mon, 06/04/2007 - 17:26

This is the longest post ever!

Just realized something after seeing your new image. Your host on the 10. network needs a route to the 192. network as well. I assumed the 2611 was the gateway for 10. network, my bad.

stemaxsin Tue, 06/05/2007 - 05:11


How do I accomplish this route from the 10 to the 192?



This Discussion