OSPF Subnet Migration

Unanswered Question
May 30th, 2007

We are migrating 3 servers (10.1.0.77-79) in our existing office to a collocation cage in a different physical location. We have 4 buildings connected through an AT&T OPTEMAN multipoint circuit. These 3 servers are part of 10.1.0.66 255.255.255.192 subnet. We have 20 servers on this subnet that aren't moving. We cannot change IP addresses when moved to the new location, but the gateway can change. For now only these 3 servers will be moving, in 6 months we will be moving the rest of the servers. This is a temporary fix.

I was thinking of doing this:

1. Creating an identical vlan 200 at the new site with new address (10.1.0.71).

2. Giving vlan 200 cost of 50 (ip ospf cost 50) so that route (10.1.0.66 255.255.255.192) to the old site is still preferred.

3. Create host routes for the three servers (.77-.79) at our other locations to point to the new location.

Existing site relevant 3750 config:

interface Vlan47

description OPTEMAN to B2/B3/VC

ip address 172.18.1.1 255.255.255.224

ip pim sparse-dense-mode

ip ospf network broadcast

ip ospf dead-interval 30

ip ospf mtu-ignore

interface Vlan200

description Production Server VLAN

ip address 10.10.5.1 255.255.0.0 secondary

ip address 10.1.0.66 255.255.255.192

ip directed-broadcast

ip pim sparse-dense-mode

standby version 2

standby ip 10.1.0.65

standby priority 110

standby preempt

router ospf 10

router-id 10.1.0.2

log-adjacency-changes

area 2 range 10.1.0.0 255.255.0.0

redistribute connected subnets

redistribute static subnets

network 172.18.1.0 0.0.0.31 area 2

network 192.168.2.28 0.0.0.3 area 0

default-information originate metric 5

New site relevant 3750 config:

interface Vlan47

description OPTEMAN to B1/B2/B3

ip address 172.18.1.11 255.255.255.224

ip ospf network broadcast

ip ospf dead-interval 30

ip ospf mtu-ignore

router ospf 10

router-id 10.1.6.2

log-adjacency-changes

redistribute connected subnets

redistribute static subnets

network 172.18.1.0 0.0.0.31 area 2

network 192.168.2.0 0.0.0.7 area 2

network 192.168.2.8 0.0.0.7 area 2

network 192.168.2.16 0.0.0.7 area 2

Please advise.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
bjornarsb Fri, 06/01/2007 - 00:13

Hi,

Problem is when remaining 10.1.0.66 \26

wants to talk to 10.1.0.77-79.

So you need to tear down the network.

According to subnetting this .79 gives us a challenge. it will be the broadcast of 10.1.0.72 \ 29. and 10.1.0.72 \ 28.

So I think I would have went for NAT,

if your applications is ok with that :)

BR,

Bjornarsb

Actions

This Discussion