Setting CoS value on QinQ (ME3400)

Unanswered Question
May 30th, 2007

Hi,

I would like to set the QinQ tunnel CoS value. According to the docus:

http://cisco.com/en/US/products/ps6580/products_configuration_guide_chapter09186a008081c8ad.html#wp1008908

Last sentence before the paragraph.

"The priority field on the metro tag is set to the interface class of service (CoS) priority configured on the tunnel port. (The default is zero if none is configured.)"

Question:

how can I configure the interface default CoS value.

kind regards

VBala'zs

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
swaroop.potdar Thu, 05/31/2007 - 01:38

Yes, I gave you the option for 7600, sorry for that.

1) For the ME3400 you can configure a parent policy on the uplink trunk.

2) This parent policy will have one child policy per Vlan (External Vlan -SP).

3) When you reference the child policy you will set the COS value to the desired value.

Here is the configuration guide to configure Hierarchial Policy Maps.

http://www.cisco.com/en/US/products/ps6580/products_configuration_guide_chapter09186a0080666643.html#wp1588585

HTH-Cheers,

Swaroop

bvarga Mon, 06/04/2007 - 02:38

Hi,

I have made some lab investigation. Nice try, but I have two problems:

1. "set" commands are not supported on output policy-maps (only for input maps)

http://www.cisco.com/en/US/products/ps6580/products_configuration_guide_chapter09186a0080666643.html#wp1445053

2. Because the QinQ tunnel, the interface towards the customer is an "access" interface, therefore match on CoS is not supported.

:-(((

So it seems to be mission impossible with the 3400.

kind regards

VBala'zs

jrichesin Thu, 06/07/2007 - 16:13

There has got to be a way to do this. I am in the same boat so if anyone knows of a way to do this please post it.

Thanks,

Josh

swaroop.potdar Thu, 06/07/2007 - 21:33

VBala'zs, Josh I will try and simulate this when possible and would be glad to share the results.

If you can confirm did you try the input policy map with set cos on the ingress interface where you receive the customer traffic into the Dot1Q Tunnel port.

HTH-Cheers,

Swaroop

bvarga Wed, 06/13/2007 - 20:58

Hi,

sorry I was away for a while. Yes I can confirm. Pls see below:

...

class-map match-any best-effort

match cos 0 1 2 3

class-map match-any premium

match cos 4 5 6 7

policy-map upstream-local-marking

class premium

set qos-group 1

class best-effort

set qos-group 0

interface "towards customer"

no shutdown

switchport access vlan 100

switchport mode dot1q-tunnel

...

mflex-me3400(config-if)#service-policy input upstream-local-marking

QM: 'match cos' and 'set' from-type 'cos' supported only with Trunk

interfaces

'match cos' supported only with IEEE 802.1Q/ISL interfaces

mflex-me3400(config-if)#

regards

Bala'zs

swaroop.potdar Thu, 06/14/2007 - 23:17

hmm...well can you try this one...

mflex-me3400(config)# table-map prec-to-cos

mflex-me3400(config-tablemap)# default 5

mflex-me3400(config-tablemap)# end

mflex-me3400(config)# policy-map setcos

mflex-me3400(config-pmap)# class class-default

mflex-me3400(config-pmap-c)# set prec 5 table prec-to-cos

mflex-me3400(config-pmap-c)# exit

mflex-me3400(config-if)#service-policy input setcos

do let me know how it goes..i still havent had a chance to get my hands on this small beast :-).

HTH-Cheers,

Swaroop

Zsolt.Maj Wed, 06/27/2007 - 06:27

Hi,

The exact policy-map syntax:

!

table-map prec-to-cos

default 5

!

policy-map setcos

class class-default

set precedence precedence table prec-to-cos

Service-policy on QinQ interface:

Switch(config)#int fa0/4

Switch(config-if)#no shut

Switch(config-if)#swi mode dot1q-tunnel

Switch(config-if)#service-policy input setcos

QM: 'match cos' and 'set' from-type 'cos' supported only with Trunk interfaces

wrong encap type specified for the interface

Unfortunately it is not working.

Regards,

Zsolt

Actions

This Discussion