Echo on IP Phones with CME and PRI

Unanswered Question
May 31st, 2007
User Badges:
  • Silver, 250 points or more

Hi,


I am having issue where users report some echo on the IP phones every now and then that lasts the whole call. The echo they hear is their voice back on the IP Phone. The outside party does not hear echo.


The T1 PRI controller is clean, no errors and the router network-clock is set to use the PRI. We have tried setting the network-clock to defaults to use backplane and that had no change.



CME is on a 2811 with IOS 12.4(6)XE2

c2800nm-ipvoicek9-mz.124-6.XE2.bin


voice-port 0/0/0:23

input gain -3

output attenuation 3

music-threshold -45


Here is phoneload. Should I update these?


telephony-service

load 7914 S00104000100

load 7941 SCCP41.8-0-4SR2S.loads

load 7961 SCCP41.8-0-4SR2S.loads


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
paolo bevilacqua Wed, 06/06/2007 - 09:57
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hello,


if you do "show voice dsp", which dsp firmware do you have? If not the latest I would suggest upgrade IOS before proceeding further.

dgahm Wed, 06/06/2007 - 10:44
User Badges:
  • Blue, 1500 points or more

Erick,

Have you tried any changes to the echo canceller settings on the PRI? I have had good luck with bumping the worst case erl from the default 6 to 3 db.


voice-port 0/0/0:23

echo-cancel erl worst-case 3


Dave

Erick Bergquist Wed, 06/06/2007 - 11:05
User Badges:
  • Silver, 250 points or more

Yes, we have and with anything other then the defaults the users say it is worse. so we are back to the defaults and no reported issues for 5+ days again. We were good for 3-4 days before, then had one day with the issue and now clear for past 5 so maybe they have some on/off issue with the PRi circuit causing some issue.


The IOS is 12.4(6)XE2 and DSPware is 9.2.0 in that


I am thinking of trying to get new phoneloads on there. Can I go to latest 12.4.11T2 from 12.4(6)XE2 without issues or losing anything that is in this XE2?


Erick

dgahm Wed, 06/06/2007 - 11:32
User Badges:
  • Blue, 1500 points or more

Erick,

Since the echo is heard on the IP phone side it is the PRI echo canceller that is not able to cope with the reflected signal from the far end. Phone loads should not have any effect on this.


I would suspect that a specific far end phone system is causing you grief. Of course you can't fix someone elses phone, but it is very useful to find a number you can call that results in echo, allowing you to make changes and test.


This is a good doc for echo problems.


http://www.cisco.com/en/US/tech/tk652/tk698/technologies_tech_note09186a0080149a1f.shtml


Dave

paolo bevilacqua Wed, 06/06/2007 - 12:36
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hello,


latest dsp firmware is 9.2.2 and I know for sure that is in latest 12.4(11)XJ3. Not sure sure about 12.4T.

As Dgham suggested, the issue is with the echo chanceller in the DSP, and the phoneload should not make a difference.


Actions

This Discussion