Configuring switchport for non Cisco IP phones?

Unanswered Question
May 31st, 2007
User Badges:

What is Cisco's definitive recommendation for configuring Cisco switchports when using non-Cisco IP phones with a PC connected to the IP phone? We are using Avaya IP phones.


I've seen several different configs, with pros and cons for each, but I would like Cisco to tell me which is their Best Practice recommendation.


Here are three examples I've seen:


data vlan = 60

voice vlan = 910


1.

interface FastEthernet1/0/2

switchport access vlan 60

switchport voice vlan 910



2.

interface FastEthernet1/0/3

switchport trunk encapsulation dot1q

switchport trunk native vlan 60

switchport mode trunk

switchport voice vlan 910



3.

interface FastEthernet1/0/12

switchport access vlan 60

switchport trunk encapsulation dot1q

switchport trunk native vlan 60

switchport trunk allowed vlan 60,910

switchport mode trunk

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
m-haddad Thu, 05/31/2007 - 09:27
User Badges:
  • Silver, 250 points or more

Hello,


Configuration 1 is usually compatible with Cisco IP phones because the switch will determine that there is an IP phone connected and will split the traffic accordingly.


IN the second configuration you are negotiating a trunk. As I said in this configuration you are using a Non-Cisco Phone where you are creating a trunk so you can pass multiple VLANs over the port. This configuration is also applicable for Cisco IP Phones.


The last one is the same as the second however, you are securing the trunk by allowing those specific VLANs. Thus if a user tries to do some attacks and tag traffic with different VLAN tag it will be dropped. Moreover, you are setting all untagged traffic to the data VLAN.


I personnaly perfer to set the port as access and use config 1 incase I am using Cisco IP Phone. This would alliviate the security risks in having a trunk with user devices. In case you are using Non cisco Ip phone config 3 is more secure than 2 because you are filtering vlans over the trunk.



Hope this helps and answers your questions,


Regards,


manumohan200 Thu, 05/31/2007 - 12:20
User Badges:

Hi,


I have a doubt regarding this.

Cisco Switches segregates Voice and Data traffic by using the CDP packets coming Cisco IP Phones. But in the case of non Cisco IP Phones, how can the Switch determine the voice vlan ? It will be part of data vlan only.


Thanks,

Manu

m-haddad Thu, 05/31/2007 - 12:32
User Badges:
  • Silver, 250 points or more

Hello,


The switch determines that there is a Cisco IP Phone connected via CDP. However, in case of non-cisco IP Phone a trunk is negotiated and the IP Phone will be configured to tag packets.


IN short, the IP Phone will be configured to tag packets.


Regards,


manumohan200 Thu, 05/31/2007 - 12:37
User Badges:

Hi,


Thanks for your reply.


But how switch segregates between voice and data packets. Which packets will be tagged by the IP Phone ?


Thanks,

Manu

m-haddad Thu, 05/31/2007 - 12:49
User Badges:
  • Silver, 250 points or more

Hello,


I have experience with Nortel where the phone is configured to tag voice traffic for example with 60 and Data traffic with 80.


Honestly, I am not that experience in other vendor's phones and I have configured switchports for Nortel.


Soon, I am going to configure switchports for Avaya and I would know how Avaya does traffic segregation.


Regards,



Regards,




manumohan200 Thu, 05/31/2007 - 12:52
User Badges:

Hi,


Thanks for your reply. Please share your Avaya experience also once you are done as I am also going to configure the same soon.


Thanks,

Manu

m-haddad Thu, 05/31/2007 - 12:56
User Badges:
  • Silver, 250 points or more

You're Welcome and will paste a sample config.


Regards,


SarRas1981 Sat, 04/27/2013 - 06:58
User Badges:

Hi


Kindly could you advise me with following :


i have a nortel ip Phone 1140E version , and 2901 Voice Gateway (2901 CME) , and i need the way to Confiure the nortel ip phone and give it Extension from 2901 CME, could you help me plz?


thanks

Actions

This Discussion