Tomcat Servlet Engine not running in LMS 2.5 Server

Unanswered Question
May 31st, 2007

Hi,


Hope someone can help me. Our LMS server suddenly stop running and when i checked the Windows 2003 Services, it shows that the Tomcat Servelt Engine is not running and failed to start, so with the Apache service, I did try to run them manualy but the Tomcat failed to. So nothing happens in accesing the LMS. I tried to checked also the Event Viewer under System and it shows that Ciscoworks Tomcat Servlet failed to start (Event ID: 7034). Please help. Thanks.



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Thu, 05/31/2007 - 20:17

Whatever you do, do not touch the services in the Services control panel. They cannot be started and stopped individually. Please provide the NMSROOT\MDC\tomcat\logs\stdout.log.

jnerecina Thu, 05/31/2007 - 22:24

Hi jclarke,


I already formatted the whole disk and have no more backup of that file. I tried to re-install everything but the probplem is still the same. same error messages. i was wondering why. im using Windows 2003 SP1.


I tried to downgrade to Windows 2000 and everything is fine. But when I try to install it to Windows 2003, the problem occurs. We are instructed to used the Windows 2003 server. Thanks.

Joe Clarke Thu, 05/31/2007 - 22:26

If the problem is the same, then get the current stdout.log after reproducing the problem. I have a feeling you're hitting CSCsh79993.

jnerecina Thu, 05/31/2007 - 22:35

Hi jclarke,


I have installed Common Services 3.0 only to the new installed windows 2003. and there are no stdout.log file. i was trying to search the bug ID that you gave but it seems I am not allowed to. can you give me information about the bug id? thanks.

Joe Clarke Thu, 05/31/2007 - 22:40

If NMSROOT\MDC\tomcat\logs\stdout.log is not being created, then that means Tomcat isn't even trying to start. This reinforces the possibility of CSCsh79993. Basically, this bug talks about a bug in Microsoft HotFix MS06-040:


Symptom:


The CiscoWorks Tomcat daemon does not start and pdshow reports that it failed to run. Additionally, Windows may report that "A desktop heap allocation failed."


Conditions:


This occurs on Windows 2003 Service Pack 1 after applying the Microsoft HotFix for MS06-040 (see http://support.microsoft.com/kb/921883/ for more on what this HotFix does).


Workaround:


There is no workaround, but Microsoft does offer a fix. Currently, one must contact Microsoft directly to obtain it. See http://support.microsoft.com/kb/924054 for more information on this fix.


NB: Microsoft integrated the fix for the memory allocation problem into the MS06-040 HotFix on September 12, 2006.. Therefore, if the current version of the HotFix is applied, this problem will not occur.


This would indicate that the Windows 2003 you are installing is a corporate pre-created image. If you can install a vanilla 2003, then apply SP1, you should not have this problem. If Tomcat is still not starting, you should open a TAC services request as the next step will be to run Tomcat manually and check the output.

a.olsthoorn Thu, 09/11/2008 - 06:33

Hi,


I run ito this same problem but then on an vmware system running win 2003 R2 Sp2. I installed LMS 3.1 on it today. No errors reported, installation succesfull. I installed all apps incl HUM, except Integration module.

No stdout.log no tomcat service running, no Apache started.

We've deinstalled the vmware tools on system manager's advise.


What can I check?


regards

Ad

Actions

This Discussion