Phone not obtaining IP address from Router (CCME)

Answered Question
Jun 1st, 2007

Hi,

I'm having problems with Call Manager Express and the registration of ephones in that the phones do not obtain an IP address from the router. I've attached the config for the C2851 router and c3650 switch I'm using. The router software is c2800nm.spservicesk9-mz.124-3e.bin. The phone simply hangs displaying Configuring IP. The router console shows no activity, either does the debug dhcp events. Phones are 7940G, 7960G and 7961G. Phones are powered via PoE.



Correct Answer by johnnystahlhut about 9 years 9 months ago

Hi.

In the switch, try sh vlan

I think you don't have created the voice vlan 700 in the switch.

You don't need the command "switchport trunk encapsulation dot1q "

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
ssielaff Fri, 06/01/2007 - 06:47

If you do a show cdp neighbot on the switch do you see the phones? are you sure they are plugged into the right ports?


You need to add the


switchport trunk encapsulation dot1q


line to the switch ports so they can see your set the phone vlan to 700



wayne.spendlove... Sat, 06/02/2007 - 06:21

Hi,


Thanks for the reply.


Did a sh cdp neighbor and I can see the phones. The phones are definitely plugged into the right port. Tried the switchport trunk encapsulation dot1q without success, phone set to vlan700 already. Strange thing is that I cannot ping the router 10.15.0.1 from the switch and vice-versa however I can ping the router from a PC connected to the switch therefore I know the switch is functioning. This configuration has been one I've used on quite a few implementations without having any issues.


Any idea's?

Paolo Bevilacqua Sat, 06/02/2007 - 07:16

Hello,


all indicates some misconfiguration most likely in the router. I'm not going over your posted configs because by the time now, you may have changed them already. As you said, the configuration is standard and must work. I'm sure that with a little of patience and the right "show" command (eg, mac address table, arp, etc), you will find why you can't ping and why the phones are not getting address.



wayne.spendlove... Sat, 06/02/2007 - 07:54

Hi,


I've checked the config line by line several times only to get more frustrated each time. The only config change (switch) is as above. I'd welcome any help on this one, would be very grateful. Thanks

Paolo Bevilacqua Sat, 06/02/2007 - 09:43

Hello,


On the switch please remove all :

- mls commands

- srr commands

- priority-queue commands


On the router, remove all nat commands.


The idea is to start again with a fresh, minimal configuration.


The switch must ping all router address, and vice-versa. Then check "show mac-address-table dynamic" and check the router MAC are in there.




wayne.spendlove... Sat, 06/02/2007 - 11:01

hi, thanks for your reply, will try tomorrow morning (uk time) and get back to you, many thanks.

Correct Answer
johnnystahlhut Sat, 06/02/2007 - 13:58

Hi.

In the switch, try sh vlan

I think you don't have created the voice vlan 700 in the switch.

You don't need the command "switchport trunk encapsulation dot1q "

Paolo Bevilacqua Sat, 06/02/2007 - 14:38

Hello,


in switches, a vlan is created automatically when referenced in a "switchport" command, and a warning is given.

The switch doesn't have a layer3 interface to the voice vlan, as that doesn't appear to be necessary.

Perhaps tomorrow the issue will be solved and we will know from what it was caused.


Paolo Bevilacqua Sat, 06/02/2007 - 15:56

Hmm, no. See following example when configuring a 3550 with a voice vlan that did not exist previously:


L3Core(config)#int gi0/8

L3Core(config-if)#switchport voice vlan 300

% Voice VLAN does not exist. Creating vlan 300

L3Core(config-if)#^Z

L3Core#sh vlan id 300


VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

300 VLAN0300 active Gi0/1, Gi0/8


VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

300 enet 100300 1500 - - - - - 0 0


Now, for the case in question, is absolutely not necessary that the switch does inter-vlan routing for the voice vlan. The CCME router will do that via the trunked port.

Note, the only case in which you need inter-vlan communication with the voice VLAN, is when you want to access phone's web server for diagnostic purposes. Else, all the phones and CCME communication is confined within the voice VLAN.



wayne.spendlove... Mon, 06/04/2007 - 05:03

Hi,

Please refer to reply above.


sh vlan did not show VLAN700 or VLAN999 and therefore I created them using vlan vlan700 and vlan vlan999, did a no shutdown and everything worked. Very strange in the the first switch would not create them automatically during config whereas the second switch did. Thanks

wayne.spendlove... Mon, 06/04/2007 - 04:58

Hi,

Removed all the commands as advised and this made no difference at all. Rebuilt the switch as a minimal config and still did not work. Used another switch with same minimal config and this did work, added the rest of my config and it still worked. First switch was 12.2(25)SEB4 and the second was 12.2(25)SEE2. Router MAC was listed along with phones however phones were not associated with VLAN700. See replies below.

Actions

This Discussion