EIGRP UP/DOWN

Unanswered Question

Hello experts!

how can i solve the the up/down neighbor relation ship in eigrp;kindly have a look to these output:


*Mar 3 23:39:19.686: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 183.1.78.8 (FastEthernet1/14) is down: peer restarted

SW1(config-router)#

*Mar 3 23:39:24.370: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 183.1.78.8 (FastEthernet1/14) is up: new adjacency

SW1(config-router)#

*Mar 3 23:39:34.194: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 183.1.78.8 (FastEthernet1/14) is down: peer restarted

SW1(config-router)#

*Mar 3 23:39:37.882: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 183.1.78.8 (FastEthernet1/14) is up: new adjacency

SW1(config-router)#

*Mar 3 23:40:39.342: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 183.1.78.8 (FastEthernet1/14) is down: peer restarted

*****************************************************************

*Mar 3 09:14:04.153: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 183.1.78.7 (FastEthernet1/14) is down: peer restarted

SW2(config-router)#

*Mar 3 09:14:10.205: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 183.1.78.7 (FastEthernet1/14) is up: new adjacency

SW2(config-router)#

*Mar 3 09:14:20.413: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 183.1.78.7 (FastEthernet1/14) is down: peer restarted

SW2(config-router)#

*Mar 3 09:14:26.453: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 183.1.78.7 (FastEthernet1/14) is up: new adjacency

SW2(config-router)#

*Mar 3 09:15:35.953: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 183.1.78.7 (FastEthernet1/14) is down: peer restarted

SW2(config-router)#

*Mar 3 09:15:42.021: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 183.1.78.7 (FastEthernet1/14) is up: new adjacency


what action could i take?

i Truly appreciate ur Kindness reply!

10xs

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
bamnocadmin Fri, 06/01/2007 - 09:10
User Badges:

Hello,


I suggest to use debug first to see EIGRP events. You can also try to adjust interval between hello packets and the hold time. Check bandwidth parameters on the interfaces.


Thanks.



Richard Burts Fri, 06/01/2007 - 09:45
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Ali


From the prompts and the addresses we can tell that the error messages came from the 2 EIGRP neighbors. We can not tell whether they came from the same time (and the clocks are just seriously out of sync) or whether they came from different times. Perhaps you can clarify.


One thing I would look at is whether there is much packet loss over this link. Use extended ping from one interface to the other, send 2000 pings and see if there are packet drops.


I am wondering if there might be a duplex mismatch between the 2 interfaces. Perhaps you can post the configuration of both interfaces and of router eigrp on both boxes.


HTH


Rick

Hi Rick!

Kindly check this output:

interface FastEthernet1/14

no switchport

ip address 183.1.78.7 255.255.255.0

duplex full

speed 100

*******************************************

interface FastEthernet1/14

no switchport

ip address 183.1.78.8 255.255.255.0

duplex full

speed 100

*****************************************

sw1

network 183.1.7.7 0.0.0.0

network 183.1.17.7 0.0.0.0

network 183.1.78.7 0.0.0.0

no auto-summary

eigrp router-id 150.1.7.7

**************************************

sw1

network 150.1.8.8 0.0.0.0

network 183.1.58.8 0.0.0.0

network 183.1.78.8 0.0.0.0

no auto-summary

10xs for ur reply

Richard Burts Fri, 06/01/2007 - 12:11
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Ali


Thanks for posting the additional information. From the configuration it certainly appears that both interfaces are manually set for speed and duplex. So duplex mismatch should not be an issue.


Can you try the extended ping with many ping packets and let us know if there is any packet loss?


Are these devices directly connected or is there any other piece of hardware in between them?


HTH


Rick

ruwhite Sun, 06/03/2007 - 03:49
User Badges:
  • Gold, 750 points or more

If these are the only two neighbors on this link, this is a rather odd set of output messages.... When log-neighbor-changes prints out "peer restarted," that means the other router has transmitted an empty update with the init bit set. That generally means the other side thinks the neighbor relationship has gone down, come back up, and has received a hello from the local router, all within the dead interval. In other words, one side thinks the adjacency has reset, while the other thinks it's fine.


The only conclusion I can come to, I think (?), is that these two outputs are so distant in time that we don't see the other side at the same time. What you really need to do is--when you see this message on one side, pop over to the other router quickly, and grab the log from that side. If you don't have the log being saved, then telnet to both sides at the same time, and watch both for a while.


The reason is actually pretty critical to figuring out what the next step is. Is it the dead timer expired? Is it a retansmission timeout? Or is it an SIA? Each of these require different sorts of troubleshooting.


:-)


Russ

ganpatspatil Sun, 06/03/2007 - 21:47
User Badges:

I think it is not related to any timer mismatch,as EIGRP nieghbour will happen only when AS number and K values are match.


As default Bandwidth and Dely is used pls chk these value on both sides....also chkeck wheather this default setting is changed .....?

Actions

This Discussion