enable spanningtree portfast on switch for AP1200

Unanswered Question
Jun 1st, 2007
User Badges:

Hi do i enable spanning tree portfast on a switch connting to a ap1200 my current configuration is:


interface FastEthernet0/20

description Wireless_2_W_1

switchport trunk encapsulation dot1q

switchport mode trunk


i am getting a lot of flapping and was wondering if this could help

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
scottmac Fri, 06/01/2007 - 11:30
User Badges:
  • Green, 3000 points or more

I don't think that portfast works with trunk ports, only access ports ... perhaps that's part of the problem.


STP will normally keep a port down for ~55 seconds, once it's up, it's up....until the other end drops (powers down, for example)or you reset / power-cycle the switch.


What is the timeframe of the flapping cycle how long down, how long up)?


Do the logs give you any error mesages?


What error messages do you see at the consoles of the AP and switch?


Let us know, or post 'em ....


Good Luck


Scott


network_team Sun, 06/03/2007 - 23:29
User Badges:

Hi these are the message i get on the core switches


24w2d: %C4K_EBM-4-HOSTFLAPPING: Host 00:16:6F:42:8A:33 in vlan 22 is flapping between port Gi2/18 and port Gi2/5


This i drill down to the access switch where the wireless device is attached: But this has no error the erros are seen on the cores above. No errors on the ap just core switches Hostflapping





mark.j.hodge Mon, 06/04/2007 - 07:10
User Badges:
  • Bronze, 100 points or more

Is this happening on lots of wireless client MAC addresses or just one?


Do you have more than one access point?


I have seen this behaviour when the client has bridged his Ethernet and Wireless adapters together, it actually caused a loop in the network and a broadcast storm ( The APs were not Cisco ).


It might also happen if there are two access points on the same channel, the client may send one conversation via one AP, and others through the second AP.


** Please Rate posts if helpfull **

mscherting Tue, 06/12/2007 - 08:46
User Badges:

This is typical of what I use:


interface GigabitEthernet3/46

description Wireless AP76

switchport access vlan 177

switchport trunk encapsulation dot1q

switchport trunk native vlan 177

switchport trunk allowed vlan 113,177,190,814

switchport mode trunk

speed 100

duplex full

spanning-tree portfast trunk

spanning-tree bpduguard disable

end


Depends too on whether the switch supports dot1q trunking natively. The 4503 switch in this example doesn't. 2950s do.

Richard Bradfield Wed, 06/13/2007 - 17:57
User Badges:
  • Silver, 250 points or more

you will get this if you have mobile wireless clients as they move between APs, on on the Switch interface the APS are connected to I put the following command to supress these messages


no logging event addr-flap


HTH

Richard.

Actions

This Discussion