Accessing Unity with term serv "/console" switch

Unanswered Question
Jun 1st, 2007
User Badges:

I ran across a weird problem the other day. After installing Unity, it registering with CallManager and everything looking good, Unity either would not answer calls at all (phone just rings when trying to call voice mail) or it would answer then immediately drop the call. The Windows APP log showed a bunch of MIU errors for each failed call attempt.


To make a long story short, I found that when logged in to the Unity server via RDP using the "/console" switch (mstsc /v:<ip address> /console", it causes the problem. As soon as I log out of the console session, Unity works fine. Logging in to a "normal" RDP session, physically logging in to the console, or logging in through the server's iLO port does not cause this problem.


Just for grins, I tried it on another Unity server that's been up and running with no problems for about 5 years and the exact same thing happened.


What is it about the "/console" switch that causes the problem? Not that it's a big issue because the server is working fine. I'm just really curious about this.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Ginger Dillon Fri, 06/01/2007 - 10:53
User Badges:
  • Blue, 1500 points or more

Hi -

Cisco has this documented as not supported for Unity servers. We encountered this back in 2005 and instructed anyone using terminal services NOT to use console only mode for Unity. In our case, we had to reboot Unity, this was pre-4.2(1) to correct the problem, many 822 errors in the application event log and Unity ceased to function.

Ginger

mbell Fri, 06/01/2007 - 11:06
User Badges:

I've seen documentation regaring the _installation_ of Unity using TS but I've never seen anything about the "/console" switch. Would you happen to have a link to that? I searched the Cisco Web site but didn't see anything.


I understand that this is not supported but I'm just trying to understand _why_. I've used TS /console with many other applications on many Windows servers and I've never seen this issue. What is it about Unity and the /console switch that causes the problem, i.e. how can just logging in with the /console switch hose up software that's running in the background? That's what I'm trying to figure out.

acleri Wed, 06/06/2007 - 03:39
User Badges:

Same problem but also with normal rdp session.....

Once I connect through rdp the unity does not answer anymore or answer and drop the call immediately!!!

MIU errors on application logs appears.


Ginger Dillon Wed, 06/06/2007 - 15:40
User Badges:
  • Blue, 1500 points or more

Hi -

In your RDP Gui, make sure you don't have the /console included after the server name or IP address. I use normal RDP to connect with Unity without problems.

Ginger

acleri Wed, 06/06/2007 - 23:32
User Badges:

I used normal rdp session without the console switch and I get the error.

Once connected with rdp the only solution to restore the unity functionality is to reboot it. Temporary I disabled rdp.


TMcCarroll Wed, 06/13/2007 - 14:07
User Badges:

Seen similar on a Unity Connection box too - unityC stops responding after any RDP (console or session). Seems that Unity and MS don't play nice together when both try to make requests to the WaveOut virtual device in Windows. There's a bugID against it, can't remember the ID, but it recommended that if you really wanted to use RDP to connect, 1)don't connect to the console session (/console etc) and 2) Set the 'Local Resources' option (eg in the GUI) 'Remote computer sounds' to 'Do not play'.



Actions

This Discussion