Backup/Restore of IPCCX 4.0 after Patching

Unanswered Question
Jun 1st, 2007
User Badges:
  • Silver, 250 points or more

Now that IPCCX 4.0(5)SR1 is available, what would be the process to restore a CRS 4.0 node from a BARS backup?


If the server is rebuilt using 4.0(5) media and the Repair -> Restore option is chosen will it recover the data from a BARS backup of 4.0(5)SR1, or would SR1 have to be applied at some point either before or during the recovery process?


I would guess that whatever the process is, it's similar for IPCCX 4.0(4) and its associated service releases.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
wenqianyu Sun, 06/03/2007 - 18:01
User Badges:

Hello there,


I can not answer your question. Instead I would like to ask you a question about CRS Restore.


I have a CRS 4.0(5) and backed it up using BARS. To test restore, I installed another server with the same IP address and Server name as this CRS server. After OS installed, I installed CRS by choosing the same LDAP server and Cluster name. After click Recover botton, it staretd to install 4 CDs.


After CRS installation, I installed BARS on this server as Backup Server. Then I started BARS Restore. The Restore went to 73% and the failed with "Unspecified Error".


I do not see an option as you mentioned "Repair -> Restore". Could you please tell me where to get this option. If you can post your procedure of BARS restore here, it would be a great help. I read doco for BARS, but the restore for CRS is quite different in my test (compare with the description in the doco).


Thanks a lot.


mmelbourne Mon, 06/04/2007 - 01:11
User Badges:
  • Silver, 250 points or more

I've also attempted a test restore in the lab environment and encountered the same issue. The BARS process appeared to fail on the BARS Server during Restore. I haven't had time to view the log files, though the BARS log just indicates a failure due to an "unspecified error". I don't know whether there is anything more helpful in the MVCD log files.


I agree, the Recovery process as documented in the 4.0(5) installation guide is different to what actually happens in practice. When I first attempted an installation on a clean server, the only option was to "Update Node". I went through this, and then re-ran the installer a second time and selected Repair -> Restore from the installation options (other options include Install and Remove), and then started a BARS Restore (as per the documentation). It was during this phase, that the BARS Restore failed with the "Unspecified Error".


I was attempting to recover a single node from a pre-HA backup. When a single node of an HA backup is restored, BARS appears to contact the other node, so this must be available. If both nodes are selected to recover, then both nodes need to be recovered together. I didn't have the hardware to try this, so reverted to the single node pre-HA backup.


Has anyone successfully recovered IPCCX 4.0(5) from a BARS backup?

Actions

This Discussion