How to set 1811 router with a DSL connection

Answered Question
Jun 3rd, 2007

Hi,

I am trying to configure my Cisco 1811 to work with a BellSouth/ATT DSL connection. My FE1 port is connected to ATT?s DSL modem. The interface is up and I have defined a PPPoE connection over this interface.

Here are the issues that I am having:

1. In order to get the static IP, DNS and gateway information, I have connected the DSL router to my computer?s port and defined a PPPoE connection. I have noticed a few strange parameters:

a. The IP address is: 74.173.58.*** and the subnet mask is 255.255.255.255 . I am not sure if the subnet mask is valid, when I try to enter those parameters to FE1 parameters, it tells me that the subnet mask is invalid. I have changed the IP Address mode to IP negotiated and it works however I rather set the IP to be static. What should I do?

b. The gateway is the same as the IP address, does it make sense?

c. I do not have DNS server in my internal network (For now) so I rather use the ISP DNS servers directly. I have entered the DNS servers that appeared under my computer?s IPConfig /all list. Is that ok?

2. When trying to ?Test the Connection? , I have selected the ?Automatically determined by SDM option and started the test. The test fails when it gets to: ?Checking Exit Interface? and I get the following error message: The specified hostname/IP address is not routed through the selected interface. / Specify a hostname/ip address routed through the selected interface or add a 'host specific/network specific/default' route through this interface and retest connection.

I could not find how to follow the recommendation and the only thing that was close was the Routing section. I do not know if it make sense but what I have tried to do is to define a default route (Prefix/Prefix Mask set to 0.0.0.0) and the forwarding is set to the IP Address/gateway. I have to restart interface FE1 however I keep getting this error message.

I have attached a text file with a copy of the config below. Can you please help?

THANK YOU, JOE

Attachment: 
I have this problem too.
0 votes
Correct Answer by Paolo Bevilacqua about 9 years 6 months ago

Hi,

ignore ICMP redirect that is not the problem.

Now, if you do "show run" you should see the default route you entered previously. Again, the command is "ip route 0.0.0.0 0.0.0.0 dialer0" in global configuration mode, or "ppp ipcp route default" under "interface dialer0".

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Paolo Bevilacqua Sun, 06/03/2007 - 17:49

Hello,

I would forget about SDM that can be confusing.

Do you know how to telnet to the router and do "conf t" manually?

Do not put IP addresses on the interface, as you are using PPP. Under dialer0, configure "ppp ipcp request default-route".

The from EXEC prompt type "show interface". You should have one virtual access, check that is up/up. If not, you may have an authentication problem.

Let us know.

oren202020 Sun, 06/03/2007 - 18:26

Hi,

Thanks for your reply. I know how to connect to IOS.

I have tried to enter the dialer0 configuration mode and type the following command:

ppp ipcp route default (I couldn't find the exact command you have specified, is my command correct?)

After doing it, I have saved the configuration and reboot the router. I logged back to the IOS interface and tried to ping google and a few other websites. I get a message that the router is trying to translate the address and then it fails. I have also tried to ping various IP addresses without any success.

What am I doing wrong?

I have attached a text file with the status of the interfaces.

Thanks,

Joe

Attachment: 
Paolo Bevilacqua Sun, 06/03/2007 - 18:44

Good news, you are about to have this working

And apologies, I misspelled the command, actually is:

ppp ipcp default route

however, if you configure

ip route 0.0.0.0 0.0.0.0 dialer0

that will have the very same effect, and you should be able to ping outside.

Couple more notes, under dialer0, configure

no cdp enable

this is a protocol not active on your WAN connection.

And, you do not need to worry about obscuring your MAC address, these are never propagated outside your router.

Hope this helps, please rate post if it does!

oren202020 Sun, 06/03/2007 - 19:08

Hi,

Again, thanks for your invaluable help. I have added the ip route command and the no cdp however there is no change.

Is there anything else I can try? Can the problem be firewall related? (I try to ping from IOS...)

THANKS

Paolo Bevilacqua Sun, 06/03/2007 - 19:30

Hi,

please do "show ip route", you should see the default route you entered, and one route type "C" with mask 255.255.255.255, try to ping that address.

If that fails, please try:

conf t

access-list 101 permit ip 192.168.0.0 255.255.255.0 any

no ip nat inside source list 1 interface Dialer0 overload

ip nat inside source list 101 interface Dialer0 overload

If still fails, please send output of "show ip route".

oren202020 Sun, 06/03/2007 - 20:03

Hi,

I think that you've found the problem. The show IP route command tells me that the default gateway is not set and there aren't any routes.

I also get the message ICMP redirect cache is empty. Have I missed anything?

Thanks,

Joe

Correct Answer
Paolo Bevilacqua Sun, 06/03/2007 - 20:15

Hi,

ignore ICMP redirect that is not the problem.

Now, if you do "show run" you should see the default route you entered previously. Again, the command is "ip route 0.0.0.0 0.0.0.0 dialer0" in global configuration mode, or "ppp ipcp route default" under "interface dialer0".

oren202020 Thu, 06/07/2007 - 17:44

Hi,

I am sorry for the late reply. I have managed to resolve the issue. Basically, what I have done is reset the switch to factory default and re-configure it from scratch. I guess that when I tried to get it up and running for the first time, I have screwed up some settings.

Thank you very much for your great assistance. I am going to rate you soon.

Regards,

Joe

Actions

This Discussion