setting qos

Unanswered Question
Jun 4th, 2007

I config the qos as follwing:

we would like

24M for VoIP min

34M for VoIP max

class-map match-any AutoQoS-VoIP-RTP-Trust

match ip dscp ef !Interactive Voice

class-map match-any AutoQoS-VoIP-Control-Trust

match ip dscp cs3 !Telephony Signaling

match ip dscp af31 !voice signaling



policy-map AutoQoS-Policy-Trust

class AutoQoS-VoIP-RTP-Trust

priority percent 70

class AutoQoS-VoIP-Control-Trust

bandwidth percent 5

class class-default



interface Serial1/0

ip address

auto qos voip trust

dsu bandwidth 44210

service-policy output AutoQoS-Policy-Trust

rate-limit output access-group 130 24000000 10000000 2000 conform-action continue exceed-action drop

access-list 130 permit ip

anything we need to improve it? thanks

best regards

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.5 (2 ratings)
hoogen_82 Mon, 06/04/2007 - 08:42

The priority percent is best recommended to be at 33% of the bandwidth available to you.

Also consider this configuration


class-map match-any VOIP

match ip dscp ef

match ip dscp cs3

match ip dscp af31


class-map match-any VOIP_CONTROL

match access-group V_Control


class-map match-any Untrust_VOIP

match access-group Voice_Udp



policy-map QOS

class Untrust_VOIP


set dscp ef



set dscp af31

class VOIP

set dscp default

class class-default



interface fastethernet 0/1

description Output interfaces

service-policy output QOS


ip access-list V-Control

permit tcp any any eq 1720

permit tcp any any range 11000 11999

permit udp any any eq 2427

permit udp any any eq 2428

permit tcp any any range 2000 2002

permit udp any any eq 1719

permit udp any any eq 5060


ip access-list Voice_Udp

permit udp any any range 16384 32768




Do rate if you find this post helpfull :)

ariela Mon, 06/04/2007 - 09:04


another little recommendation: use a policer "always-on" for voip traffic, is the best solution to improuve the QoE (quality of experience) about your voice service. See this example:


policy-map QOS

class VOIP




In this case, the policer prevents an oversubscription use of exceeded bandwidth, so in case of congestion your Customer won't experience a worsening of QoS (example: call drop).





This Discussion