LLQ for 871 in PPPoE scenario: how?

Unanswered Question
Jun 4th, 2007

Hi folks,

I've some troubles using a 871 and LLQ for voice traffic in PPPoE scenario.

In my experience, to activate the LLQ QoS policy in this case I've to use a PPP multilink. But when I try to check the connection, I see a % of packet loss:

May 31 20:15:40.143: Vi2 MLP: Lost fragment 4CE (all links out of sequence), class 0.!!!!!!!!!!!!!!!!!!!!!!!!!.!!!!!!!!!!!

Success rate is 96 percent (48/50), round-trip min/avg/max = 16/16/24 ms

c871-TestPPPoE#

May 31 20:15:43.646: Vi2 MLP: Lost fragment 4E9 (all links out of sequence), class 0

My configuration:

871

---

c870-advipservicesk9-mz.124-11.T2.bin

!

class-map match-any VoIP

match ip dscp ef

!

!

policy-map Dial0_Out

class VoIP

priority 500

class class-default

fair-queue

!

!

interface FastEthernet4

description *** WAN ***

bandwidth 15000

no ip address

ip nat outside

ip virtual-reassembly

ip tcp adjust-mss 1452

speed 100

full-duplex

pppoe enable group global

pppoe-client dial-pool-number 1

!

!

interface Dialer0

bandwidth 15000

ip address negotiated

ip mtu 1452

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

no cdp enable

ppp chap hostname <removed>

ppp chap password <removed>

ppp multilink

ppp multilink interleave

ppp multilink fragment delay 10

ppp multilink multiclass

service-policy output Dial0_Out

!

BRAS

----

c7200-jk9s-mz.122-15.T16.bin

!

class-map match-all Voip_WiFi

match ip dscp ef

match ip precedence 5

!

!

policy-map QoS_Wifi_Downstrean

class Voip_WiFi

priority percent 33

class class-default

fair-queue

!

!

bba-group pppoe BBA2

virtual-template 2

sessions per-vc limit 20050

sessions per-mac limit 3000

sessions per-vlan limit 20050

!

!

interface Loopback0

ip address yy.110.159.254 255.255.255.255

!

interface GigabitEthernet0/0.4093

description ***Test PPPoE***

encapsulation dot1Q 4093

ip access-group 101 in

no ip proxy-arp

pppoe enable group BBA2

!

interface Virtual-Template2

description ***PPPoE Test***

mtu 1492

ip unnumbered Loopback0

ip access-group 101 in

service-policy output QoS_Wifi_Downstrean

no peer default ip address

keepalive 5

ppp lcp delay 0

ppp authentication chap 7206

ppp authorization 7206

ppp accounting 7206

ppp multilink

ppp multilink fragment-delay 10

ppp multilink interleave

ppp multilink multiclass

!

For QoS point of view, I see that the policy is applied on Dia0, and packets match the policy-map.

The virtual interfaces are:

c871-TestPPPoE#sh user

Line User Host(s) Idle Location

* 0 con 0 admin idle 00:00:00

Interface User Mode Idle Peer Address

Vi1 PPPoE 00:00:00

Vi2 MLP Bundle 00:01:04 yy.110.159.254

On Vi1 no policies are applied, on Vi2 the policy-map is applied but no packets match:

c871-TestPPPoE#sh policy-map interface vi2

Virtual-Access2

Service-policy output: Dial0_Out

Class-map: VoIP (match-any)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: ip dscp ef (46)

0 packets, 0 bytes

<omissis>

Class-map: class-default (match-any)

1135 packets, 133181 bytes

<omissis>

Well, I've found a bug that sounds quite sinister ...

CSCsi76841: PPP Multilink Interleaving is not happening with LLQ configured

same as:

CSCdr60739 "Enabling ppp multilink on dialer makes link unusable"

It seems that Multilink ppp is not supported for PPPoE

In this case, any other solution to queue the voice traffic in the strict priority queue on 871 platform?

I've not experience on this device family, any advice will be appreciated

Thanks for your support

Regards

Andrea

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
Paolo Bevilacqua Mon, 06/04/2007 - 12:46

Hi Andrea,

why don't you try without multilink and fragmentation? If you uplink speed is 256 or better, you do not need fragmentation, because the serialization delay is not large enough to cause problems.

Hope this helps, please rate post if it does!

ariela Mon, 06/04/2007 - 13:10

Hi,

thanks for your answer. Without MLPPP it seems that the policy-map doesn't work ... I've no packets match on dia0 ...

Physically I've a fastethernet (as you can see on my config)

Thanks

Andrea

Paolo Bevilacqua Mon, 06/04/2007 - 13:39

Hi,

I should have notice this before. Your outgoing interface is FE, hence is never congested.

If you really need to configure LLQ, you need to shape output to same speed as upload speed of your ADSL, this will create the backpressure for priority to work. The service policy is under the physical interface, not dialer. See example:

http://cisco.com/en/US/tech/tk543/tk545/technologies_tech_note09186a00800b2d29.shtml

Hope this helps, please rate post if it does!

ariela Mon, 06/04/2007 - 21:34

Hi,

the dialer is required from my PPPoE config, and when I try to apply the service policy under the physical interface, it seems that it doesn't work (I've no packets match).

Any advice, for QoS or PPPoE config, will be appreciated.

Regards

Andrea

ariela Tue, 06/05/2007 - 07:45

Hi,

a configuration like this could be solve my troubles?

PPPoE Client:

!

!

vpdn enable

vpdn-group 1

request-dialin

protocol pppoe

!

!

class-map match-any VoIP

match ip dscp ef

!

!

policy-map Dial0_Out

class VoIP

priority 500

class class-default

fair-queue

!

!

interface Loopback0

ip address x.x.x.x 255.255.255.255

!

!

interface FastEthernet4

description *** WAN ***

no ip address

pppoe enable

pppoe-client dial-pool-number 1

service-policy output Dial0_Out

!

interface Vlan1

description *** LAN ***

ip address x.x.x.x 255.255.255.0

ip nat inside

!

!

interface Dialer0

ip address negotiated

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 1

ppp authentication chap

ppp chap hostname Test

ppp chap password

!

PPPoE RAS:

!

aaa authentication ppp default local

!

!

username Test password

!

vpdn enable

vpdn-group 1

accept-dialin

protocol pppoe

virtual-template 2

pppoe limit per-mac 10

pppoe limit max-sessions 32000

!

!

!

interface Loopback0

ip address x.x.x.x 255.255.255.255

!

interface GigabitEthernet0/0.23

description ***Test PPPoE***

encapsulation dot1Q 23

pppoe enable

!

interface Virtual-Template2

mtu 1492

ip unnumbered Loopback0

no peer default ip address

ppp authentication chap

!

Any advice will be appreciated

Thanks for your support

Regards

Andrea

Paolo Bevilacqua Tue, 06/05/2007 - 10:42

Hi Andre,

for client pppoe, vpdn is not required.

You should be able to apply the service policy either under dialer0, or physical interface.

If the example I linked does not work, we should contact cisco and have it corrected or removed.

Good luck!

ariela Tue, 06/05/2007 - 12:56

Thank you very much for your support!

Just a question: what the difference between vpdn-group and bba-group? And why for client pppoe vpdn is not required?

thanks again

Andrea

Paolo Bevilacqua Tue, 06/05/2007 - 13:19

Hi Andrea,

some features like vpdn/pppoe where developed for the BRAS (broadband router aggregation services) set of functionality that are used by the ISP, for example vpdn allows one common infrastructure to be shared by multiple ISPs that get the ppp session forwaeded with l2tp.

The configuration for the home/small office access device is much simples and does not need all commands related to the above.

Actions

This Discussion