Port Security disable

Unanswered Question

Hello


I was working on 6500 switch and came across this problem where port security in implemented on this port.



I have implemented a port secuirty on one of 6500 switch; This port is in shutdown mode and I tried clearing out the port security by typing

command > (enable) clear port security 0/0 all

> (enable) set port security 0/0 enable

> (enable) set port enable 0/0

it connects for about 5 seconds and then this comes up "2007 Jun 04 16:51:22 %SECURITY-1-PORTSHUTDOWN:Port 4/14 shutdown due to security

violation 00-45-78-48-d5-g8.


So what i did was >(enable) set port security 0/0 disable and this brought the interface up.


Does anyone know why this is happening and how i can fix port security?



Thanx...


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jasonrandolph Mon, 06/04/2007 - 15:22
User Badges:

Well, outside of the g8 on the violation ouput I'd say that looks like a Mac address. Did you mean f8?


Have you tried setting the port device's mac address to see if that works?

anandramapathy Mon, 06/04/2007 - 20:15
User Badges:
  • Bronze, 100 points or more

Hi


As suggested by jasonrandolph


Try the following


If the mac address of the PC is A.B.C.D


The first clear port security on the interface


verify the port security couters by

show port security command


disable port security


Then enable the port security back on the Interface by the following


set port security (port # ) A.B.C.D



Then try plugging the machine.

After that try plugging another machine to check if the port security works






beckerola Tue, 06/05/2007 - 03:06
User Badges:

Hi


The problem you are having is that the machine you are trying to connect in that port was attached to another port and still has the mac address in memory. What you have to do is force the mac address 00-45-78-48-d5-f8 int the new port where you want to connect the computer with this command:


set port sec (port) 00-45-78-48-d5-f8


It will give you a message saying that mac address is already configured in another port. Go to that port and clear the port security configuracion. Then try again on the new port. This time it will work.


Hope it helps.

Actions

This Discussion