BGP Help reqd.

Answered Question
Jun 5th, 2007
User Badges:

Hi all,


I am attaching a network diagram


I have used minimum BGP configuration


I want to know what additional configuration required without using any IGP on all routers so that I can reach from every router to every router


Regards


Mahesh



Attachment: 
Correct Answer by Jon Marshall about 9 years 9 months ago

Mahesh


You need to advertise out the networks in AS100 to the 7613 router. You can use "network" statements under your BGP config


eg


3750


router bgp 100

network 2.2.2.4 mask 255.255.255.252

etc..


It would be better if you used a different network for the 7613 -> 3750 connection then you could just summarise out the 2.2.2.x networks from the 3750 ie


router bgp 100

network 2.2.2.0 mask 255.255.255.0


HTH


Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (4 ratings)
Loading.
mohammedmahmoud Tue, 06/05/2007 - 02:29
User Badges:
  • Green, 3000 points or more

Hi,


You need full mesh iBGP between you iBGP routers, and make sure the peering IPs are pingable from each router (use static routes).



HTH, please do rate all helpful replies,

Mohammed Mahmoud.

Jon Marshall Tue, 06/05/2007 - 02:34
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Hi


Mohammed is spot on. Just to give another option. Rather than full mesh IBGP you could set up your 3750 as a route-reflector for the 2811 and the RAS routers. This would achive the same effect.


HTH


Jon

mohammedmahmoud Tue, 06/05/2007 - 02:37
User Badges:
  • Green, 3000 points or more

Hi,


Jon is completely right, using RR is the best practice, and even if you want to simplify the configuration, using RR is not a hard task.



HTH,

Mohammed Mahmoud.

mahesh-gohil Tue, 06/05/2007 - 02:43
User Badges:

Ok I have changed config of 3750 like


3750# router bgp 100

no synchronization

bgp log-neighbor-changes

neighbor 2.2.2.1 remote-as 200

neighbor 2.2.2.1 next-hop-self

neighbor 2.2.2.6 remote-as 100

neighbor 2.2.2.6 route-reflector-client

neighbor 2.2.2.18 remote-as 100

neighbor 2.2.2.18 route-reflector-client

no auto-summary


Now I am not able to ping from 2811 to RAS


Do i need static router and where ?


Regards

mohammedmahmoud Tue, 06/05/2007 - 02:49
User Badges:
  • Green, 3000 points or more

Hi,


Yes you need static routing on both 2811 and RAS pointing to each other peer ips having the next-hop as the 3750 (and the 3750 will route between its directed interfaces).



HTH,

Mohammed Mahmoud.

mahesh-gohil Tue, 06/05/2007 - 02:56
User Badges:

ok i had given static route on 2811 as

ip route 2.2.2.16 255.255.255.252 2.2.2.5


and on RAS

ip route 2.2.2.4 255.255.255.252 2.2.2.17


and that is working


Now to reach from RAS and 2811 to 7613 what should I do


Regards


Mahesh

mohammedmahmoud Tue, 06/05/2007 - 03:04
User Badges:
  • Green, 3000 points or more

Hi,


This case is slightly different, as the 2811 to 7613 is eBGP not iBGP, and thus you'll need "ebgp-multihop 2" on both sides, plus static routing as before.



HTH,

Mohammed Mahmoud.

Correct Answer
Jon Marshall Tue, 06/05/2007 - 03:06
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Mahesh


You need to advertise out the networks in AS100 to the 7613 router. You can use "network" statements under your BGP config


eg


3750


router bgp 100

network 2.2.2.4 mask 255.255.255.252

etc..


It would be better if you used a different network for the 7613 -> 3750 connection then you could just summarise out the 2.2.2.x networks from the 3750 ie


router bgp 100

network 2.2.2.0 mask 255.255.255.0


HTH


Jon

Jon Marshall Tue, 06/05/2007 - 02:55
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Hi


Yes you can use static routes or


1) use network statements under the BGP config to advertise out the subnets on 2811 and RAS.

2) use the "redistribute connected" command under the BGP config.


Depends how many subnets you are using on each router.


HTH


Jon

mahesh-gohil Tue, 06/05/2007 - 04:11
User Badges:

Thanks everybody


Now I had many option without IGP


Really thanks


Mahesh


Actions

This Discussion