cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
528
Views
12
Helpful
5
Replies

about PPPoE over Ethernet and LLQ

ariela
Level 4
Level 4

Hi folks,

I've to implement a PPPoE solution, with ppp authentication chap and LLQ for voice traffic. The client will be a 871, the RAS a 7200. I've no experience about vpdn/bba-group/etc... so any advice about the best way to follow will be appreciated :)

Regards

Andrea

5 Replies 5

kerek
Level 4
Level 4

Hi,

I think the LLQ cannot be applied on the LNS per session basis or at all.

Please refer to this link:

http://www.cisco.com/en/US/tech/tk543/tk545/technologies_tech_note09186a00800b2d29.shtml

and check the restrictions part.

In respect to the pppoe client (871) it is possible to configure it. See the bottom of the same link for configuration details.

Hope it helps, rate if does,

Krisztian

Thanks Krisztian,

a configuration like this, in your opinion, sounds correct?

PPPoE Client:

!

!

vpdn enable

vpdn-group 1

request-dialin

protocol pppoe

!

!

class-map match-any VoIP

match ip dscp ef

!

!

policy-map Dial0_Out-child

class VoIP-cm

priority 500

police 500000

class class-default

fair-queue

policy-map Dial0_Out

class class-default

shape average 5000000

service-policy Dial0_Out-child

!

!

interface Loopback0

ip address x.x.x.x 255.255.255.255

!

!

interface FastEthernet4

description *** WAN ***

no ip address

pppoe enable

pppoe-client dial-pool-number 1

service-policy output Dial0_Out

!

interface Vlan1

description *** LAN ***

ip address x.x.x.x 255.255.255.0

ip nat inside

!

!

interface Dialer0

ip address negotiated

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 1

ppp authentication chap

ppp chap hostname Test

ppp chap password

!

PPPoE RAS:

!

aaa authentication ppp default local

!

!

username Test password

!

vpdn enable

vpdn-group 1

accept-dialin

protocol pppoe

virtual-template 2

pppoe limit per-mac 10

pppoe limit max-sessions 32000

!

!

!

interface Loopback0

ip address x.x.x.x 255.255.255.255

!

interface GigabitEthernet0/0.23

description ***Test PPPoE***

encapsulation dot1Q 23

pppoe enable

!

interface Virtual-Template2

mtu 1492

ip unnumbered Loopback0

no peer default ip address

ppp authentication chap

!

Any advice will be appreciated

Thanks for your support

Regards

Andrea

Hi,

Looks ok.

Please be careful with the shape average command. You always have to count with the overhead through SP network (pppoe overhead, ATM header). As I see it is only a test environment so it is not really problem. You also have to add route 0.0.0.0 0.0.0.0 dialer 0 on the client. The class-map match-any VoIP matches dscp ef so it assumes that your device is already set it. The nat setting is also missing.

On the concentrator if you use no peer default ip address under virtual-template you will have to assign somehow ip address for the peer (for example by means of radius).

Anyway it is ok.

Krisztian

Yes I know, my config is partial ...

So, just a question: what the difference between vpdn-group and bba-group?

thanks again for your support

Regards

Andrea

Hi,

Honestly I don't know the exact difference between theses two as I haven't had to dig into this deeply but the below link explain what is the concept of pppoe profile (bba-group) and the difference between legacy mode (vpdn-group) and the other. I think the idea is similar to the ISDN where you can configure legacy and dialer profiles.

http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_feature_guide09186a00801541b8.html

Hope it helps, rate if does,

Krisztian