Issue with HSRP

Unanswered Question
Jun 5th, 2007

Hi all,

I have running HSRP for remote client on my two 6500 for redudancy on Layer 3 interface.

The problem is if my primary router gets reloaded and come up, HSRP process start and comes fast as active but still routing protocol not coverge with my other side of network and due to that Traffic from client comes to HSRP active router and then drops till routes get convered for destination and my voice call gets drop.....

I could try "preempt delay" but there are some limitation for this....

Can any body suggest good solution for this ??

REgards,

Chintan

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Tue, 06/05/2007 - 06:00

Chintan

It would seem that the solution to your issue is either to make HSRP recover more slowly (preempt delay) or to make your routing protocol converge more quickly. What routing protocol are you running? Perhaps there is something that can speed up convergence of the routing protocol?

HTH

Rick

shah.chintan Tue, 06/05/2007 - 06:05

Rick

I'm using OSPF as routing protocol...

To use HSRP preempt it is mandatory that both active and standby router exchange HSRP hello packet so i thought of using "standby delay minimum 120 reload 120" so that HSRP will not initate till 2 min by this time routing protocol convergance will happend but here issue is there will be asymetric routing for as for other side of network Active route is prefred path....

Could you suggest any other solution

thanks,

Chintan

Jon Marshall Tue, 06/05/2007 - 06:11

Hi Chintan

Are you tracking any interfaces with HSRP. If not the simplest solution would be to just turn off preemption. That way the primary switch will not be come the active HSRP gateway.

This may or may be useful however as you may setup your Layer 2 paths to match your L3 paths and these would then be out of sync.

HTH

Jon

shah.chintan Tue, 06/05/2007 - 06:15

Hi Jon,

Thing is if I remove preempt then even there is flap on interface standby router will become active. But I want primary router always active back......

I know it is complex situation and if possible i m trying to get best solution......

rgds,

chintan

Richard Burts Tue, 06/05/2007 - 06:37

chintan

If you want to make OSPF converge more quickly there is an option to configure OSPF with shorter time for hello and for deal interval which will make it converge more quickly.

If you want REALLY fast convergence of OSPF Cisco introduced a feature in 12.2T called OSPF fast HELLO which results in the fastest convergence of OSPF. This link should give you information to help you get started:

http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_feature_guide09186a00801039b1.html

HTH

Rick

Actions

This Discussion