booting rsp4 7500 with boot image on flash disk

Unanswered Question
Jun 5th, 2007

I have seen messages on forum regarding booting the boot image from flash disk.

I did get the 123-14.T7 boot image to load ONCE. I believe i actually had errors in my syntax when it worked:

Here is the show run:

boot system flash disk0:rsp-ik9sv-mz.123-14.T7.bin

boot bootldr disk0:rsp-boot-mz.123-14.T7.bin

boot config disk0:startup-config

logging buffered 300000 informational

no logging rate-limit

logging console informational

Here is the bootvar

c7505-3(boot)#show bootvar

BOOT variable = disk0:rsp-ik9sv-mz.123-14.T7.bin,1;

CONFIG_FILE variable = disk0:startup-config

BOOTLDR variable = disk0:rsp-boot-mz.123-14.T7.bin

INHIBIT_BSI variable does not exist

Configuration register is 0x2102

=======================================

The device keeps booting to the image in bootflash. 12.2(40)

This is what I want to boot from.

Directory of disk0:/

1 -rw- 26741584 Jun 4 2007 01:18:08 -07:00 rsp-ik9sv-mz.123-14.T7.bin

2 -rw- 10775480 Jun 3 2007 23:33:18 -07:00 rsp-boot-mz.123-14.T7.bin

3 -rw- 1635 Jun 5 2007 14:32:56 -07:00 startup-config

4 -rw- 1635 Jun 5 2007 14:32:42 -07:00 startup-config1

5 -rw- 1635 Jun 5 2007 14:37:06 -07:00 startup-config2

64221184 bytes total (26689536 bytes free)

=============

Q. How do I debug this ?

Q. Why is it not booting correctly?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
etheric Tue, 06/05/2007 - 15:53

I discovered that the older flash drives work.

By inserting a slot0 device the problem seems to be resolved.

I wonder why no error message is generated when the config file "errors out".

This config is working:

boot-start-marker

boot system flash disk0:rsp-ik9sv-mz.123-14.T7.bin

boot bootldr slot1:rsp-boot-mz.123-14.T7.bin

boot config disk0:startup-config2

boot-end-marker

Actions

This Discussion