Isdn Layer 1 deactivated when there is no active call

Unanswered Question
Jun 6th, 2007
User Badges:

Hi All,

I am in Nairobi Kenya. Here we use ISDN Basic-net3 and my problem is that most of the telco switches here deactivate Layer 1 when there is no active call.

When I try to initiate a call by using the ISDN test call command I get an error to the effect that B channel is not available.

The only way I can initiate a call is I first call the line then and then disconnect. Then I have about 5 seconds to make a test call and pings are successful. How do I make the router initiate a call when layer 1 is deactivated.

the debug isdn q921 out has nothing till a call comes in.

I also understatnd that European ISDN switches deactivate Layer 1 when there no active call. I dont have a problem with one of the switches, coz it does not bring down the line when there is no active call.

Thakx in advance

Martin

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
paolo bevilacqua Wed, 06/06/2007 - 02:01
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hello,

saying "deactivating layer 1" or "bringing down the line" when there is no active call, is absolutely the same thing.

As you said, this is normal behavior for european switches and I think for the switch you have there too.

This said, the router should be able to reactivate the line to place an outgoing call, without needing an incoming call first.

Please send: router model and exact IOS version, router configuration.

martin-githiomi Wed, 06/06/2007 - 02:32
User Badges:

Thanks for the quick response.

It is a cisco 1760

The IOS is c1700-sv3y-mz.122-15.T5.bin


When I try to make a test call the show isdn status initially indicates that the router is trying to activate layer 1 then after 5 seconds it indicates that it is deactivated.

I have not yet configured DDR as indicated in the config file



Building configuration...


Current configuration : 3054 bytes

!

! Last configuration change at 00:38:54 UTC Mon Aug 9 1993

! NVRAM config last updated at 00:36:54 UTC Mon Aug 9 1993

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Gill-House

!

logging queue-limit 100

enable secret xxx

!

ip subnet-zero

!

!

no ip domain lookup

!

!

isdn switch-type basic-net3

!

!

!

!

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

!

!

!

class-map match-all voice-traffic

match ip rtp 16384 16383

!

!

policy-map voice

class voice-traffic

priority 24

class class-default

fair-queue

!

gw-accounting syslog

!

!

interface Loopback0

description Loopback interface for VoIP Dial-peers

ip address 128.1.x.x.255.255.255

!

interface Multilink1

bandwidth 6

ip address 128.1.x.x.255.255.252

ip tcp header-compression iphc-format

ppp multilink

ppp multilink fragment-delay 20

ppp multilink interleave

multilink-group 1

ip rtp header-compression iphc-format

!

interface FastEthernet0/0

description Gill-House LAN

ip address 128.1.x.x.255.255.0

speed auto

!

interface Serial0/0

description Link to Head Office

bandwidth 64

no ip address

encapsulation ppp

no fair-queue

ppp multilink

multilink-group 1

!

interface BRI1/0

ip address 10.10.1.2 255.255.255.0

encapsulation ppp

isdn switch-type basic-net3

isdn point-to-point-setup

keepalive 20

!

router eigrp 100

passive-interface FastEthernet0/0

passive-interface Loopback0

network 128.1.0.0

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

no ip http server

!

!

!

logging source-interface Loopback0

logging 128.1.1.179

!

call rsvp-sync

!

voice-port 2/0

cptone GB

ring frequency 50

!

voice-port 2/1

cptone GB

ring frequency 50

!

dial-peer cor custom

!

!

!

dial-peer voice 2 pots

destination-pattern 101

port 2/0

!

dial-peer voice 51 voip

destination-pattern 100

session target ipv4:128.1.0.254

ip qos dscp cs5 signaling

!

dial-peer voice 55 voip

destination-pattern 120

session target ipv4:128.1.31.254

ip qos dscp cs5 signaling

!

dial-peer voice 52 voip

destination-pattern 102

session target ipv4:128.1.91.254

ip qos dscp cs5 signaling

!

dial-peer voice 53 voip

destination-pattern 103

session target ipv4:128.1.121.254

ip qos dscp cs5 signaling

!

dial-peer voice 54 voip

destination-pattern 110

session target ipv4:128.1.21.254

ip qos dscp cs5 signaling

!

dial-peer voice 56 voip

destination-pattern 130

session target ipv4:128.1.41.254

ip qos dscp cs5 signaling

!

dial-peer voice 57 voip

destination-pattern 140

session target ipv4:128.1.111.254

ip qos dscp cs5 signaling

!

dial-peer voice 58 voip

destination-pattern 150

session target ipv4:128.1.61.254

ip qos dscp cs5 signaling

!

dial-peer voice 59 voip

destination-pattern 160

session target ipv4:128.1.71.254

ip qos dscp cs5 signaling

!

!

line con 0

logging synchronous

line aux 0

line vty 0 4

password housing

login

!

ntp clock-period 17208074

ntp server 128.1.1.211

ntp server 128.1.0.254

end


Gill-House#



paolo bevilacqua Wed, 06/06/2007 - 12:44
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi,


Your ISDN configuration appears incomplete.

Specifically, it misses the required "dialer string" or "dialer map" necessary to place a call.

Please see an example of configuration at:

http://cisco.com/en/US/tech/tk801/tk379/technologies_configuration_example09186a0080093d4a.shtml


The above document also introduce a command "isdn tei-negotiation preserve" that is useful when switches brings down layer 1 on inactivity.


If still doesn't work, I suggest you upgrade to 12.2(46)


Hope this helps, please rate post if it does!

martin-githiomi Thu, 06/07/2007 - 01:58
User Badges:

I am using the "isdn test call" command to make a call. The "debug isdn error" output indicates that B- channel could not be found when i try to place a call . At another site the 2801 router works fine. I also tried the "isdn tei-negotiation preserve" and still cannot make a call with the 1760 router.

I will upgrade the IOS but mean while I will try with another type of router first.

I will get back to you.

Thanks

paolo bevilacqua Thu, 06/07/2007 - 03:17
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi,


Be aware that different IOS versions may behave differently with regard to "isdn test call". Why not testing the circuit with a regular configuration, and then ping to ip ?


I suggest you upgrade the IOS first before switching router. Unfortunately IOS has an history of bugs in ISDN so chances are that something has been fixed.


srimural Wed, 06/27/2007 - 14:18
User Badges:
martin.githiomi Thu, 06/28/2007 - 02:07
User Badges:

The SP has 3 types of switches. The switches that are giving me problems are known as Linear UT. They have been configured to shut dsown the port when there is no active call. The NEAX switch is working fine. Someone told me to use the BRI-S/T and use an external NT1. Currently I am using BRI-U cards. What do you think.

srimural Thu, 06/28/2007 - 07:23
User Badges:

Hi,

When you use a external NT1 you will find your L1 as active but L2 deactivated. Only when a call comes it will be active.


Thanks and Regards,


Srinath.M

Cable&Wireless

paolo bevilacqua Thu, 06/28/2007 - 08:07
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Would definitely try with BRI-S/T and external NT.

BRI-U was designed for the US market where there is no deactivation on inactivity.

Wilson Samuel Thu, 06/28/2007 - 10:05
User Badges:
  • Gold, 750 points or more
  • Community Spotlight Award,

    Mobile User, July 2015

Hi Martin,


From your post, I guess you are only concerned about the ISDN Test Call? Correct?


Also, please give us the outputs from:-


sh isdn status


sh int bri 0/0


sh ver

srimural Thu, 06/28/2007 - 23:01
User Badges:

Hi,

Please try the same with this command.


isdn tei-negotiation preserve


Thanks and Regards,


Srinath.M

Cable&Wireless

Actions

This Discussion