Rommon

Unanswered Question
Jun 6th, 2007

Need to change configuration so that I no longer have rommon> prompt at sup engine.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
royalblues Wed, 06/06/2007 - 03:42

The switch can go into ROMmon mode for any of these reasons:

The boot variables are not set correctly to boot the switch from a valid software image.

The configuration register is not set correctly.

The software image on the bootflash: is missing or corrupted, or there is a software upgrade failure.

have a look at this link

http://www.cisco.com/en/US/products/hw/switches/ps663/products_tech_note09186a00800949c3.shtml

HTH, rate if it does

Narayan

gmvburg23 Wed, 06/06/2007 - 04:13

Went into register to change to 0x2102 and resolved--thanks!

Amit Singh Wed, 06/06/2007 - 03:47

Which OS you are running? Is it CatOS or IOS.

There are two things that you can check and change.

1. Config-regsiter should be 0x2102

For IOS, once the switch is booted Check the " Show version".It will list you config register at the end. Do the following:

Conf t

config-register 0x2102

For CatOS, Check "show boot", and it will list the config register there.Do the following

console(enable)> Set config-register 0x2102

2. Check the bootpath for the switch boot. makre sure that it is configured properly and the files name is listed there. use " show boot " for the same.

3. Make sure that a valid image file exist in the flash or CF card and the bootpath is set accordingly.

Please see the docs below:

http://www.cisco.com/en/US/products/hw/switches/ps700/products_tech_note09186a008015bfa1.shtml

http://www.cisco.com/en/US/products/hw/switches/ps663/products_tech_note09186a00800949c3.shtml

HTH,please rate if it does.

-amit singh

Actions

This Discussion