Callmanger to CCME calls cut off on answer, help needed

Answered Question
Jun 6th, 2007
User Badges:

Hi

I have just configured a CCM 4.2(3) system with an ICT to a CCME4.0 system.

I can place a call from the callmanger to a CCME extension and it rings and displays name but when it is answered i get reorder tone back and the call is cleared. I used suggested configuration posted on CISCO site. I have looked at debug ccapi on CCME sytem and can see a reference to "Transfer Number Is Null" but dont know what this means. I attach the dabugs, with some comments added. any help appreciated.


regards

colin



Correct Answer by Brandon Buffin about 10 years 1 month ago

Colin,

Do you have the following command under telephony-service?


call-forward pattern .T


Brandon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (6 ratings)
Loading.
Brandon Buffin Wed, 06/06/2007 - 08:07
User Badges:
  • Purple, 4500 points or more

This is very likely a codec mismatch problem. The disconnect cause code is 65 which is Bearer Capabililty Not Implemented. Check the codec being used over the ICT and the codec on the incoming dial peer in CME.


Hope this helps.


Brandon

ReadersUK Thu, 06/07/2007 - 01:40
User Badges:

Hi Brandon


Thanks for your reply, since i posted this i tried removing the "Media termination Point Required" tick box on the ICT on the callmanager, and the call goes through ok. I agree with you that it must be a codec issue but so far can't find the missmatch. I dont have an incoming dial peer on the ccme and am not sure how tell what codec i am using on the callmanager. I assume it may use g729 by default on an ICT. Does anyone know?


Colin

Brandon Buffin Thu, 06/07/2007 - 07:19
User Badges:
  • Purple, 4500 points or more

Colin,

The codec used by calls over the trunk will be determined by the Region associated with the Device Pool assigned to the ICT. The Region configuration will be used to determine the codec used by calls within and between regions. Also, if you have not configured an inbound dial peer, then you are hitting the default dial peer. It's a good idea explicitly configure a dial peer rather than have calls hit the default dial peer.


Brandon

ReadersUK Thu, 06/07/2007 - 07:37
User Badges:

Hi Brandon

Thanks

I configured a dial peer and set it for g711 to match the region set in device pool on callmanager.It's working but now i have an additional problem, if i call the CCME and dont get an answer when the call forwards to voice mail it cuts off. I realise the UNITY VM sytem uses g711 so i didnt think there would be a problem a long as i didnt use g729 but this doesnt seem to be the case. Any ideas


Colin

Brandon Buffin Thu, 06/07/2007 - 07:48
User Badges:
  • Purple, 4500 points or more

Colin,

Is the call forwarding to Unity Express? If so, you will need the following commands:


voice service voip

allow-connections h323 to sip


Brandon

ReadersUK Thu, 06/07/2007 - 08:04
User Badges:

Hi Brandon


I didnt know about that command and yes it is unity express. I tried the command but still get the same results. I attach a debug ccapi and can see the call forwarded to my voice mail "1700" in this case and then get disconnected. What do you make of it.


regards colin



Attachment: 
ReadersUK Fri, 06/08/2007 - 02:08
User Badges:

Hi Brandon


I really appreciate the help. Unfortunately i don't think this bug is my problem. The bug refers to the CUE pilot number matching the dialplan pattern, which mine does not.

I tried removing the dial plan pattern config just to be sure and i still have the same problem so I'm back where i started.


Colin

Brandon Buffin Fri, 06/08/2007 - 04:12
User Badges:
  • Purple, 4500 points or more

Colin,

I assume you can call CUE locally without a problem? It's only when a call goes across the ICT and gets forwarded to CUE that you get fast busy? If you do a "debug voip dial peer", do you see the call hitting the correct dial peers? Is the call configured for G.711 end to end? If not, you will need a transcoder as CUE only supports G.711. If you let the call connect to the called DN and you press ?? on the phone, does it show G.711 for the codec?


Brandon

Rob Huffman Fri, 06/08/2007 - 04:44
User Badges:
  • Super Red, 40000 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Brandon,


Really great work on this thread Brandon. It is great to see such follow-through! A 5 point must for sure :)


Take care,

Rob

Brandon Buffin Fri, 06/08/2007 - 04:48
User Badges:
  • Purple, 4500 points or more

Rob,

Thanks for the nice words and the nice rating.


Brandon

ReadersUK Fri, 06/08/2007 - 05:37
User Badges:

Hi Brandon


First let me say i echo Rob's comments, you are a star!


In reply to your questions:


Yes local calls including incoming PSTN calls forward to V/mail ok.

Its only calls from callmanager that forward to voice mail that fail. I get no tones it simply clears the call and the phone goes idle.


the dial peer is working fine i did a debug yesterday.


the region setting on callmanager is set for g711 and the incoming dial peer on the ccme is also set and i checked using debug that the incoming call is hitting the correct dial peer.

What is interesting now is that i did a debug on ccsip to see what hits the unity express and i see nothing so the call is not getting that far.

just below is the debug H225 output when the call is transfered to voicemail, also at the end is my voice service voip commands.


.Jun 8 15:32:19: H225 NONSTD OUTGOING ENCODE BUFFER::=

.Jun 8 15:32:19:

.Jun 8 15:32:19: H225.0 OUTGOING PDU ::=


value H323_UserInformation ::=

{

h323-uu-pdu

{

h323-message-body releaseComplete :

{

protocolIdentifier { 0 0 8 2250 0 4 }

callIdentifier

{

guid '804D61A1C733D11D0F001901A1E6750C'H

}

}

h245Tunneling FALSE

nonStandardControl

{


{

nonStandardIdentifier h221NonStandard :

{

t35CountryCode 181

t35Extension 0

manufacturerCode 18

}

data '5001000080A87400000000020000313730300000...'H

}

}

}

}




.Jun 8 15:32:19: H225.0 OUTGOING ENCODE BUFFER::=

.Jun 8 15:32:19:


voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

no supplementary-service h450.3

h323

h225 h245-address on-connect

regards

colin


Correct Answer
Brandon Buffin Fri, 06/08/2007 - 06:26
User Badges:
  • Purple, 4500 points or more

Colin,

Do you have the following command under telephony-service?


call-forward pattern .T


Brandon

ReadersUK Fri, 06/08/2007 - 07:42
User Badges:

Hi Brandon


I didn't but when i tried it it works.

well done and thanks for your help.

I learnt a lot during this thread, i hope it helps someone else doing a similar set up to me.


Once again thanks for all your help


Colin

Brandon Buffin Fri, 06/08/2007 - 07:46
User Badges:
  • Purple, 4500 points or more

Colin,

You're more than welcome. Glad that did the trick for you.


Brandon

Actions

This Discussion