IP Communicator on Dell Latitude D620 laptops

Answered Question
Jun 6th, 2007
User Badges:

Has anybody successfully used IP Communicator on a Dell Latitude D620?


I'm finding (consistently across several laptops of this model) that there is a problem with the microphone selection. Communicator works just fine with an external Plantronics USB headset, but often I just want to use the built in speakers and mic to make a quick call (particularly when working at home on the sofa!). This worked perfectly well on the older model D600 laptops.


The newer D620 has two mic "inputs" - the internal mic, and the "mic in" jack. If I use the media controls to ensure the internal mic is selected and then run the Cisco Audio Tuning Wizard, everything appears OK. However, once Communicator is running, the moment the phone goes off hook the mic selection switches from the internal mic to the "mic in" option. The radio buttons to switch it back are disabled until the phone is on hook again, and the setting doesn't revert to the internal mic automatically. Net result is if I call somebody they hear nothing, though I hear them just fine.


Platform is Windows XP with every update available via "Windows Update", and the latest available download of IP Communicator. I've tried installing the latest Dell audio drivers and utilities, and also the previous version and the one before that too, and finally a couple of earlier releases of Communicator. The behaviour doesn't change.


If I was the only user impacted, I'd just make sure I carried a USB headset in my bag. Unfortunately we're rolling these laptops out to about three thousand users this year and will want to provide many of them with Communicator in the not too distant future.


Any suggestions?


Correct Answer by mchandak about 9 years 11 months ago

What is the CIPC version you are using ?? You could be hitting into CSCse19671. Try using CIPC 2.1(1) and see if that solves the issue or not. You can download it from http://www.cisco.com/cgi-bin/tablebuild.pl/ip-comm

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
mcreilly Wed, 06/06/2007 - 07:57
User Badges:

Thanks for the very fast reply!


I just downloaded that and installed it - and yes, it looks like that was the problem. It all seems to work perfectly now! :)


(I guess I should have checked for further updates between last time I actively worked on this problem and today!)

Actions

This Discussion