ipv6 plz help

Unanswered Question
Jun 6th, 2007

hi guys, i have a very simple scenario but its not working, see i have a router wid fa0/0 connected to a switch, my pc is also connected to that switch. these are my configs for router

int fas0/0

ipv6 enable

no shur

then in global config i typed ipv6 unicast-routing.

now when i run show ipv6 int brief i can see fas0/0 link local address

now i install ipv6 on xp on my pc.

when i do ipconfig i can see my link local address but i dont see my default gateway :( :( :(, why my pc is not discovering my router as its default gateway ??? wat i have to do to add default-gateway to pc ??? plz dont take me wrong but dont give me advises to reinstall coz i have done it, plz tell me wat am i missing or wat should i do plz tell me

thanks in advance

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
devang_etcom Wed, 06/06/2007 - 12:14

I think enabling IPv6 will assign only link local address... not sure but i think its not give configuration for the default route... so you can have communication between two devices on the same link but not out side that...



shaila_rox Wed, 06/06/2007 - 12:22

thanks for reply but i didnt helped me much :( plz tell me some 1

Harold Ritter Wed, 06/06/2007 - 13:46

You have to assign a /64 prefix (either unique-local or global) to the interface for the router to send Router Advertisement (RA) messages and therefore for your PC to get a gateway.

It would help your PC to get gateway information if it only had a link-local address.

Hope this helps,

zhanghx510 Wed, 06/06/2007 - 16:51

I have some questions to ask you:

have you configured your cisco router as a DHCP server?

if yes, have you typed the key command "default-router" to setup a default gateway on your router?

if yes, have you enable your xp pc as a DHCP client?


This Discussion