Can't ping the host after the ip address changed

Unanswered Question
Jun 6th, 2007

I have a catalyst 6509, installed with 2 sup2(also wtih msfc2) and some interface modules. The two msfc2 work in SRM redundancy mode.There are some servers and hosts connect directly to the 6509. The problem is when I chang the ip address of a server, the hosts in the same vlan with that server can ping the server, but the hosts in other vlans can't ping the server. If I restore the server with the previous ip address, then all the hosts can ping the server. Why? Is it a bug of the SRM features?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
xiaojun-he Wed, 06/06/2007 - 23:19

Yes, the gateway configuration is right both on the server and the other hosts.

Also, I have disabled the "proxy arp" features on all the SVI.

xiaojun-he Thu, 06/07/2007 - 00:21

The OS is windows 2000 server. It seems the problem is not on the Server, but on the 6509.

If I change the ip addresses of the hosts, which are windows 2000 or xp, the same problem happens.

ycae Thu, 06/07/2007 - 05:12

Are you able to sniff the interfaces on the gateway to see if the packets are crossing the gateway. Are you able to ping your server from the gateway? And also the other way around?

xiaojun-he Thu, 06/07/2007 - 07:56

I can ping the server from the msfc2 of the 6509 and the server can also ping its gateway ( the msfc2), but I can not ping the server from the sup2's management ip address, the sup2's management ip address is in a different vlan from the server.

bdeng1201 Thu, 06/07/2007 - 08:30

There is something wrong with the msfc2. Double check the configuration on msfc2, especially the routing configuration. Use a external router to simulate the routing function of msfc2 to see if the msfc2 is malfunctioning.

xiaojun-he Thu, 06/07/2007 - 18:00

The problem happens after the changing of ip addrees of the server. The arp and cef tables seem ok, but they maybe work abnormally. I can ping the server from any ip address of any svi in the msfc2, but can not from any hosts in other vlans than the server. The 6509 is cos, and the two sup2 work in HA mode, the two msfc2 work in SRM mode. I clear the arp table and route table on the msfc2, but it doesn't work on that problem. Additionally , I find some more information: after 16 hours or more, I can ping the server again from all of the hosts and the arp timeout interval is the default value(4 hours). Jon may be right, and the output of the "show arp" and "show ip cef" command seems ok, the mac address table on the sup2 seems ok too. But how can I check more information about the cef table?


This Discussion