DFM and CiscoView problems

Unanswered Question
Jun 7th, 2007

Hi, guys!

There are an LMS 2.6 (upgraded from 2.5.1)


all devices are in learning state in DFM. (DFM log attached) version of DFM is 2.0.6

NMSROOT\bin\perl NMSROOT\bin\resolver.pl cworks (cworks.company.com )

Both commands return the same IP address.

CiscoView 6.1.5 problem:

it doesn`t want to recognize Catalyst 2960.

I upgraded it with patches Cat2960.cv50.v3-0 and Cat2960.cv50.v2-0.

both are even not appear in <NMSROOT\MDC\tomcat\webapps\CVng\WEB-INF\classes\com\cisco\nm\cvw\devpkgs>


Other packeges accepted good (for example 3800 package).

What are the problems?

Thanks in advance

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Joe Clarke Thu, 06/07/2007 - 06:12

At what percentage are the devices in DFM? This can be seen under DFM > Device Management > Rediscover/Delete.

Please provide your psu.log for the CiscoView problem. For whatever reason the packages are not properly installing.

rromashko Thu, 06/07/2007 - 06:27

I can`t understand what percentage do you mean. Here DFM > Device Management > Rediscover/Delete I see 149 learning devices and 1 questioned. All=150.

psu.log is attached

Joe Clarke Thu, 06/07/2007 - 06:33

Pick one of the devices in a learning state, and look in the right-hand pane. You will see a percentage.

What version of the Cat2960 package is reported as installed for CiscoView under Common Services > Software Center > Device Update (click the CiscoView link, and search for Cat2960).

rromashko Thu, 06/07/2007 - 06:41

IP Address =

DNS Name =

Device Status = Learning

Device Type = N/A

Aliases = N/A

Containments = N/A

DFM Processing = N/A

Time Last Discovered = N/A

Import Time Stamp = 04-Jun-2007 16:54:07

*** Data Collector Status Information ***

Discovery Progress = 10% completed

Error Code = N/A

Error Message = N/A

Try to install package for 2800, here is an error that CiscoView answered:WARNING : Rtr2800(8.0):Consistency check failed for base package NGMARShare

CiscoView under Common Services > Software Center > Device Update

there is no 2960; package instaled but don`t appeare in any directory.

Joe Clarke Thu, 06/07/2007 - 06:52

10% does point to a problem with DfmServer. It looks like DFM thinks the current hostname is "lms" so I assume that is correct. If so, disable DFM auto-manage under DFM > Device Management > Device Selector, then delete, all the devices in DFM, and try adding one or two back to see if they go into a managed state.

How did you install the 2960 CiscoView package. Note: this Rtr2800 error is a known problem with the current package set on Cisco.com.

rromashko Fri, 06/08/2007 - 00:35

DFM > Device Management > Device Selector

here is the message:"All devices in the Device Credentials Repository (DCR) are in DFM." and table is empty.

2960 CiscoView package I installed with Software Center> Device Update>C:\psu_download

localy from server.

Note: this Rtr2800 error is a known problem with the current package set on Cisco.com.

Is it mean that I willn`t see my 2801 devices in CisoView?

Joe Clarke Fri, 06/08/2007 - 04:22

What you then need to do is uncheck the auto-manage checkbox, then apply. Then you can delete devices from the Rediscover/Delete interface.

I don't see any indication that the 2960 package was installed which makes me thing this 2800 error is preventing that from happening. Try reinstalling all of the available CiscoView packages from Cisco.com EXCEPT the Rtr2800 package, and see if that helps.

The Rtr2800 problem is being fixed. Once it is, you will be able to download and install that package. If you do not already have a version of the Rtr2800 package installed, then you will not be able to view your 2801 in CiscoView until this is fixed.

rromashko Fri, 06/08/2007 - 06:01

Rtr2800.cv50.v8-0.zip - downloaded from cisco.com. I can`t see any pathes or fixed updates for 2800 for CiscoView 6.1.5. cisco.com offer only nmidb.1.0.088.zip, but I don`t understand how to intall it.

in Server>Admin>Processes I see DFMCTMStartup -- Administrator has shut down this server . May be it is a reason of DFM poor working? cause Delete and rediscovering didn`t help.. I removed "Synchronize with Device Credential Repository" from Device selector.

Joe Clarke Fri, 06/08/2007 - 06:06

Don't do anything with Rtr2800 now. It is temporarily broken. Focus on getting the Cat2960 package installed which should work for you.

DFMCTMStartup is okay to be down. I recommend you open a TAC service request so additional debugging can be done on your DFM problem.

rromashko Fri, 06/08/2007 - 06:18

the most interesting thing is that noone 2960 package (Cat2960.cv50.v3-0 or Cat2960.cv50.v2-0) don`t indicate any error. it`s just install but I cann`t see any file of package after installation.

Joe Clarke Fri, 06/08/2007 - 06:32

What are you selecting in the CiscoWorks GUI when it presents you the list of available package updates?

rromashko Fri, 06/08/2007 - 06:41

CiscoWorks GUI presents me Cat2960.cv50.v3-0 or Cat2960.cv50.v2-0 or Rtr2800.cv50.v8-0.zip.

All of this packages was downloaded by me from cisco.com and placed to psu_dowload directory.

Joe Clarke Fri, 06/08/2007 - 07:09

Okay, good. On the next screen, you need to select "Install Device Packages". Then finish the flow. At this point, the package will be downloaded, and installed, then the daemons will be restarted. Once you are able to login again, check the Common Services > Software Center > Activity Log > Event Log and look at the last entry. That should tell you what happened with this installation.

rromashko Fri, 06/08/2007 - 07:28

Of course, I looked at Event Log.. It says that everything ok and package was installed successfully.

Joe Clarke Fri, 06/08/2007 - 07:32

Then additional PSU debugging needs to be enabled. You should open a TAC service request for this. As a workaround, you can manually download the latest Cat2960 package, rename it to "Cat2960.zip" and copy it to both NMSROOT/MDC/tomcat/webapps/CVng/WEB-INF/classes/com/cisco/nm/cvw/devpkgs and NMSROOT/www/classpath/com/cisco/nm/xms/psu/pkgs/cvw then restart dmgtd. Of course, if you do this, future troubleshooting will not be effective.

rromashko Mon, 06/11/2007 - 02:29

Hi, Joe!

I did the same action before: rename it to "Cat2960.zip" and copy it to both NMSROOT/MDC/tomcat/webapps/CVng/WEB-INF/classes/com/cisco/nm/cvw/devpkgs;

but I don`t Know about this folder NMSROOT/www/classpath/com/cisco/nm/xms/psu/pkgs/cvw

It works!!!

Now I can see Cat2960 in CiscoView!

In DFM everything ok also! Now I have only 2 learning devices (40%), I think it`s for a while.

THANK YOU so much!

But what I have to do with 2800 patch for CiscoView to see router 2801 there?

rromashko Mon, 06/11/2007 - 05:23

it`s ok!

I solved all problems for that moment.

thanks for all, Joe!

smandrapa Fri, 09/07/2007 - 05:36

Same problem with DFM, devices in learning state ! Problem is not solved.


This Discussion