CSA Report Viewing ActiveX problem IE7

Answered Question
Jun 7th, 2007
User Badges:

When I am trying to run the reports in CSA they work fine, in HTML format. However when I am trying to view them in activeX, it comes back on IE7, telling me it cannot access the resource and that I need to install IE4 and DCOM for windows 95. I am sure that I am simply over looking something. Suggestions?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
tsteger1 Thu, 06/07/2007 - 09:43
User Badges:
  • Red, 2250 points or more

What version of CSA? Might just need to clear cookies...

cdillon12 Thu, 06/07/2007 - 10:13
User Badges:

CWCS Foundation 2.2 3-16-2006 17:35:30 ENABLED

Management Center for Cisco Security Agents V5.0 5.0 5-24-2006 09:55:18 ENABLED

Monitoring Center for Performance 2.0.2 3-16-2006 17:35:30 ENABLED

Monitoring Center for Performance 2.0.2 3-16-2006 17:35:30 ENABLED

IPS MC 2.2 3-22-2006 16:50:51 ENABLED

Security Monitor 2.2 3-22-2006 16:50:51 ENABLED

Management Center for Firewalls 1.3 3-16-2006 17:35:31 ENABLED

Router-MC 1.3.1 3-16-2006 17:35:31 ENABLED


tsteger1 Thu, 06/07/2007 - 12:44
User Badges:
  • Red, 2250 points or more

Did you try clearing the cookies? It worked when I had problems displaying items before.


I think the IE7 problem is different though and I noticed it after the last Cumulative IE update.

cdillon12 Thu, 06/07/2007 - 12:51
User Badges:

Yes. IE7 / Tools / internet options / general tab / browsing history / delete / Cookies and Temp Interent files.


The exact error message I get, when I click view report. A new window opens, I get a pop up and it says...


"The Seagate ActiveX viewer is unable to create it's resource objects. To rectify this problem, please install Internet Explorer 4.0 or install DCOM for Windows 95 and the latest Microsoft Scripting Engine. These files are available at Microsoft's web site."


I click OK, and it pops right back up again, forcing me to end task on the process. This is not just my PC but all of the IE7 PC's that I am using. I would use Firefox however, I am unable to "print" the report in the HTML formats.


Thanks again for your time and efforts on this issue.

cdillon12 Thu, 06/07/2007 - 14:02
User Badges:

You sir.. are fantastic!!! RESOLVED - Solution :


To Resolve:


1. Open up Internet Explorer 7

2. From the Tools menu, select Internet Options

3. From the new popup window, select the Security tab

4. Ensure that you highlight Internet

5. Click on the button named Custom level

*The Security Settings menu will now come into view*

6. Scroll down the settings until you reach "ActiveX controls and plug-ins"

7. Ensure the settings are as below -


Allow previously unused ActiveX controls to run without prompt

Enable


Allow Scriptlets

Disable


Automatic prompting for ActiveX controls

Enable


Binary and script behaviours

Enable


Display video and animation on a web page that does not use external media player

Disable


Download signed ActiveX controls

Prompt


Download unsigned ActiveX controls

Disable


Initialize and script ActiveX controls not marked as safe for scripting

Disable


Run ActiveX controls and plug-ins

Enable


Script ActiveX controls marked as safe from scripting*

Enable


Please ensure that you click OK, once finished ? to save


tsteger1 Thu, 06/07/2007 - 14:10
User Badges:
  • Red, 2250 points or more

Glad to help.. Please do the checkbox thingy on the solution so that others may see it as a solution.


Tom

Actions

This Discussion