SIP phones cannot register accross vlan

Unanswered Question
Jun 7th, 2007

My Call Manager Express 2801 is connected to a Catalyst on vlan 20; dhcp server is on vlan 10; if I plug the phone on the same vlan with 2801, it registers fine; if it's from a different vlan, the phone cannot register.

with "debug ccsip messages", I don't have any trace regarding to registration.

Using Ethereal, I capture the traffic on the port where 2801 is connected to. I see the registration request and response from 2801 says "401, unauthorized"

Please advise. Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Paolo Bevilacqua Thu, 06/07/2007 - 15:25

Hi,

with CCME, when a SIP phone is on a different subnet, it requires user authentication to register. At that point, the mac address that you configure under "voice register pool" becomes irrelevant. So you should configure username/password for the phone, and under "voice register pool".

If you use SCCP instead, there is no problem and the phone will register from any subnet local or remote.

Hope this helps, please rate post if it does!

junwu_key Fri, 06/08/2007 - 05:08

Thanks.

It makes a lot of sense. I actually have tried this, but it still does not work. I also tried upgrade the phone firmware. It still behavies in the same manner.

It raise another question: ideally I would like to register third party VoIP devices to CME as well and they will all be on different subnet. Will this work?

Thanks again.

Paolo Bevilacqua Fri, 06/08/2007 - 05:49

Hi,

I'm not sure why is not working for you. You said that you tried "debug ccsip message" but nothing shows, I assume you have "term mon" and logging monitor enabled ?

Yes, third part SIP phones will register without problems from any subnet, once you configure username and password.

junwu_key Fri, 06/08/2007 - 07:00

You are right. "term mon" was off.

I am using CME 4.0 on top of IOS 12.4(4)XC6.

If I create username and password under voice register pool, should I enable authentication is voice register global?

What else can go wrong?

You advice is highly appreciated!!!

Paolo Bevilacqua Fri, 06/08/2007 - 07:11

I have SIP phones registering OK without "authenticate" under "voice register global". The purpose of it, is mainly to define a realm.

Useful post? Please rate it using the scrollbox below!

junwu_key Fri, 06/08/2007 - 07:18

Thanks for your quick response.

Just notice a new thing: I have two phones. 8002 on the same subnet with CME; 8001 on a different subnet. 8002 shows as registered but not 8001.

"show voice register pool 1" (for 8001 on different subnet) show one active registration.---This is wroing'cause must be not expired yet.

Interesting thing is call from 8001 to 8002 is ok; call from 8002 to 8001, after dialing the number, I hear nothing...

Please tell me what's wrong?

Paolo Bevilacqua Fri, 06/08/2007 - 08:35

Hello,

I think, after you configure username and password, and generate the configuration files, these should go in the xml file for the phone, that you can examine, try "show voice register tftp-bind". Is the phone completing the tftp process? Try "debug tftp event".

Beside that, it is normal for an unregistered phone to be able to place calls but not receive.

junwu_key Fri, 06/08/2007 - 08:45

I have the following lines as output of "show voice register tftp-bind":

tftp-server SIPDefault.cnf url system:/cme/sipphone/SIPDefault.cnf

tftp-server syncinfo.xml url system:/cme/sipphone/syncinfo.xml

tftp-server SIP0017957DD50E.cnf url system:/cme/sipphone/SIP0017957DD50E.cnf

tftp-server SIP000F8F28E2A9.cnf url system:/cme/sipphone/SIP000F8F28E2A9.cnf

Yes, the phone is running tftp process.

Not registered phone does not need to locate the location of other phones in order to call?

What if the registered phone moved?

Thanks,

Paolo Bevilacqua Fri, 06/08/2007 - 08:52

Hi,

I would examine the files "more " and see if the authentication files are there.

Registration and placing calls are two separate things in SIP. You don't need the first for the latter.

If you want your phones work no problems, convert to SCCP.

Hope this helps, please rate post if it does!

junwu_key Fri, 06/08/2007 - 08:56

I think yes. Authentication is in the file.

Can you explain why I can place call without registration? The phone needs to know the URI of the other party.

Paolo Bevilacqua Fri, 06/08/2007 - 09:40

In XML files, there is a "processNodeName" tag with address in the configuration file and that is enough to place calls. In CNF files, there is "call_manager1_addr".

Actions

This Discussion