IdleURL Not Showing Extensions

Unanswered Question
Jun 7th, 2007

I have the idleurl asp code from the most recent sdk working on my phone. However unlike the screenshot, the extensions on the right side are not showing up. (The little phone next to the button is showing thereby noting that I have a phone line), yet the number is not showing up.


I have looked through the code and cant find anything (I even looked through the includes but all looks ok there as well.) The devicelistx.asp seems to be available (I browsed to it without a problem.


Any help or guidance would be great.


Thanks,


michael

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
stephan.steiner Fri, 06/08/2007 - 03:44

Well, I guess the time has come to debug the idleurl.asp page ;) A quick look reveals quite a few things that can go wrong.


E.g. you need to configure the CCM IP and the administrator login and password. If those are wrong, forget about the extensions showing up.


Then you'll see that the document does a POST to the ccm and sends a getPhone, then looks for the lines and speeddials and further descends into getLine for each line found.


So, either you start the debugger, or as a pre-emptive step, run ethereal on your webserver to see the communication with the call manager.. perhaps it'll already show you what's going wrong.

fremenusul Fri, 06/08/2007 - 06:26

Thanks for the response.


The ccm password, et al is all correct. Could it be the axlquery include? Again, I have looked over the code and not seen any problems. Also, what debugger do you use?

stephan.steiner Mon, 06/11/2007 - 01:17

Hmm... debugging ASP. I wonder why the majority of people here writes/tries to write ASP scripts but has no idea about debugging those scripts ;)

Keep in mind that website wise I'm an ASPX/JSP guy but I think Visual Studio also does ASP. Back in the day, I tried to help myself with print statements, but that is really cumbersome so that the time /money spent to get a decent IDE is well invested.

By the way, google is also pretty good at figuring out how to debug an ASP: http://www.google.ch/search?hl=de&q=debugging+asp+pages&btnG=Google-Suche&meta=


Also keep in mind that Cisco's samples are not production ready.. they might work but they lack the error handling and logging to make them stable and help you figure out what is going wrong when something goes wrong. Hence, you shouldn't deploy those apps but instead write your own and using the SDK apps as templates.

Actions

This Discussion