Point to Point Help

Unanswered Question
Jun 8th, 2007
User Badges:

I have a new point to point t1 and am having trouble.

I can ping from both routers (both 1800's) to the serial ip of the other but am not able to ping to the lan on the other side. A trace shows it going to the serial interface of the distant router and stopping there.

Here is router A's

ontroller T1 0/0/0

framing esf

linecode b8zs

channel-group 0 timeslots 1-24

!

!

interface FastEthernet0/0

description $ETH-SW-LAUNCH$$INTF-INFO-FE 0$$ES_LAN$$FW_INSIDE$$ETH-LAN$

ip address 192.168.0.245 255.255.255.0

ip access-group Any in

ip access-group Any out

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

duplex auto

speed auto

no mop enabled

!

interface FastEthernet0/1

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

shutdown

duplex auto

speed auto

no mop enabled

!

interface Serial0/0/0:0

no ip address

ip access-group Any in

ip access-group Any out

encapsulation frame-relay

no keepalive

!

interface Serial0/0/0:0.1 point-to-point

ip address 192.168.254.1 255.255.255.0

ip access-group Any in

ip access-group Any out

no ip redirects

no cdp enable

frame-relay interface-dlci 100

router rip

network 192.168.0.0

network 192.168.254.0

no auto-summary

!

ip classless

!

ip http server

ip http authentication local

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip access-list extended Any

remark SDM_ACL Category=1

permit ip any any

!

logging trap debugging

access-list 1 remark SDM_ACL Category=2

access-list 1 permit 192.168.0.0 0.0.0.255

disable-eadi

no cdp run

!

control-plane

Router B's config


Current configuration : 2967 bytes

!

version 12.4

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service sequence-numbers

!

hostname admin1800

!

boot-start-marker

boot-end-marker

!

security authentication failure rate 3 log

security passwords min-length 6

logging buffered 51200 debugging

logging console critical

no aaa new-model

!

resource policy

!

clock timezone PCTime -7

clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

no ip source-route

ip cef

!

!

ip tcp synwait-time 10

no ip dhcp use vrf connected

!

!

ontroller T1 0/0/0

framing esf

linecode b8zs

channel-group 0 timeslots 1-24

!

!

interface FastEthernet0/0

description $ETH-SW-LAUNCH$$INTF-INFO-FE 0$$ES_LAN$$FW_INSIDE$$ETH-LAN$

ip address 192.168.100.252 255.255.255.0

ip access-group any in

ip access-group any out

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

duplex auto

speed auto

no mop enabled

!

interface FastEthernet0/1

description $ETH-LAN$

ip address 192.168.0.201 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip route-cache flow

shutdown

duplex auto

speed auto

no mop enabled

!

interface Serial0/0/0:0

no ip address

ip access-group any in

ip access-group any out

encapsulation frame-relay

no keepalive

!

interface Serial0/0/0:0.1 point-to-point

frame-relay interface-dlci 100

!

router rip

network 192.168.100.0

network 192.168.254.0

no auto-summary

!

ip classless

!

ip http server

ip http authentication local

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip access-list extended any

remark SDM_ACL Category=1

permit ip any any

!

logging trap debugging

access-list 1 remark SDM_ACL Category=2

access-list 1 permit 192.168.0.0 0.0.0.255

access-list 2 remark SDM_ACL Category=2

access-list 2 permit 192.168.0.0 0.0.0.255

access-list 100 remark SDM_ACL Category=1



i am sure it is something stupid I am doing.

Any help would be welcome


Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Paolo Bevilacqua Fri, 06/08/2007 - 14:49
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hello,


you have a point-to-point T1, hence you don't need frame relay encapsulation. Please configure on both routers::


no interface Serial0/0/0:0.1 point-to-point


interface Serial0/0/0:0

ip address 192.168.254.1 255.255.255.0 <- use .2 for the router B

no ip access-group any in

no ip access-group any out

encapsulation hdlc

keepalive 10


And you should be able to ping and connect fine. Also I suggest you quit using SDM because most of the time will do things wrong, or in manner that you don't understand, beside it will hide the configuration logic from you.


Hope this helps, please rate post if it does!

thotsaphon Sat, 06/09/2007 - 01:29
User Badges:
  • Gold, 750 points or more

What is device that you used for testing connection?

Can you do show ip route command of both routers?


L.Thot

Edison Ortiz Sun, 06/10/2007 - 12:41
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

I will be very careful suggesting to remove frame relay.


If he is able to ping the remote-end, the encapsulation is valid and the DLCIs assigned to each end are also valid. A 'show frame pvc' would be ideal before pulling the trigger on that.


Seeing his RIP config may be the suspect here and he may be facing a split horizon issue with RIPv1.


I suggest configuring RIPv2 for classless support.


Matt, can you supply a show ip route from both ends ?

Paolo Bevilacqua Sun, 06/10/2007 - 16:11
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hello, please check posted config above for serial on router B, there is no IP address whatsoever, I'm not sure what he is pinging, but on my book, interface without IP address == no ip routing on that interface.

Edison Ortiz Sun, 06/10/2007 - 19:14
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

I did check the posted config but to suggest removing frame relay is a bit drastic without examining the routing between the 2 routers.


As Richard pointed out, this config is not complete and we need more info.

mohammedmahmoud Sat, 06/09/2007 - 01:51
User Badges:
  • Green, 3000 points or more

Hi,


I agree with every word Paolo has said, but please supply us with a show ip route to find out the reason behind your connectivity issue, and another thing "admin1800" shows inconsistent configuration for Serial0/0/0:0.1, can you confirm this or if it is a typo error.



HTH,

Mohammed Mahmoud.

Richard Burts Sun, 06/10/2007 - 16:18
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

I see several issues in the configs as posted. routerA has network 192.168.0.0/24 on interface FastEthernet0/0 and routerB has network 192.168.0.0/24 on interface FastEthernet 0/1. Unless the routers are connected on the FastEthernet segment this is a serious error (or a major typo). As configured routerA will never go to routerB for that network and routerB will never go to routerA for that network since both routers believe that the network is locally connected.


There is also an issue on routerB about the serial interface which does not have an IP address assigned in the config as posted. I note that there is a network statement in RIP for the 192.168.254.0 network which suggests that perhaps omitting the IP address was an oversight. Since the original post says that the routers can ping over the serial interface I would assume that this is just a mistake in posting.


Perhaps the original poster can clarify these issues.


HTH


Rick

mattbashara Tue, 06/12/2007 - 08:29
User Badges:

Thanks every one for the help. I have it working now.


If any one is interested I would be happy to post the new config files. Let me know.

Paolo Bevilacqua Tue, 06/12/2007 - 08:34
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

If the posts helped, please take a moment to rate them using the scrollbox below.

Actions

This Discussion