Cisco CallManager, DBHelper and missing subscribers

Unanswered Question
Jun 10th, 2007

Hello all!

On our CallManager system, two of our three subscribers don't appear when

running DBHelper.

However, according to ms-sql enterprise manager they are replicating just

fine.

Is there any way of getting the missing subscribers back into DBHelper?

Regards

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
espereir Sun, 06/10/2007 - 11:21

Hello Steven,

Are those subscribers on the CCMAdmin Server page? Or on the CCM or CCM Group?

DBLHelper takes the data from the subscriber table, you should check if you have added the server on the Pub and btw, are you running the DBLHelper from the right folder?

What happen if you manually delete and then add the SQL subscriptions with the SQL Enterprise Manager?

Thanks!

stevencoutts Sun, 06/10/2007 - 11:59

Yes the subs show up on the CCMAdmin Server page.

What folder should DBLHelper be run from?

I have tried removing and adding a server to SQL replication and it doesn't help!

Regards

mchandak Sun, 06/10/2007 - 12:28

Sounds like a DB issue and you might want to involve TAC to get this resolved as if the issue is with DB entry for the subscriber is it not recommended to play with it without TAC Assistance.

Also, check the DBLHelper logs (Attach it to the form if possible) to see what is happening with DBLHelper. You can find this file at C:\Program Files\Cisco\Trace\DBL

Jason Aarons Sun, 06/10/2007 - 16:27

Place dblhelper.exe in the bin folder under the c:\program files for callmanager

gogasca Sun, 06/10/2007 - 19:31

As Mahesh explained it is highly recommended to open a TAC case for this.

If you go to CCMAdmin | Service Parameters | Database Layer Monitor | Advanced

For those servers missing...are you able to see anything under:

Database Connection String

If no info is there...this is the case where some DB entries are missing and needs to be pulled from DB Logs and inserted into DB again...or a reinstall if during DB installation some PKID were not created...this require TAC Assistance.

Flemming Ortvald Wed, 12/05/2007 - 04:12

I'm encountering same problem, newly added subscriber missing from "dbhelper" and giving "?" in "AdminUtility" for database-access for all but the first account.

Are there any more precise actions that can be taken?

Tried adding "DBConnection2" in registry, but no change.

Can this be resolved without reinstalling subscriber server?

Any help much appreciated.

espereir Wed, 12/05/2007 - 07:17

Since the DBLHelper is not showing the subscriber, my advise will be to install the Upgrade Utility and execute it just to see if you get any errors; if you have some, go to SQL and execute this query:

SELECT *

FROM ProcessConfig

WHERE (ParamName LIKE '%dbc%')

This will return the dbconnections; you should have as many entries as CallManager servers; notice that the DSNs are exactly the same that we have on the registry.

If one of the server entries is missing, we will need to manually add it and we will need th results of these queries:

------------------

SELECT *

FROM ProcessConfig

WHERE (ParamName LIKE '%glas%')

------------------

SELECT *

FROM ProcessConfig

WHERE (ParamName LIKE '%dbc%')

------------------

SELECT *

FROM CallManager

------------------

SELECT *

FROM ProcessNode

kurtdeneef Tue, 06/17/2008 - 21:54

Hi,

Although my servers are well displayed in the DBLHelper tool,my publisher has a red icon in the SQL replication tab

However,if i take a look in the traces,this is what i see:

/13/2008 00:13:01.003 HELPER| CNameResolution::DisplayGrid 172.16.0.11 CALLMANAGER2 0ms 0ms CALLMANAGER2 172.16.0.11 CALLMANAGER2

06/13/2008 00:13:01.003 HELPER| CNameResolution::DisplayGrid 172.16.0.10 CALLMANAGER1 0ms 16ms CALLMANAGER1 172.16.0.10 CALLMANAGER1

06/13/2008 00:13:01.003 HELPER|<--CNameResolution::DisplayGrid

06/13/2008 00:13:05.268 HELPER|-->CReplication::GetDatabaseReadWrite

06/13/2008 00:13:05.268 HELPER|-->CReplication::MakeDSN

06/13/2008 00:13:05.268 HELPER| CReplication::MakeDSN DSN=CiscoCallManager;SERVER=CALLMANAGER1;DATABASE=CCM0300;Trusted_Connection=yes

06/13/2008 00:13:05.268 HELPER|<--CReplication::MakeDSN

06/13/2008 00:13:05.268 HELPER| CReplication::GetDatabaseReadWrite Get connection

06/13/2008 00:13:05.284 HELPER| CReplication::GetDatabaseReadWrite select pkid,systemNode from ProcessNode

06/13/2008 00:13:05.284 HELPER| CReplication::GetDatabaseReadWrite update ProcessNode set systemNode=1 where pkid='00000000-1111-0000-0000-000000000000'

06/13/2008 00:13:05.284 HELPER|-->CReplication::MakeDSN

06/13/2008 00:13:05.284 HELPER| CReplication::MakeDSN DSN=CiscoCallManager;SERVER=CALLMANAGER2;DATABASE=CCM0300;Trusted_Connection=yes

06/13/2008 00:13:05.284 HELPER|<--CReplication::MakeDSN

06/13/2008 00:13:05.284 HELPER| CReplication::GetDatabaseReadWrite Get connection

06/13/2008 00:13:05.300 HELPER| CReplication::GetDatabaseReadWrite select pkid,systemNode from ProcessNode

06/13/2008 00:13:05.300 HELPER| CReplication::GetDatabaseReadWrite update ProcessNode set systemNode= where pkid=''

06/13/2008 00:13:05.315 HELPER| CReplication::GetDatabaseReadWrite *ERROR* Error executing "update ProcessNode set systemNode= where pkid=''": [Microsoft][ODBC SQL Server Driver][SQL Server]Incorrect syntax near the keyword 'where'.

06/13/2008 00:13:05.315 HELPER|<--CReplication::GetDatabaseReadWrite

06/13/2008 00:13:05.315 HELPER|-->CReplication::GetDBConnection0

06/13/2008 00:13:05.315 HELPER| CReplication::GetDBConnection0 ServerName: [CALLMANAGER1] temp: [CALLMANAGER1] before

06/13/2008 00:13:05.315 HELPER|-->CReplication::GetHighestCCMDatabaseName()

06/13/2008 00:13:05.315 HELPER| CReplication::GetHighestCCMDatabaseName() Connect

06/13/2008 00:13:05.347 HELPER| CReplication::GetHighestCCMDatabaseName() DBName=[CCM0300]

06/13/2008 00:13:05.347 HELPER|<--CReplication::GetHighestCCMDatabaseName()

06/13/2008 00:13:05.347 HELPER| CReplication::GetDBConnection0 Highest Database: [CCM0300]

06/13/2008 00:13:06.003 HELPER|-->CNameResolution::GetWinsockStatus

06/13/2008 00:13:06.003 HELPER| CNameResolution::GetWinsockStatus getHostByName CALLMANAGER2

So it looks like the ODBC connection to Callmanager1 (publisher) is always working fine but the one to Callmanager2 is failing 3 or 4 times during "republish" and that's why i get the red icon.

During the trace,i can only see this error 3 or 4 times but i suppose it implies the failure of the sql replication.

Is my statement true?

What to do about?

manually re-add something again?

Thanks for some advise

Kind regards,

Kurt

espereir Wed, 12/05/2007 - 08:39

From the Enterprise Manager or Query Analyzer; use the CCM030X database.

Actions

This Discussion