AXL with VMWARE doesnt work

Unanswered Question
Jun 10th, 2007
User Badges:

Hi people,


I am trying to test axl applications in a callmanager (ver. 5.1.1.2000-2) running inside a vmware. The PC is an Windows XP Pro, core2duo with 2G memory.

I have tried to run the java example illustrated in the Developers Guide for Release 5.0, but it returns nothing, in fact, returns special caracters "".

I also have tried with php and returns the same thing.

The java code is attached here.

Is my code correct?

The PC is running with IIS, PHP 5 and Netbeans 5.5 with JDK 1.6.

The PC has IP 10.1.1.100, the callmanager inside the vmware has IP 10.1.1.1. The files are in the PC, and when I call them, I got the error above described.

Any one got the same problem?

Can any one post a correct example?


Thanks.



Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Sascha Monteiro Mon, 06/11/2007 - 13:24
User Badges:
  • Silver, 250 points or more

Hi,


You cannot just open a socket to a secure connection (HTTPS)

have a look at the axlsqltoolkit, it has an example of how to connect.

toshiosakata Wed, 06/13/2007 - 09:21
User Badges:

Hi Monteiro,


Finally it works.

Is possible to update an registry ou only query the database?

Some thing like:


update device set description='abcde' where pkid='089d9f80df98fdf'


I have triend this and I got the following response:

http://schemas.xmlsoap.org/soap/envelope/">



SOAP-ENV:Client

Method only for queries


http://www.cisco.com/AXL/1.0">-79750

Method only for queries

executeSQLQuery







Thanks!

Sascha Monteiro Wed, 06/13/2007 - 13:28
User Badges:
  • Silver, 250 points or more

I am not sure how you can update via executesqlquery

(you couldn't in cm4.x)

It's better to do a updatePhone via AXL

toshiosakata Wed, 06/13/2007 - 18:12
User Badges:

Hi Monteiro,


Can you give me a example using updatePhone?


Thank you.

Sascha Monteiro Wed, 06/13/2007 - 18:20
User Badges:
  • Silver, 250 points or more

did you access the AXL schema?


>

SEP0000AABBCCDDThis is a test


stephan.steiner Thu, 06/14/2007 - 23:57
User Badges:
  • Silver, 250 points or more

In CCM 5.x and higher you can use executeSQLUpdate to update the database (insert, update or delete) - there is no equivalent in CCM 4 and lower.

toshiosakata Fri, 06/15/2007 - 04:11
User Badges:

Hi Stephan,


You are right!

The axlsqltoolkit example for CCM 5.1 works with executeSQLUpdate.


Thanks!


Also thanks to Monteiro.

Actions

This Discussion