H323 to SIP IPIP Gateway problem

Unanswered Question
Jun 10th, 2007
User Badges:

Hi,


I have setup as below;


CME--> H323 --> IPIPGW --> SIP --> CCM


When i initial a call from CME phone to CCM phone, the phone at CME just keep on ring out even when the phone at CCM side pick up, my dial-peer config as below;


CME


dial-peer voice 100 voip

destination-pattern [12]...

session target ipv4:10.100.1.1 (IPIPGW)

dtmf h245-alphanumeric


IPIPGW


voice service voip

allow-connection h323 to sip

h323

sip


dial-peer voice 100 voip

incoming number [12]...

dtmf h245-alphanumeric


dial-peer voice 101 voip

destination-pattern [12]...

session protocol sipv2

session target ipv4:10.100.1.10 (CCM)

codec g711uw

dtmf rtp-nte


the codec transcoding is working fine


did i miss out anything here?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
jcastilloz Fri, 07/13/2007 - 13:24
User Badges:

Hi,


Try configuring "h225 connect-passthru" under h323.


regards

markus.thelen Sun, 07/29/2007 - 05:11
User Badges:

I?ve the same problem. I?m doing the situation vice versa. Call coming from CME via SIP to IPIP-Gateway and going to H323 to CCM. The CCM phone rings, but when I go offhook, the CME phone does not get connected, but stays in ring-out state. The h225 connect-passthru on the IPIP-Gateway did not help?

Any other ideas?

Thank you in advance.

Kind Regards, Markus

m.newbould Fri, 04/11/2008 - 02:55
User Badges:

Hi,


I have a similar problem to this. Our customer is using a Mitel environment using SIP, and wish to connect to other sites which are using CCM 4.1. The topology is:


Mitel -> SIP -> IPIPGW -> H323 -> IPIPGW(GK) ->H323 ->IPIPGW -> CCM4.1(h323)


I get the same issue in my test lab. When I dial from the SIP environment to the CCM, the CCM Phone rings. When I answer the CCM Phone, I get silence, but the Mitel handset continues to play ringback. I have configured as per this document and it does fix the problem... HOWEVER, in the customer environment I have no control over the CallManager side, and they are unwilling to enable faststart as they are using Video and it causes problems...


Is there any way I can make this work without enabling faststart on the CCM Gateway configuration?


Any help would be greatly appreciated.


Regards


Mark.


ryan_oconnell Mon, 07/14/2008 - 11:41
User Badges:

Hi Mark,


I'm about to attempt the same thing with Mitel 3300 -> Sip -> IPIPGW -> h.323 -> CM.


Can you share some of your experiences and limitations of the integration if you came across any? Of course outside of the issue you posted above, which I assume you have sorted out by now.


Cheers ryan

m.newbould Tue, 07/15/2008 - 00:55
User Badges:

Hi Ryan,


The issue appears to be that the IPIPGW does not support H323 Slow Start to SIP Early Media Start and vice versa. It will only support like signalling methods when converting between SIP and H323 (although when reading Cisco documentation it depends which document you read :-).


I couldn't find anything in the SX3300 to force it to run SIP Delayed Media Start, so as a result I had to enable H323 Inbound Fast Start on the CallManager Gateway Configuration. This then did the trick, and I could make calls in both directions.


The strange thing is that this appears to be an IPIPGW issue, because if you connect the CCM to the SX3300 directly via a SIP trunk, without the IPIPGW in the middle, you can run calls in both directions without ticking the H323 Fast Start box in the CCM Gateway Config.


I have been meaning to put a sniffer on it to have a detailed look at what is happening, but other jobs have got in the way, so that hasn't happened as yet.


If you need any more information get back in touch.


Good luck!!


Mark.


Tommer Catlin Thu, 09/10/2009 - 10:54
User Badges:
  • Green, 3000 points or more

This worked for me! I had CUCM---h323-h323-pbx and the call was failing.


Unchecked and it worked!


Thanks!

Daniele Giordano Thu, 08/14/2008 - 09:14
User Badges:
  • Gold, 750 points or more

You can configure allow-connection sip to h323 too.


Is your IP2IP GW configured as RTP media gateway or no?

media flow-around | media flow-through

CCME use h323 fast start?

h323 call start {fast | slow}





m.newbould Thu, 08/14/2008 - 23:50
User Badges:

Hi


Yes I agree and I have had the IPIPGW running as a gateway between SIP and H323 and it does work. The problem is when you try running the CallManager in Slow Start, with the SIP PBX running Early Media Start or vice versa. The IPIPGW seems to have an issue working between the two variants. If I configure H323 Fast Start on the CallManager and SIP Early Media Start, it all works fine.


The original problem has been resolved as we are now running the CallManager in Fast Start, which works okay.


I have had no experience of this with CCME, so I can't comment on how this 'problem' affects that particular platform.


Best regards


Mark.



Actions

This Discussion