connecting LAN over T1

Unanswered Question
Jun 11th, 2007
User Badges:

Hello friends,

I have two offices to be connected over 3xT1 lines, I have placed router at both end, both routers are able to ping each other, but LANs are not connecting. my configuration is :

Current configuration : 1241 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname SL

!

boot-start-marker

boot-end-marker

!

no logging console

enable secret 5 XXXXXXXXXXXXXXXXXXXXXXX

aaa new-model

!

!

!

aaa session-id common

!

resource policy

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

ip cef

!

!

no ip dhcp use vrf connected

!

!

multilink virtual-template 1

!

username amar password 7 XXXXXXXXXXXXXXXX

!

!

!

interface FastEthernet0/0

ip address 192.168.3.1 255.255.0.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0

bandwidth 2048

no ip address

encapsulation ppp

pulse-time 3

ppp multilink

!

interface Serial0/1/0

bandwidth 2048

no ip address

encapsulation ppp

pulse-time 3

ppp multilink

!

interface Serial0/1/1

bandwidth 2048

no ip address

encapsulation ppp

pulse-time 3

ppp multilink

!

interface Virtual-Template1

ip unnumbered FastEthernet0/0

ppp multilink

!

ip classless



side B

ip add is : 192.168.2.1/16


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.3 (3 ratings)
Loading.
Paolo Bevilacqua Mon, 06/11/2007 - 02:47
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hello,


you are missing routing, either static or dynamic. Please pick a configuration example from CCO and apply.


Hope this helps, please rate post if it does!

spremkumar Mon, 06/11/2007 - 02:49
User Badges:
  • Red, 2250 points or more

Hi


Is it possible to readdress you ip addressing scheme?


If you can then you can change the local lan block to 192.168.3.0/16 or /24 even on one end and 192.168.2.0/16 or /24 at the other end..


Once you are done with this do change the ip address on the wan interfaces..


Instead of creating virtual template interface try creating interface multilink and bundle the physical links onto it..


Once you are done with the bundling and assigning the interfaces to it assign 10.1.1.1 on Side A and 10.1.1.2 on Side B..


Do make sure that you are assigning /30 as your subnet mask to the ip addressing scheme..


You need to add a reverse route for the respective lan blocks on both the ends so that you can have lan to lan reachability...


regds



Richard Burts Mon, 06/11/2007 - 05:20
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Amrendra


You have not given enough information for us to be sure what the issue is. You have given us the config of one router and 1 IP address from the other router. At a minimum we need to know what is the addressing of the LAN on the other router.


As was pointed out in a previous post there does not appear to be any static routes or any dynamic routing protocol in the config that you posted. Without either static routes or dynamic routing protocol the router will have no knowledge of how to reach the LAN of the other router, producing the symptoms that you describe.


At this point I would make a guess that the second router may also be using 192.168.0.0/16 on its LAN. If so this would be a problem. If router 1 believes that 192.168.0.0/16 is local then it will never send any traffic over the serial attempting to reach 192.168.0.0/16 on the other router.


HTH


Rick

Paolo Bevilacqua Mon, 06/11/2007 - 05:42
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi Rick,


Excellent answer, I rated a '5'. What a pity that in the scale of someone else, you risk a maximum rating of '2' :(

anandramapathy Mon, 06/11/2007 - 07:15
User Badges:
  • Bronze, 100 points or more

Hi,


as quoted earlier change the subnet masks of both the ckts to /24



192.168.1.0/24

192.168.2.0/24


Then run configure a routing protocol like EIGRP on both the routers.


router eigrp 1

network 192.168.1.0

network 192.168.2.0

re-distribute static



HTH - rate as useful posts


amrendraks Tue, 06/12/2007 - 00:44
User Badges:

Hello Anand,

It really worked, but one more problem I am facing is , this is network of 1.0/24 is able to communicate to 2.0/24.

But I have 10.0/24, or 40.0/24 as LAN their on other sides, how can they ping to 2.0/24 or 1.0/24. ?


Thanks.

anandramapathy Tue, 06/12/2007 - 01:31
User Badges:
  • Bronze, 100 points or more

How are they being routed ? what is the conenction between the gateways 192.168.10.1 & 192.168.40.1 & the two routers for which you have pasted configs ?


Also note - That in future if you want more thant 255 hosts, you will have to change the subnet mask for the 192.168.2.0 & 192.168.1.0 network.


If you feel they will not scale it is ok else change it to say 192.168.1.0 / 255.255.240.0 & 192.168.2.0 / 255.255.240.0 right away






Anand Narayana Tue, 06/12/2007 - 02:28
User Badges:
  • Silver, 250 points or more

Hello Amerandra Kumar,

what you can do is, juz configure the 192.168.10.1/24 ip address on fas 0/1 interface on Router A & on Router B fas 0/1 configure the ip address as 192.168.20.1/24, & give the gateway to the PC, your problem will be solved.

Actions

This Discussion